Can No Longer Login to TIDAL

Core Machine (Operating system/System info/Roon build number)

Roon Rock
Roon Version 1.7
Build 571

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon Rock connected via ethernet. iMac Connected via ethernet. Various iOS devices connected via WAP.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

iMac via ethernet.

Description Of Issue

Hi all,

I have 2 separate annual subscriptions to Roon and two Roon Rocks (Intel NUCs). One for the house and one for our recording studio. Up until a few weeks ago, both were accessing my TIDAL account just fine. However, now that we are in phase 4 in upstate NY, I was able to access the studio again and have been trying for about a week to get Roon working again. The issue is, no matter what I do, I cannot login to TIDAL at the studio.

I have tried from an iOS device and from the Roon on the iMac. The behavior is the same in both cases. In Roon I go to add the TIDAL account, Roon kicks it over to the browser, login to Tidal successfully and the browser re-directs back to Roon and…nothing happens. Roon just sits there saying that I need to login to TIDAL.

Also, I can see in Roon, that in the About tab under the Core section it’s saying ‘There was an error checking for an update’. Maybe TIDAL changed the way logins are authenticated and I need an update from Roon but for some reason I’m not able to get it?

I’m sort of at my technical limits of understanding networking and libraries and things. Is anyone else having this issue? Can someone from support help walk me through what might be happening?

Thanks so much,


1 Like

Hi @Wade_Strange,

If your Core machine is not up to date that could definitely be causing some issues. Can you share a screenshot of the Web UI?

Have you tried giving the ROCK machine a reboot?

Hi Dylan,

Yes, rebooted the ROCK machine and the iMac many, many times. Everything seems to work right up until the point where the web browser should redirect me back to the Roon app. Roon just sits there and there is no change or update.

Attached please find a screen shot of the web UI.

Thanks so much for any help you can offer.


@Wade_Strange seems perhaps your DHCP server might have some issues… your subnet mask is likely meant to be not with the 254 as the 3rd octet and also I would suggest you also have your DHCP server add the router address and a public one or

If you can’t fix those then maybe set a dhcp reservation and use fixed IP address and manually correct the subnet mask and DNS’s - but if you DHCP server is giving the correct subnet mask then definitely add the public DNS servers at least.

NOTE that subnet mask would give a class C network of 512 addresses FYI and maybe your network admin has this right (as you have an IP of and a gateway of …or maybe its a typo

While not so common, the settings are valid. With a mask of, both and are considered part of the same local network.

With that said, even if just one device along the chain has something else (incorrectly) set, or the DHCP issued settings are incorrect, things are bound to go wrong.

Thank you @wizardofoz and @Nepherte. I really appreciate you both taking the time.

That said, I was a bit afraid the answers might be something to do with networking because a) as strong as I may be in other technical disciplines, I have never had the follow through to make learning networking a priority and b) the studio is located in a building where all of the tenants share one DSL connection. This means that I am not the network admin and there may be limits to what I can do.

That said, there are other network related things going on in the studio and I think they are all being caused by the same issue.

  • Roon cannot log into TIDAL

  • I can no longer connect to the HUE bridge from outside of the studio to control the lights (ie turn them off if I forgot to on the way out)

  • Have a Roland rack mount synth that has a wifi dongle that connects it to my router so that I can connect to the synth with an iPad app. That stopped working as well.

That said, all of this worked in the very recent past which leads me to believe that maybe the network admin of the building has changed something.

On my end, I essentially have an Airport Extreme Basestation plugged into the building’s ethernet drop. This creates a wifi network for the studio for all my devices to access. All has been good up until now. Here are a few screen shots from the AEBS. Maybe you guys notice something obvious/easy I can try?

Thank you again for your help. I’m dying in the studio without Roon and clients LOVE it. Unfortunately, I do not have any local files here. It was ALL just one big TIDAL collection so Roon is utterly useless to us at the moment.



without knowing a little more about your network behind the AEBS (APE) its a little hard to know what subnet mask you should be using and also what the wireless and network tabs look like with making assumptions. This info is likely being provided by the outside network but it might (now) be incorrect - as we cant tell when it was working what the settings were.

Assuming you can get to the internet on this connection to the APE? maybe it might be just a matter of setting the APE as DHCP and just remove the DNS servers letting the network behind assign them. or at least if you want to specify DNS put in the router address and one other like or

do you have any details from the outside network setup? Is it a shared office setup or an ISP connection?

Hello @Wade_Strange, and thanks for the detailed information here! Another good test would be to make your iMac the core temporarily. This would tell us a lot about whether this issue is with your ROCK machine specifically or if this is something to bring up with your network admin. Thanks!

Keep in mind that federated authentication to Tidal appears to be down for other products too. For example, my Amazon Echo can’t connect to Tidal either.

I have a feeling the problem is on Tidal’s end.

Thank you @nuwriy. That is a great idea and I’ve done just that.

So quick update on a few things I tried today.

First, I physically took the studio Roon ROCK to the house and swapped it with the one there. It fired right up, logged into TIDAL in 2 seconds and was ready to go. I was thinking if I could just get it to log in at the house, maybe it would save a cookie or something and then I wouldn’t have to re-log in when I got it back to the studio. You guys probably already know this, but no dice. As soon as I got it back to the studio, I was greeted with this message:

So then I unauthorized the studio Roon ROCK and setup a new version of Roon on the iMac and lo and behold, was able to log into TIDAL perfectly there too even though both the iMac and the Roon ROCK are sitting right next to each other and hardwired to the same router.

Any ideas? Using the iMac is a temporary stopgap. But really we have Roon for when the computer crashes or needs to restart in the studio to entertain clients while we wait for everything to come back up.

Thanks guys!


Sorry, one more quick thing in case it makes a difference…just wanted to point out that the studio Mac can easily see the Roon Rock on the network and I am able to browse to the reg folder and can see the TIDAL login file that updated and was time stamped with when I logged in from the house.

It seems like there is something about my local AEBS network that is preventing the Rock ROCK from seeing the internet maybe?


Hi Roon support,

Any ideas I can try to fix this? I haven’t been able to use Roon in the studio for a few months now. Internet is working for all devices in the studio but the Roon ROCK does not appear to be able to connect to TIDAL to generate the correct login credentials.

Thank you,


Hello @Wade_Strange, I’d like to collect diagnostics for ROCK and bring the report to my team. I believe you’re experiencing a network issue based on the symptoms but I’d like to confirm with an extra set of eyes. For ROCK, could you please use the directions found here and send us over a set of logs using this link.

Please let me know when you’ve had a chance to do this and I’ll submit the report, thanks!

Thank you, thank you thank you @nuwriy for looking into this for me. I can confirm that I followed the instructions and have uploaded the logs.

This whole thing is very peculiar as I have been using my Roon rock for months and haven’t had a problem since day one until this TIDAL issue…which I guess you’re right, seems like a connection issue. Though nothing in the studio has changed network equipment-wise, so…puzzling.

Let me know if you or the team needs any other info.

Thank you,


Hey @Wade_Strange, no problem! We’re here to help. I know they’ll ask me, do you have an idea of what router they’re using or any switches in place? I know you said Ethernet to your machines, but any idea what hardware that’s connected to?

Tidal fails login. No changes on my end. This is getting painfully OLD!!!

@nuwriy - So I have created a sort of subnetwork I guess with my Apple Airport Extreme Basestation. I plug that into the ethernet drop in my room and it creates the local network that my studio runs on. Beyond that, no, unfortunately I do not know what gear the building has or even who is the network admin. The equipment room is right next to to the studio though so when I get over there I could take a picture of the big switch they have there.

But again, this was all working perfectly for months. The only device connected to the AEBS that is not not connecting to the outside internet is the Roon Rock. However, I am able to browse to it via the network sharing in Mac OSX’s Finder. So the Rock is on the local network with all my other devices.

Is there an easy way to ping it from the outside world to see if it can see anything beyond the local network? That is a little beyond my meager networking skills.

Also, remember from above testing, if I physically pick this Rock up and bring it to the house and replace the Rock I have there, it jumps online non problem and logs right in to TIDAL.

Ok, thanks again. Hope to hear from the team soon.


Hey @Wade_Strange, let’s submit the report with the data we have, and we’ll see what else the team needs to help. Thanks again for the info! I’m sending in the report now.

Brilliant. Thank you!

Hi @nuwriy, any update from the team. I’m starting to feel like I paid for a NUC I can’t use and an annual subscription that’s going to waste. As much as I love Roon, wondering if it’s time to cut my losses on this one.