Can No Longer Login to TIDAL

without knowing a little more about your network behind the AEBS (APE) its a little hard to know what subnet mask you should be using and also what the wireless and network tabs look like with making assumptions. This info is likely being provided by the outside network but it might (now) be incorrect - as we cant tell when it was working what the settings were.

Assuming you can get to the internet on this connection to the APE? maybe it might be just a matter of setting the APE as DHCP and just remove the DNS servers letting the network behind assign them. or at least if you want to specify DNS put in the router address and one other like or

do you have any details from the outside network setup? Is it a shared office setup or an ISP connection?

Hello @Wade_Strange, and thanks for the detailed information here! Another good test would be to make your iMac the core temporarily. This would tell us a lot about whether this issue is with your ROCK machine specifically or if this is something to bring up with your network admin. Thanks!

Keep in mind that federated authentication to Tidal appears to be down for other products too. For example, my Amazon Echo can’t connect to Tidal either.

I have a feeling the problem is on Tidal’s end.

Thank you @nuwriy. That is a great idea and I’ve done just that.

So quick update on a few things I tried today.

First, I physically took the studio Roon ROCK to the house and swapped it with the one there. It fired right up, logged into TIDAL in 2 seconds and was ready to go. I was thinking if I could just get it to log in at the house, maybe it would save a cookie or something and then I wouldn’t have to re-log in when I got it back to the studio. You guys probably already know this, but no dice. As soon as I got it back to the studio, I was greeted with this message:

So then I unauthorized the studio Roon ROCK and setup a new version of Roon on the iMac and lo and behold, was able to log into TIDAL perfectly there too even though both the iMac and the Roon ROCK are sitting right next to each other and hardwired to the same router.

Any ideas? Using the iMac is a temporary stopgap. But really we have Roon for when the computer crashes or needs to restart in the studio to entertain clients while we wait for everything to come back up.

Thanks guys!


Sorry, one more quick thing in case it makes a difference…just wanted to point out that the studio Mac can easily see the Roon Rock on the network and I am able to browse to the reg folder and can see the TIDAL login file that updated and was time stamped with when I logged in from the house.

It seems like there is something about my local AEBS network that is preventing the Rock ROCK from seeing the internet maybe?


Hi Roon support,

Any ideas I can try to fix this? I haven’t been able to use Roon in the studio for a few months now. Internet is working for all devices in the studio but the Roon ROCK does not appear to be able to connect to TIDAL to generate the correct login credentials.

Thank you,


Hello @Wade_Strange, I’d like to collect diagnostics for ROCK and bring the report to my team. I believe you’re experiencing a network issue based on the symptoms but I’d like to confirm with an extra set of eyes. For ROCK, could you please use the directions found here and send us over a set of logs using this link.

Please let me know when you’ve had a chance to do this and I’ll submit the report, thanks!

Thank you, thank you thank you @nuwriy for looking into this for me. I can confirm that I followed the instructions and have uploaded the logs.

This whole thing is very peculiar as I have been using my Roon rock for months and haven’t had a problem since day one until this TIDAL issue…which I guess you’re right, seems like a connection issue. Though nothing in the studio has changed network equipment-wise, so…puzzling.

Let me know if you or the team needs any other info.

Thank you,


Hey @Wade_Strange, no problem! We’re here to help. I know they’ll ask me, do you have an idea of what router they’re using or any switches in place? I know you said Ethernet to your machines, but any idea what hardware that’s connected to?

Tidal fails login. No changes on my end. This is getting painfully OLD!!!

@nuwriy - So I have created a sort of subnetwork I guess with my Apple Airport Extreme Basestation. I plug that into the ethernet drop in my room and it creates the local network that my studio runs on. Beyond that, no, unfortunately I do not know what gear the building has or even who is the network admin. The equipment room is right next to to the studio though so when I get over there I could take a picture of the big switch they have there.

But again, this was all working perfectly for months. The only device connected to the AEBS that is not not connecting to the outside internet is the Roon Rock. However, I am able to browse to it via the network sharing in Mac OSX’s Finder. So the Rock is on the local network with all my other devices.

Is there an easy way to ping it from the outside world to see if it can see anything beyond the local network? That is a little beyond my meager networking skills.

Also, remember from above testing, if I physically pick this Rock up and bring it to the house and replace the Rock I have there, it jumps online non problem and logs right in to TIDAL.

Ok, thanks again. Hope to hear from the team soon.


Hey @Wade_Strange, let’s submit the report with the data we have, and we’ll see what else the team needs to help. Thanks again for the info! I’m sending in the report now.

Brilliant. Thank you!

Hi @nuwriy, any update from the team. I’m starting to feel like I paid for a NUC I can’t use and an annual subscription that’s going to waste. As much as I love Roon, wondering if it’s time to cut my losses on this one.



Hello @Wade_Strange, I checked in with the team for an update just now and from their findings, they asked if it would be possible for you to try a VPN to connect to TIDAL and if you could please provide us with a timestamp when you try to use ROCK in the studio again so we can collect more data. They noticed some network errors being reported but we’d like to gather more info.

We appreciate your patience and we’re narrowing down on the cause, thanks for your cooperation!

Thanks for the quick response @nuwriy.

Unfortunately, I have an update that further complicates our troubleshooting. It does seem like the building’s network admin is blocking Roon completely now. When I tried to launch the client app on the Mac Pro I’m getting an error that says: "Network error: Please check your internet connection: I get the same error on my iPhone and iPad when trying to launch Roon. So now I’m not even able to call home to Roon’s servers to log in. Of course, all the devices can connect to the web for other sites, etc. Just not for Roon stuff.

My question for you is, what do I have to ask the network admin to do in order to give Roon access to to call home (both to login and for the Roon Rock to reach TIDAL’s servers)? If you can send me a little blurb that I can forward on to them, maybe that would get us somewhere?

Thank you!


Hello @Wade_Strange, that sounds like a good idea! We need the network admin to make a port exception for the program Roon through whatever firewall or antivirus software is set up. That should resolve the issue. We have some instructions available here for what needs to be done.

Hi @nuwriy,

I hope you are really well.

Ok, I think it’s time for me to wave the white flag on this one and give up. It does not seem like the Roon support team is able to help me sufficiently troubleshoot this issue and I now feel like I’m completely wasting a subscription.

I am hoping you can help me with a few things in order to bring some finality to the situation.

  1. I would like to post my Intel NUC Roon Rock in the sales and trades category but I am unable to post, I guess since I do not have the right trust level. Are you able to assist with this? If you need references I can post my eBay handle, etc. I just think that someone in the community could really benefit from an essentially brand new NUC with Roon already installed and working, etc. Would be very plug and play for another fellow audiophile.

  2. is there someone I can talk to regarding a partial refund of my subscription? I started a second subscription for the studio in November but haven’t been able to connect to Roon servers in the studio since April. Roon works perfectly at the house and we truly love it. But between the severe lag times in support responses and the fact that there seem to be network issues we are unable to overcome together, I really haven’t been able to see any value out of the second subscription in months.

Assistance with with both of the above would go a long way towards keeping me a Roon fanatic (of both the product and the company).

Thank you!


@Wade_Strange check your Private messages

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.