Can’t stream to any end point after installing 1.7-528

QNAP NAS, Roon build 1.7/528

Netgear Wifi, iFi Pro iDSD and Bryston bdp2 connected via wire to Netgear Wifi extender

IPhone 11pro latest IOS, Marantz SR6012, ifi Pro idsd, Bryston bdp2, Yamaha A-S2100
My normal setup for listening is:
Roon client -> Bryston bdp2 Roon end point -> ifi Pro iDSD via USB - Yamaha A-S2100

The setup above is unchanged since a few weeks and worked well. However, after installing Roon 1.7 build 528 Roon cannot play to any end point anymore. I tried

  • Bryston bdp2 in Roon Ready mode
  • ifi Pro idsd via Airplay
  • iPhone

I then tried to play to pro idsd from other software (8player via DLNA, Tidal via Airplay) - no problems at all.

2 posts were split to a new topic: Can’t play to any endpoint except for iPhone

Hi @Peter_Gross,

Welcome to the forum! Can you please share a screenshot of you Roon Settings -> Audio tab?

Has anything changed with regard to your setup before this issue started occurring? Have you installed any new apps on your QNAP?

Is there any change in behavior if you try rebooting your QNAP and Networking Gear?

Those are the screenshots.

Will try rebooting the QNAP later, also Netgear. I have no hope that the Netgear equipment has anything to do with this though. I open my Roon client and try to play to one of the Airplay end points. I will not play (see also the screen shots … i intentionally left it trying to play to my Pro iDSD via Airplay. I looks like is playing but the timer remains at zero). Then i switch my iphone to Tidal and Airplay to Pro iDSD and everything plays.
Actually, after i saw your message i tried to play music again - and it worked for about half a song. After that it stopped and nothing played anymore. Go figure.

So i rebooted QNAP and the Netgear equipment (an access point and an extender). I have better success now. Playing from the Roon clients to Airplay end points works. Also it appears that i can play to the Bryston BDP-2 in Roon Ready mode again for more than just a few seconds.
I still do not understand how i got to a situation where i could play to any of my Airplay capable devices when using IOS Airplay but i could not play to them from Roon. The Bryston BDP-2 Roon Ready is a different story - i love it but i understand it is old hardware though the Roon code is from end of 2019.
Might we worth for Roon to check. For me up until this last release I liked Roon not only because of the library functionality but also because of its stability when playing to different end points.

Hi @Peter_Gross,

Thanks for trying the reboot of the Core and networking equipment. I’d like to focus on playing to your Bryston BDP-2 zone as a starting point.

Can I please ask that you reproduce this behavior of trying to play to the BDP zone, and note the exact local time + date + track you experience an issue on?

After getting this info I can enable diagnostics mode for your account and see if there are further clues in logs. Thanks.

Since rebooting the server and the network gear i have played to the BDP-2 yesterday and today for 30+ minutes each day and there was no problem.
If anything the BDP-2 appears to take a little long to appear in the list of Roon audio devices. But once it is there it plays solid.
When i reported the issue i could play to the BDP-2 for less than a minute and then it simply stopped.

Hi @Peter_Gross,

If the issues return do let me know the additional information I requested above. You should also know that WiFi extenders may cause issues within Roon, a direct Etherent run is always preferred.

Ok - I will. Regarding your other statement (wired Ethernet preferred over WiFi, in particular when extenders are used) - are there real specs available of what critical transmission parameters between a Roon core and Roon clients are? I would be happy to try and test or even monitor for specific indicators.

Hi @Peter_Gross,

There are no parameters that you could try to monitor. From our experience, WiFi extenders (and Powerline adapters as well) in general have a poor multicast implementations and multicast is used by Roon quite heavily for device discovery.

If the behavior occurs again, I would try rebooting your networking gear and Core, first the router, then the extender, then the Core.

If the issue occurs more often, you may want to look into a mesh-style network (Orbi/Eero/Velop) instead of your current one, as we have seen mesh-style have better multicast implementations.

Thanks for the information. Will consider. Generally i trust my Netgear stuff … it is pretty highend.
But you never know.

But how about the fact that Roon could neither play via RAAT nor via AirPlay, when i could play to each of my Airplay devices from the same iPhone i ran Roon on?

Hi @Peter_Gross,

Roon operates with a different streaming technology than your iOS devices do. If you were having networking issues, it is possible that they impacted all of Roon’s communication.

It’s hard to say what exactly occurred here with regard to your network, but if the issue happens again, do let me know and we can take a closer look.