Can Waiting for your Roon Core be a hardware issue?

Roon Core Machine Lenovo I5 tiny form factor. 8th Gen windows 10. 8 Gb RAM 256 Gb SSD. Running headless. Have used this for approx 3 to 4 years

On automatic update so running latest versions

Networking Gear & Setup Details

Sagecom router supplied by Optus. PN 2982013/50115. Ethernet connection to Roon core and Bluesound Vault. Wifi connection to Roon controllers. Usually an IPad but sometimes a windows 11 machine

Connected Audio Devices

Bluesound Vault. Wired HDMI connection to the router.

Number of Tracks in Library


Description of Issue

I keep getting this issue we I have previously assumed to be related to Tidal, but am now wondering if my hardware is getting old and actually causing the issue.
Most of my Listening is from Tidal. I keep having the music drop out and I then get messages:
Waiting for your Roon Core. This often times out to be replaced by: Uh oh, something is not right, make sure your Roon core is turned on etc. This usually then goes away and music resumes. Occasionally it is followed by a warning that Roon can’t log in to Tidal or that Tidal media is loading slowly.
Every time I have found that I have fast download speeds, in excess of 40 Mb/s. Also I have no issue logging onto the native Tidal app and playing something. (Admittedly, this does not get sent to my Bluesound Vault.)
I also have no isues with the network when watching Video downloads from numerous streaming services.

Could this be caused by the hardware getting old?

I am thinking it may be time to replace the core with the highest spec recommended NUC running ROCK. Will this solve my issues?

Please advise

1 Like

There are several possible causes, not just your core machine’s hardware.
But you can quickly find it out if you install the core on another machine, jus as a trial, and see how it goes.

However, I had the same experience immediately after some short circuits here in the house. Since my NUC Core was connected to a UPS, I couldn’t quite imagine that the NUC’s hardware had been damaged. But since my router was already more than 5 years old, I tried and bought a new one (Asus RT-AX86U). And with that, all the problems you described as well, disappeared. By the way, I had no issues with video streaming, only Roon was affected by the dropouts. It’s been 4 months now and the problem hasn’t recurred.

Thankyou Axel.

Looks like changing the router is worth a try. Sometimes rebooting the Roon server seems to temporarily solve the issue.
Is this by any chance caused by poor response from Roon’s internet server?

It just occurred to me, since you have Windows installed, that there are free programs that you can use to check the RAM memory of your machine. Maybe you can google it? I’m just on the go, gotta get out of the house now …

Hi @Frank_Rome
I’m back. Just in case you didn’t find it:

And an interesting thread as well

Best, Axel

Hi Axel,

Thank you for the follow up. I ran the memory test and it came back with a pass with no errors detected.
The problem persists

Hi Axel,

I would appreciate some guidance on the features or specs to look for in a router. I note that the ASUS router you bought is fairly expensive. What were your criteria?



Hi Frank,
The answer is the usually crap software of cheap WiFi routers aimed at consumers. There is no need to write decent software, as they only have to appear to work when first turned on, so they don’t get returned to the shop. Over time they fill their internal tables, have memory leaks and other failures due to poorly written and tested code. The easy way to work around this is simply to power cycle the router but that sucks more and more over time.
Good quality routers will run for a long time without slowing down. While the hardware is sightly better quality, the real difference is properly written and tested software.

In addition, it is very easy to flash Asus routers with alternative software, which might be useful if an update causes problems at some point.
My previous router was also an Asus, which worked reliably up until the short circuit. I’m familiar with the user interface, which allows to make almost any setting.
Another reason, because I am dependent on a reliable network for professional reasons, I have an additional DSL line that is handled via a Fritzbox 7590. Quite okay the FB, but not nearly as good as the Asus. The WiFi range of this one is much better, the signal is stronger, the throughput much higher and the performance of the Asus does not drop even when the whole family is gathered in the big house for a week over the Christmas holidays: In addition to smart home devices, several TVs streaming at the same time, people working on laptops, phones, tablets, running Tonieboxes, and me while cooking listening to roon in the kitchen. The Fritzbox couldn’t get that without performance drops.

But that’s just me. :slight_smile:
Others have different preferences and I encourage you to read through this thread:

Hoping I could be of some help, good luck!

There can be other reasons as well, not just an underpowered router, the first thing coming to my mind is a corrupt database …
Maybe others can comment on this?
I remember there are suggestions in the Roon KB help pages.
Or just wait for @support?

Thanks for the replies. All helpful.

I do still neeed support. Cycling the Router does nothing but rebooting the Roon server appears to the solve the issue for a few hours to a day or so.

1 Like

Hey @Frank_Rome,

I would be happy to look into this for you. Can you do me a favor and get me some instance details? A date/time/track played instance will allow me to look into diagnostics logging and find out what Roon thinks is happening.


Hi Wes,

Thankyou for looking at this.

Her is the first instance today:
13:58 am Sydney time.
Playing the album “The Bespoke Man’s Narrative” by Aaron Diehl From Tidal
It played fine last night after a reboot of the core computer. This morning it played fine for 15 minutes.
I came back to it now to play the balance of the album. After playing for only a minute, it has dropped out of the track
image which I was halfway through when I paused it. Instead of recommencing playing the track it has skipped to track No. 9: “bess you are my Women Now” I pressed play again. It dropped out again after a few seconds and has paused on the beginning of the next track: “Epilogue”. It is now 14:07 and it it showing a message
I rebooted the core at 14:10. It took a full three minutes to come back online. I was able to reset t back to track 8 and it now is playing fine without dropping out

Hey @Frank_Rome,

Thank you for the wealth of information here.

I don’t normally comment on brand names etc but I am a HUGE fan of ASUS routers. So much so that I gave their laptop a chance and love it too. I don’t think there’s any reason to believe that either your core machine or your router is specifically at fault but you should understand that using streaming services and other apps is in no way a barometer for how Roon should perform. Those items use the internet while Roon uses both the internet and intranet. It’s certainly worth updating the router setup to ensure smooth sailing. In my case, my ISP (Xfinity) provides a modem/router combo and I could never get it working smoothly with both Roon and Roon ARC so I had to bring my own modem and router to use.

All of that said… I think we need to look at a couple of things on the Roon side before we do anything drastic. First, let’s clear your cache:

  • Exit out of Roon (in your case, you will need to exit Roon Server)
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

If this doesn’t change anything, please report back with the instance information and we will work on this further. I’m hoping this does the trick though!


Hi Wes,

I followed your instructions. Unfortunately it hasn’ fixed the issue

What has happened:

8 March 11:49 Contued playing the same album from the night before:
Playing the album “The Bespoke Man’s Narrative” by Aaron Diehl From Tidal Last track
Began playing then stopped and skipped the track.

16:15 System completely stuck. Followed your instructions. Moved the contents of the cache and rebooted. Then played fine last night.
March 9 11:15 Very slow to recognise the Roon Server when fisrt accessing the system today.
Started to play and then dropped out. Playing the balance of the album I was accessing last night from Tidal: Paco de Lucia: The Montreaux Years. Last track Messages: Tidal loading slowly, then: waiting for Roon Core.
3 minutes before the system came back online. Balance of last track skipped. Started the track again and it dropped out after 2 minutes.

11:14 Selected new album: Wille by Vincent Meisner.
Dropped out after 23 seconds. Message: Can’t fid the Roon core. Was able to resart the track, it drped out again at 2:23 on track 1
11:20 Dropped again a few seconds into track 2 and it skipped racks 2 and 3.
11:22 Message re Tidal loading slowly, then Waiting for Roon Core. Track skipped

I then resrted the Roon core. It is now 13:45 and the system is playing fine since the restart

It is now 16th of March and the Core has not needed a reboot since the 9th. Working a lot better without dropouts.
However, I am still getting longish delys when first accessing the system after a couple of hours of not using it. I still get the Waiting for Roon Core message. Here are instances:
11 March 23:09 While browsing for music to play got the “Can’t find Roon core” message
15 March 22:26 Can’t find Roon core message.
16 March 1:28 Usual can’t find Roon Core message, then all tracks on the album I was playing showed as unavailable. After a couple of minutes it was all OK again.
16 March 11:07 Can’t Find Roon Core message while the music was paused. Album Mich Goodrick In Passing

I will appreciate some more comment from Roon Support on this.
Today, Roon is working fine, but I tried Roon ARC at home and it won’t connect at all with a message “poor connection”. This is despite having in excess of 50 Mb/s download and no problems with Roon today.

Roon Arc problem solved by deleting the app and reinstalling. I thought it may have been related to the core.
Will still appreciate comments from Roon Support on still getting “Can’t Find Roon Core” messages on the main Roon system

Hi Wes,

The problem has reappeared:
I was playing John Bailey Time Bandits this morning. I came back to it this aftenoon and the album played through flawlessly. When it came to an end, I searched for Ann Hampton Callaway. Her details were slow to come up. I then clicked on “discography” and got the message: “Uh Oh, Something is not right” I went back to searching for the artist and got no response.
I then reset the router. No change. I then rebooted the Roon Core machine and everything worked fine again.
Any suggestions on the next move?



Hi Frank, have you tried resetting ARC when there are problems? I’ve found it often resolves minor connectivity issues… Reset can be found in settings, scroll to the bottom of the screen to find it…

Hi PixelPopper,

Thanks for the suggestion. I tried that and after 1.5 hours the app was stiil “syncing with the Roon Core” . I deleted the Roon ARC app, reinstalled it and it then synced very fast, and now works again.

1 Like