Cannot Access Roon OS Data Directory from Windows Explorer

Roon Core Machine

Roon ROCK on i5 Intel NUC

Networking Gear & Setup Details

Netgear Orbi Mesh (model year ~2018) with all nodes connected via Ethernet. All Roon devices are connected via wired Ethernet (Core, Clients, Endpoints). I also have some Chromecast devices connected wirelessly.

Connected Audio Devices

Core only here, running headless with no audio output.

Number of Tracks in Library

33129 tracks

Description of Issue

I got stuck in the upgrade/downgrade mess of the v2.0 update (most of my devices updated to v2.0, then the core automatically “updated” itself to v1.8). The instructions to get back to v2.0 involve accessing the Roon OS Data Directory. I am unable to access this directory following the instructions in the help article though. I’m on Windows 10 and using Explorer, I get an error when typing in the \ROCK\ or \. I can access the ROCK status page just fine and it reports that everything is working fine. I am able to connect to the core from the Windows Legacy 1.8 client and the Android Legacy 1.8 client.

This is what I get when trying to access the data directory (Windows cannot access \ROCK, I get similar with IP access attempt):

What else can I try here? I’d like to get Roon back to a “just works” state. The reason I pay for Roon is because it has always “just worked” and at the moment it’s not “just working”.

@Jonathan_Barton, please try using the IP address of the NUC instead. This is shown on the screen you posted, but I can’t see it because it is obbscured by the Explorer window.

Instead of typing \\ROCK use \\<IP address., e.g., \\

Martin, thanks for the suggestion, but I’ve already tried the IP address too and get the same behavior (except that the error message lists not being able to access the IP address in place of \\ROCK\ ).

The other thing that I realized is that this problem wasn’t always the case, as I must have accessed ROCK this way in order to add the required Codecs when I initially set things up.

Can you please reboot ROCK; I see that it’s be running for some days.

I should have thought of this sooner, but I tried accessing the \\ROCK\ data directory using 2 other machines. The 1st worked exactly the same (no connection), but the second worked just fine (although I got different directory contents using ROCK vs IP).

So, I’m most likely in business here. I still have to actually go through the update steps now, but I’ve got step 1 moving at least.

Questions that I still don’t understand the answers to:
Why does this only work on 1/3 of my Windows machines?
Why does using \\ROCK\ on the machine that does work not actually give me access to the contents of the directory?

At least one user reported that the SMB client was missing on Windows 11:

Update: You may also have to enable insecure guest logons:

1 Like

For each of your Windows computers, click search on the Windows task bar and search for “windows features” then click on “Turn Windows features on or off” then scroll down to “SMB 1.0/CIFS File Sharing Support”. Make sure that is selected then click the “+” and make sure “SMB 1.0/CIFS Client” is checked. You will need to reboot any of the computers that didn’t already have the SMB client installed before it will work but after this you should be able to see the ROCK shares on all your computers.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.