Cannot add a network folder; Core on Ubuntu on a NUC10,


I bought a NUC 10i3 especially to run ROCK. Unfortunately, the installation failed. I managed to activate the legacy boot und the installation went through. After the first reboot, I couldn’t connect to my network, even it was connected to my LAN.

"Searching for network address…
If this persists, please check your network configuration."

Recommendation from Roon Labs was to downgrade to NUC8 which was not a very viable option. So I decided to run the Core on Ubuntu. Installation went straight. Tidal is working fine.

BUT I can’t connect to the network folder running on my Synology NAS.

" Cannot connect to network folder: unauthorized!!!"

I have really no idea why. Migrating to Win10 is no option. I do not want to buy a additional Windows license for my NUC.

Any Hint?

Best regards.

Have you read through this: Connecting to a NAS

Hi Daniel,

it worked on Windows, on my Synolgogy NAS as well. But I have still problems on Ubuntu.

BR, Gerhard

Roon core dont work with SMB V3.

Your nas must be SMB v2…

Roon dont want to fix this issue

Hi, I the meantime I solved the problem. The tricks is editing the /etc/fstab and adding a line for the network share. The howto can be found in ubuntuusers.