Can't add NAS directory to Roon library

Core Machine (Operating system/System info/Roon build number)

Debian 10 Roon Core

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue


Just want to add a folder from my nas to music library

Samba is ok on my nas (Ubuntu nas) :


(User = hadrien, password (exemple, not the truth :stuck_out_tongue: = azerty)
It works

Works too with windows


Hi @ComasSky,

Does the password for the share have any special characters in it?

Did this share work previously with Roon? Have you tried rebooting your Core and the NAS?

No spécial characters

It’s the first time i try to connect my NAS in Roon.

Dont try to reboot, i’ll test today.

Is not possible to see logs ?

Hi @ComasSkym

You can access the Roon logs by using these instructions. Can you please reproduce the behavior, note the exact local time + date when you attempt to add the share and then share a copy of these logs via Dropbox / Google Drive / your preferred file sending service? If you want to also take a look in the logs for more clues that might help narrow down the issue.

Here are the logs

Are you running your Roon Server in a docker container?

More privileges are required for mounting within a container, the container must be started with –privileged."Unable+to+apply+new+capability+set."

You’re right !

And second problem, Roon cifs does not support SMB3, i must downgrade to SMB2 :slight_smile:
It works now

Form LinuxInstall:

cifs-utils (Roon Server only)

If you intend to use Roon’s network folders feature, the mount.cifs command must be available in your PATH. Generally this comes from a package called cifs-utils.

Actually the mount.cifs of your OS?

root@Serveur-Hadrien:/# mount.cifs -V
mount.cifs version: 6.8

Commont solution is usually to add vers=3.0 to the cifs mount command

In the logs, we can see Roon try 3 times, SMB1, SMB2 and SMB2.1, but does not try SMB3

@dylan Maybe add SMB3 connection ?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.