Cannot connect Roon ARC to ROCK while on the go

Roon Core Machine

Mac OS 12.6, MacBook Pro 16" M1 Max 64GB

Networking Gear & Setup Details

Experia Box V10 connected via Ethernet

Connected Audio Devices

TV connected via Ethernet
Apple TV connected via Ethernet
Devialet Phantom Gold connected via Ethernet
Roon server (not Nucleus) connected via Ethernet
MacBook Pro connected via Ethernet

Number of Tracks in Library

23196 tracks

Description of Issue

I am unable to connect remotely to my Roon Core via Roon ARC.
I get the following message:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}

Could you please help?
Thanks in advance

Who is your ISP?

My ISP is KPN, in The Netherlands

I thought it might be…

OK, have you had a read of this Help article:

Going by the error message you are seeing, it appears as though UPnP is not currently enabled in your Experia box. Can you try turning that on?

Thanks Geoff,
I know that article and read it prior to contacting you here. Will check with my ISP on how to enable UPnP and keep you posted.

Hi Geoff,
I was eventually able to access the web interface of my modem today and I enabled the UPnP port but was still unsuccessful. Going deeper in the settings, it appears that both Firewall and Anti-hacking are enabled by default and cannot be disabled.
Is there another way around?
Thanks in advance for your reply.

Can you turn UPnP off, and set up manual Port Forwarding as in this example (See which port you need to set up by looking in Settings > Roon ARC)

It works now!! Thanks a lot for your help! I couldn’t have done it on my own…
Have a great day.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.