Cannot connect to distant library [Solved]

I setup Roon nicely (Windows 8.1 wired to Ethernet, music on a NAS) and was flawlessly able to connect a Samsung tablet to operate it.
In another room I have my main computer wired to the same network. I downloaded Roon and opted to operate a distant library, but it keeps looking for it, unable to find it. I have done everything that is suggested (including putting the IP address of the computer that has the Roon Core) but no luck.
Thanks in advance for any help / tip.

Did you enable “Allow Remote Connections” in the distant library? Without that switched on, nothing will connect.

Thank you for your swift reply. Yes I did that (and it allowed to connect nicely the tablet).

…But not the second computer…

Firewalls or permissions ? If they’re not the problem then @kevin or @vova will see this thread on their rounds of Support.

Thanks for the suggestion but I think it unlikely since I first installed the trial version on this computer and it worked just fine, so Roon is allowed access to the distant database.

What is your main computer. You haven’t mentioned specs

A build fixing some connection bugs that have been identified will be released in the next few days:

Lets see if that picks up this issue.

Hey @hdis. A couple of preliminary questions:

  1. What OS are you running on your the computer that’s having trouble connecting
  2. In your network layout, is there anything other than an ethernet switch between the computer that’s having trouble connecting and the Roon server?

Hello Brian,
Thanks for taking the time:
1: Windows 8.1
2. Yes, there are 2 ethernet cables coming out of the Router, and the Roon server and my second computer are not connected to the same one. But again, so is the NAS and I have never had any problems connecting to it (Synology).

Ok. There’s a reasonable chance that the change @andybob mentioned will fix this problem for you-it is a Windows specific issue, and your symptoms are consistent with our understanding of that problem. Your network layout is simple, which pretty much rules out a networking configuration problem here.

We are planning to get that build out in the next couple of days. If that doesn’t fix you, we’ll investigate further.

1 Like

Hi brian,
A few hours ago @vova posted on a related topic that the new build was released.
Should I install the new build on ALL my computers (Remote PC with the problem as well as the problem-free Core PC and the Tablet ?).
Thanks again for your help.

Edit: by the way, in the meantime I have upgraded the Remote PC with Windows 10 (upgrade went flawlessly however didn’t fix the Roon problem) - I hope this will not ruin the chances the new build will solve the problem :smile:

Hi @hdls ,
Install the new build on both Core and Remote. Not sure if the android app is available yet. If you are still having trouble after upgrading, post again in this thread and the devs will investigate further. Windows 10 shouldn’t make a difference.

Installed the new build tonight and … PROBLEM SOLVED !!!
Thanks a lot to everybody for your help and to all the staff working hard at Roon to further improve their product !

1 Like

This topic was automatically closed after 8 hours. New replies are no longer allowed.