Cannot connect to Roon Server (Windows 10)


After 2 trials in past few years I decided to start my Roon subscription, mainly because I use Tidal now as my main streaming service.

I have a fresh install of Roon Server on an Ubuntu based system, but I will use only Windows Clients to connect to the server.

During the trials I didn’t have a single problem connecting my clients to the server.

With the current release though, I have problems connecting my main Client with the Roon Server.
I can connect though my iOS devices withing the Roon app, but my Windows 10 client cannot find the server.

Please see attached the screenshot of the client trying to connect forever plus here you can see an extract of the logfile (perhaps the relevant part with the error message):

6/16 00:30:14 Debug: [SOOD] failed to init socket: System.Net.NetworkInformation.NetworkInformationException (0x80004005): The requested protocol has not been configured into the system, or no implementation for it exists
   at System.Net.NetworkInformation.SystemIPInterfaceProperties.GetIPv4Properties()
   at Sooloos.SOOD.Connection.InitSocket()
   at Sooloos.SOOD.Connection.SendMessage(Dictionary`2 map, Action`2 response_callback, Action done_scanning_callback)
06/16 00:30:17 Trace: Successful POST response from
06/16 00:30:17 Trace: [push] connecting to
06/16 00:30:17 Trace: [push] connected
06/16 00:30:20 Info: [stats] 5269mb Virtual, 199mb Physical, 20mb Managed, 1113 Handles, 44 Threads
06/16 00:30:35 Trace: [appupdater] initial check for updates
06/16 00:30:35 Debug: [base/updater] Checking for updates:
06/16 00:30:35 Info: [stats] 5265mb Virtual, 196mb Physical, 18mb Managed, 1107 Handles, 43 Threads
06/16 00:30:36 Debug: [appupdater] Update not needed
06/16 00:30:37 Info: Flushing kart data to server
06/16 00:30:37 Debug: server said: .

On this system I have the HyperV-Role enabled, so there are more than one network adapters configured, but I disabled the IP protocol on all adapters beside the main network connection from my client. Perhaps this could be relevant, because I didn’t have the Hyper-V Role enabled during the trials.



You could turn it (Hyper-V) off and see if the Windows clients can connect.

I can’t connect with my main client (Win 10).
2 of my iOS devices can connect without any problem, so most probably it is a problem with the client, but I’m stuck right now.
Until now I also tried to install the complete setup on the Win 10 system and the core does start, but the Roon server logs do show the exact same error message as the client and I cannot connect to the core on this system.
So there is something related to this system, but I cannot find the root cause.

Thank you for your report, @Jochen_Renner.

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Do you have any antivirus or firewall enabled on the Windows 10 machine? If you disable them do you see any change?

Are you connecting the Win10 device via WiFi? Any difference over ethernet?

If you disable this, is there any difference?



the brief description about the non-working client:

  • Windows 10 x64 (1803 build)

  • Windows Firewall is enabled in general. I have done also tests by disabling the Firewall with no change. Additionally I’ve added the following rules to the firewall:

  • Antimalware solution is Bitdefender. Added exclusions for Roon folders and applications though. Tested also the installation of Roon and running Roon by disabling bitdefender completely with no change.

  • Hyper-V Role is enabled and at the moment I cannot disable it because is an important system/vm running on it which also hosts the Roon Server component (Ubuntu based).

  • Networking in general is all ethernet beside mobile clients. But all mobile clients can connect to the Roon Server work.via Roon app.

  • the network config on the client consists of 4 network interfaces (2 physical and 2 virtual), but only one interface has the IP protocols enabled.

  • Also checked if it makes any difference if I start roon with administrative privileges, but there is no change.

  • Installed Roon version is current version (1.5 build 323)

  • I just checked on another Windows 10 client (x64 build 1803) and Roon can connect to the server without problems.

  • I also checked if it makes any difference, when I set the hostname (short and fqdn) or ip address during discovery with no change.



Update - Problem could be partially solved - Bug request?!

Luckily I had another dev project, in which I used the exact same .NET Classes which where mentioned in the exception, so I could reproduce the error.
For reference again the relevant exception message:

System.Net.NetworkInformation.NetworkInformationException (0x80004005): The requested protocol has not been configured into the system, or no implementation for it exists
   at System.Net.NetworkInformation.SystemIPInterfaceProperties.GetIPv4Properties()

As I wrote earlier I have some network interfaces which have no IP protocols enabled.
Within my code I get the exact same Exception if I iterate through all network interfaces and there is one which is not enabled for IPv4.
As soon as I activate the IPv4 protocol on all network interfaces, the problem goes away and the Roon client instantly can connect to the server.
So it looks like that this Exception is not handled in the Roon client.
Again it is only relevant if there are any network interfaces which have the IPv4 protocol not enabled.


Thanks for the update, @Jochen_Renner, and apologies on the delayed response.

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics, as well as the information you’ve provided above, over to the team for further investigation.

Kind regards,

Hi @dylan,

recently I got my workaround running (see last post), so I don’t run into the problem right now.
Therefore you can’t see anything wrong right now in the diagnostic logs.
If you need further information please let me know.


Hey @Jochen_Renner,

I spoke with the technical team regarding their investigation into your report. They confirmed that it is expected that the IPv4 protocols need to be enabled here for the remote device to work properly and this is currently expected behavior. I’m glad that you’re up and running now, though!

Happy listening!

Hi @dylan,

thanks for the response.
I understand that there has to be at least one network interface with IPv4 protocol enabled, but the problem is, if there is any other network interface which has IPv4 disabled, the Roon client cannot connect though there is another network interface configured correctly.
This is not a situation which we can find on many clients for sure, but I hope you can understand my view and the problem.
For me personally it is not a dealbreaker anymore as I have the workaround running but I had to reconfigure my complete networking setup, so for others it could be a dealbreaker.


Hey @Jochen_Renner.

While I cannot make any promises at this time, I’ll be sure to pass that along to the team so we can investigate if there is anything we can do better here. Thank you for the feedback, it truly is appreciated!

Kind regards,