Cannot connect to Synology NAS

I’m using a macbook pro running the latest Roon build. Previously I had no problems connecting to my music folder on my Synology NAS by connecting to network path “smb://DiskStation/(my music folder)”. After I installed the latest build I couldn’t connect to Synology anymore. I did not change any settings at all. Please help.

Hi @Andy – there were some configuration changes for Synology discussed in this thread. Can you take a look and let us know if you’re still having issues?


I followed an advice posted somewhere in this forum that I should go to finder and connect to server and type in the smb path. It worked and Roon is able to see synology again. However this additional step wasnt necessary before.

Yes, there were some changes in how network storage works on OSX in last week’s release.

So I understand the issue, you’ve now mounted the drive using OSX, and you’re all set?

Yup correct. I believe for the best user experience the connection should be automatic and seamless. This additional step is getting in the way.

1 Like

@andy - I too have a Mac and a Synology NAS. I have SMB2 enabled for Windows File Services on the NAS.

I map a network folder on the Mac Mini under storage settings to access the music folder on my NAS. I do not use Finder and mount the drive locally and the set a path to it.

So in my setup I configure the network path to be, smb://" . I use the full IP address rather than the Mac friendly smb://diskstation/music path.

This has worked flawlessly for me.

I hope that was what you were asking about.

The connection is as desired, automatic and seamless…

Hi bplexico

Thanks for your input. The method you are using appears to the same as my workaround. My point is that prior to the latest build the network drive need not be mounted for the watched folders in Roon to work.

I apologize, I was less than clear. I set the path to the network folder in Roon. That is all. I do not mount the drive on my desktop.

Thus, once configured in Roon, the drive does not appear in Finder. I do not have the network drive auto mount. So I boot the Mac, Roon launches and that is it. No action on my part.

I tried your method but it is not working for me. Are u running the latest build and did you have afp disabled?

Yes AFP disabled. SMB3 set in settings for Synology NAS for Windows File Services (Advanced). Latest build.