Cannot enable ATV4


I see my appletv in the roon audio, when I select it asks for passcode, I enter the 4 digit code on the ATV, it thinks for a while and just returns to the settings screen with the ATV still available for set up.

I am 100% entering the data correctly.

I restarted the apple and tis time it connected so I thougt happy days, however no music plays, roon says its playing but there is not sound.

Hi @Gareth_Irwin,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Since experiencing this issue have you tried rebooting your Core machine and the Apple TV?

Was this working in Roon previously/

Hello @Gareth_Irwin,

In addition to the troubleshooting @Dylan recommended, could you try setting your Airplay security to “Require Password”? Once you have set a password on the AppleTV, you can then try enabling the zone in Roon with the password you entered on the AppleTV.



The Roon server is running on a dell server quad core xeon and windows server 2008 24 gigs ram

The network is principally ubiquiti, with 3 hdpros for wifi access and 3 switches. Router is a custom pc with UNtangle UTM on.

I have not tried using the ATVs before however I have a yamaha amp with airplay and it works just fine on there.

I have rebooted the roon and atv a couple of times.

Roon thinks its playing, but nothing comes out the atv.

I dont know how to set up airplay secuirty but if this in essence means that all airplay in my house now needs a password, I wont be doing that.

Well I have been trying various things today and have to say I dont think its roon, my entire network is not accepting airplay in any form from one device to another.

Most odd!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.