Cannot get Roon to work as a Roon core with Innuos

I am just not tech savvy enough to use this product. I habe tried everything. Even the USB backup and restore failed. Formatted USB drive on the Innuos > fresh backup on PC > Roon cant see the backup on the USB stick when pointed back at the Core on the Innuos.

What makes this worse is that Roon was seemingly able to create a backup to the USB drive while it was unplugged.

This is all totally crazy and I am now giving up.

A NUC would have been the easier route, but before you go why don’t you just forget about the backup, connect your local music and services and see how it looks.

1 Like

That sounds like you didnt’t back it up to the USB stick. Not sure why your having so many issues with what is a pretty basic operation. Put USB stick into windows PC. Format it here as exFAT which is Roons recommend filesystem.

In Roon goto back up section. Select Backup Now and then select the USB stick as shown in the images below. These are from phone remote process is the same windows remote will show the drives to the left rather than a drop down box.

Ensure you chose the correct location, back it up, leave it to do its thing when done check the USB stick in Windows to see if it’s made the files. Put it in the Innuos go to Roon Backup, select find backups navigate to the stick the same way as you backed it up to restore. Do not go into the folders it’s created stay at root level of the stick where the backup was chosen to go. Restore, wait and it’s done.

Ha! If only it were that easy!

I did all of that. Didn’t work.

The USB drive (post backing up Roon direct from the PC) just will not show up on the Roon remote’s “Choose folder” dialogue, when pointed back at the Core running on Innuos. On the PC it shows up just fine. It is formatted by the Innuos first, as that is the only way to get it to show up in Roon’s browser. Then plugged into the PC to perform the backup, then back to the Innuos where it can’t be seen. I was up all nigh last night trying all sorts!

Thanks for your pointers though. At least it confirms I am following the correct process. The only thing I would say is that formatting the USB on Windows first, exFAT, means Roon on Innuos won’t see it. Only after formatting on the Innuos can Roon then see it.

To test this I set it as a backup destination on the Innuos Roon Core. I then unplugged it to see if Windows would see the folder it created, which it did. Then I performed a backup on Roon while connected to the Innuos Core without the USB plugged in - literally in my hand and Roon processed the full backup to the phantom USB stick and said it was successful. Crazy.

Sounds like a permission issue of some sort on the Innuos. Are you ejecting the stick from Windows and not just pulling it out as that can lock them up I find.

Does the Innuos OS see the usb stick when it’s put back into it after backing up. If it doesn’t then there lies the problem. Roon can’t fix issues with hardware. The backup restore to stick works fine so this has to be hardware related. I format it on windows to exFAT as recommended. Not sure if innuos supports this if your on later firmware. If it’s not showing up then something is not allowing it to mount. This is not a Roon issue but the operating system of the Innuos. Reach out to them.

I had one last failed attempt via USB (reformatted again on Windows, no joy seeing it on the Innuos Zen Mini Core, then formatting again on the Innuos, before backing up (successfully) from the PC (direct to the USB). Then no joy again on the Innuos restore, even after rebooting it still couldn’t detect the USB drive.

However, my latest, and final attempt, at restoring a backup was back over the ethernet mid morning. (I would never find time for all this at any other time of the year). It worked…finally :sweat_smile:

I have come to the conclusion (only a theory) that any backups I made to folders on the PC that sync with Microsoft OneDrive, do not restore to the Innuos. At one point, I saw a strange error message when copying one such backup to a USB, saying something like “[certain] metadata information [which looked like the sort of thing OneDrive uses to monitor the syncing status of some of the files within the Roon backups] couldn’t be copied”. It errored on files, that for some unknown reason, would not sync to OneDrive cloud servers.

The backups direct to USB failed for different reasons, but a backup to the root user folder (not synced with OneDrive) restored successfully over the network to the Innuos no problem at all. I am yet to see how the Innuos now performs as a core, but the restore was a success.

The solution for me was not to try and restore a backup to a folder synced with Microsoft OneDrive and to make sure SMB1 (whatever that means) is installed and activated on Windows 10, also see this post…

1 Like

Of course you are right about that! I didn’t realise the hassle it would save and it also avoids the wasted (IMO) expense of the Roon Nucleus.

I might get one yet (or use it as an excuse to get a new M1 Mac Mini!).

Will see how the Innuos Zen Mini fairs as a Roon Core


Yes it does.

The problem is the Innuos OS appears to see the USB stick just fine, even after the backup from the Windows PC. It’s just Roon that can’t see it.

I do think this is a Roon issue though. Insofar as it, Roon, is complicated. I mean, when it is set-up and running it is robust and sophisticated. Let’s face it, it is amazing. What it can achieve with all sorts of low end to high end audio equipment, streaming etc. etc. on and on. I went through all this pain because the end product is so damn good.

However, setting up Roon, moving the Core and getting your head around it all is far from straightforward. The error messaging on Roon could be much clearer. Also, I strongly feel that Roon needs to be more prescriptive about the required hardware setup. Once you know, you know and all the info is somewhere (endless support threads, knowledge base etc.). But, one needs a lot of patience, time and help to set it up properly.

The message, if you want to avoid hassle, get a NUC should be shouted more loudly! But when I first discovered Roon, I had absolutely no idea what a NUC was. Thats a whole learning curve itself!

New MACs are getting very good reviews, I did wonder about one for pure Tidal but I have a LUMIN streamer.

I got a NUC from the below, seem to have some cheap deals, I had an old SSD drive so just had to add some memory and I put Linux Mint on as a free OS. Very pleased with it.

If Roon can’t see it the OS is not mounting it for it to see it. I would reach out to Innuos anyway as they might know what’s up or had users with similar issues.

My experience is very different, moving my core was the easiest thing to do. I just followed the knowledge base and it worked. No issues whatsoever.

A Roon Nucleus is NOT a wasted expense. It is a great turn-key device that runs Roon core perfectly. I paid $1119 for mine and would gladly pay that price to avoid the hassle you just went through. Mine has been running flawlessly for 13 months.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Core Machine (Operating system/System info/Roon build number)

Screenshot 2020-12-26 at 21.46.14
Innuos Zen Mini Mk 3

2nd Core (the one that works flawlessly) Windows 10 running on 10 year old iMac.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Sky Q Broadband Hub, Netgear Ethernet Switches and Ethernet connections to all devices.
Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Zen Mini Mk 3 with RCA audio out to Rega Class A amp and passive speakers.
Description Of Issue

I am still having major problems switching my Core from a Windows 10 device to the Innuos Zen Mini mark 3.

After a lot of angst and effort, Roon is working on my Innous Zen Mini as a Core. I finally restored the backup from the Windows machine over my home network to the Zen Mini. However, since the restore, Roon couldn’t see my music library (which is on the Zen Mini itself).

I performed a backup of my music library from the Zen Mini (via it’s Web interface) to an attached USB drive.

After trying to run Roon again from the Core on the Zen Mini, the music library was still unavailable. I revisited it today and it started to re-scan and import my music library (from somewhere, I can’t tell). All albums are showing as “new” imports and none of my Tags or Bookmarks are working. Lovely.

My first request is to be pointed in the right direction for some instructions of how to fix this latest problem. I find it impossible when relying on Roon to be intuitive, as I do with most Roon set-up procedures. It is the opposite experience with Roon when using it, which is very intuitive. I am looking forward to getting out of this nightmare backup restore experience.

This is so, so, so. painful. I truly am going to give up if I can’t get this sorted by the New Year. I’m not going down the extortionate expense of the Nucleus as I’d prefer to spend the money on Audio equipment. However, I am considering a dedicated server and using my Zen Mini as an endpoint only.

To this end, my second request is some advice (which Knowledge base article(s)?) on restoring my Windows 10 Roon Core backup to a different dedicated device, which will either be another Windows 10 device running on an Intel NUC or a new Mac Mini. I not expecting it to be straightforward because I can’t understand how the backup knows where the music library is when restored to a new device on the network. The Roon software couldn’t even figure this out when being restored to the device my music library is stored on.

Thanks in advance for any help. Sorry for my frustration showing, I am trying to be calm.

@Robert_Borley, I’ve reopened your previous topic and merged so all this history is together for Roon’s @support team.


I have restored the Roon Database backup again.

When using the Roon Core on the Zen Mini, it seems to add my library as an entirely new library, reseting the history, I.E.not recognising any play history, tags, ratings, likes etc. It remembers everything from Tidal though. Does anyone know how to fix this? The restore seems to ignore pretty much everything about my music library. For example, the date added for my entire library is todays date (plus the loss of the tags etc.). It’s as though the restored Roon DB refers to a completly different library.

Apart from that it’s working. Just impossible to get the restore to work properly.

That isn’t because you Restored the Roon database. Roon is pulling your Tidal selections from your Tidal Favorites. Your Tidal music would be in Roon whether you Restored or not.

What do you have for this setting?

When you do the Restore, are you still also referencing the old location for your music files in Settings==>Storage?

Even the Roon Tags? Where are they stored, also in Tidal? I added a few dozen or so Albums from Tidal to my tags in Roon and it has remembered those from the restore. Pretty sure that’s not info stored in Tidal.

At what point would I do this?

I’m trying the restore again, from the Login screen without logging in.

Does anyone know how to tell Roon where the music library is, even though it’s on the same device as the Core (the Innuos Zen Mini)? Or should I not need to do this?

Roon’s Settings==>Storage is the way to tell Roon where the music is.

What does that look like?

What does “ library” look like?