Cannot import MP3

Roon Core Machine

Mac mini M1, macOS Monterey 12.2
Roon version (build 898) stable

Number of Tracks in Library


Description of Issue

Roon is not importing an MP3 file – It’s a favorite compilation of mine. I’m evaluating Roon to see if it’s something I want to use, and if I can’t play basic MP3 files this is an absolute non-starter for me. This file plays fine in Apple Music.

I’m able to drag it to the interface, a (+) appears, it asks me if I want to Copy, I say yes. After that I see nothing on the screen, no feedback at all. The file is simply not copied over. It does not show up in Recents list. It does not show up in the Skipped section of settings.

My network set up and devices should have nothing to do with this as it’s not even appearing in the library.

Is it possibly an older file that has Apple DRM?

Chapter importing music.

I have found that Roon doesn’t like some 32 bit mp3s or mp3s with nonstandard ID3 tags. Can you see what happens if you convert it to a different format in something like Audacity?

I converted it to AAC and it works now. I noticed there were a couple hundred other files that were skipped when Roon built my library. Y’all need to work on your file support. As this forum is the only support channel to the folks at Roon, I’m writing here to give this feedback.

I had a few oddball mp3 files that Roon struggled with. Most mp3 files worked just fine. For the oddball ones, I simply converted them to another format, and then Roon handled them.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.