Cannot Play Music on my Computer's System Output

Core Machine (Operating system/System info/Roon build number)

Small Green Computer (Asus) Sonictransport i7 Version 2.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

External Network:

ATT DSL Modem/Router (external router)
Manufacturer: ARRIS
Model Number: NVG589

Internal Network:

Netgear Orbi RBR750
Firmware: V3.2.16.6_1.4.4

The Orbi provides the internal router for both wired ethernet and wifi. The Sonictransport is connected via wired ethernet (MOCA - ethernet over COAX). All wireless devices on the internal network control Roon just fine. For instance, my 2019 MacBook Pro laptop will control Roon and play to either the stereo or to the System Output (either laptop speakers or headphones).

Desktop Computer:
Mac Pro 2013 Desktop Computer
Processor Name: 6-Core Intel Xeon E5

Processor Speed: 3.5 GHz
Number of Processors: 1
Total Number of Cores: 6
L2 Cache (per Core): 256 KB
L3 Cache: 12 MB
Hyper-Threading Technology: Enabled
Memory: 64 GB

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Streamer: Sonore Systems UltraRendu
Amp/DAC: Lyngdorf TDAI 2170 connected to Ultra Rendu via USB

Description Of Issue

I cannot play to System Output on my desktop computer (the Mac Pro described above). The Mac Pro is connected to the network via wired ethernet. System Output does not appear as an Option under Audio in Roon. My laptop computer does not have this issue. The issue has been a recurrent one on my desktop computer since Roon 1.6 was distributed. (Before 1.6 I never had this issue). I would like to solve it permanently, but nothing I know how to do has changed the situation at all.

Hi @Michael_Bade,

Do you have any antivirus or firewall running on the Core machine? If so, can you disable them temporarily — Is there any change when doing so?

Hi, Dylan - I have BitDefender (in its Netgear Armor version) running. All my computers run BitDefender, and all but one don’t have this issue. (We have 2 MacBook Pros and one Mac Pro, as well as 2 iPhones and 2 iPads). I currently have BitDefender Shield disabled and it makes no difference - the Mac Pro’s System Output doesn’t show up in the Roon Audio tab in Settings.

Hello @Michael_Bade,

Can you please check to see if the Apple Firewall might be blocking Roon and/or RAATServer from operating properly? These instructions from Apple provide more context on how to do this.

Hi, Noris - I have allowed incoming connections from Roon (I had it set up that way already). Still no System Output in the Audio screen in Roon.
Michael Bade

Hi @Michael_Bade,

Can you please share a screenshot of your Roon Settings -> Audio tab from the Macbook?

You can also try a full reinstall of the Roon app on the Mac, since the SonicTransporter is the Core, you should be able to re-connect and preserve the Core:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Connect to SonicTransporter Core

Hi, Noris - Here are the two screenshots. The Mac Pro is displaying the Sonictransport Audio output - it’s as if the Mac Pro is the Sonic Transport. I can’t see a way to get the Mac Pro to be a separate remote device, like the MacBook Pro is.

Here’s the MacBook Pro:

Here’s the Mac Pro:

The telltale is under Settings at the top of the image in each case. The Mac Pro presents itself as if it’s the Sonictransport. There is no “This Mac” area showing local computer system output options. I have desktop speakers on my Mac Pro that connect to the 3.5mm headphone jack. I want to be able to play through this output, either with the speakers or with headphones.

In the case of the MacBook Pro the 'This Mac area shows both the laptop speakers and the headphone connection (“System Output”.

Hi @Michael_Bade,

Thanks for those additional details! I would like to try to see if a RAATServer refresh can help with the symptoms you’re having.

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings -> Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have. On the Mac, can you please::

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Please let me know if this helps!

Hi, Noris -
No change - I followed the instructions and created a new RAATServer folder.

This is the screenshot after the new RAATServer folder was created. This is in Roon when I open it on my Mac Pro. If you notice the top of the image, the output settings of the sonictransport are correctly displayed for that device (which, of course, is remote). What is not displayed are the output settings on my Mac Pro, even though that is the device from which this screenshot of the Roon Audio tab was taken.

On my MacBook Pro I see both the sonictransport output settings AND the local output settings for the MacBook Pro (laptop speakers output and headphone output) in the Audio tab. What I want is the same thing on my Mac Pro, which would be the 3.5mm headphone jack.

Thanks in advance,
Michael Bade

Hi @Michael_Bade,

Thanks for running that test! I would next like to see if this issue reproduces if we temporarily change the Roon Core to the Mac Pro. Can you please use these instructions to do so?

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Hi, Noris -
I haven’t yet tried deleting and reinstalling Roon on the Mac Pro. Interestingly, I just half a hour ago downloaded Roon to my wife’s MacBook Pro. Everything set up beautifully in distributed mode - now, from her laptop and iPad she can play to any device in the Roon environment (except my Mac Pro). On my MacBook Pro I can play to her MacBook Pro, my MacBook Pro, and the Sonictransporter/Lyngdorf (which is our stereo). I cannot play from my MacBook Pro to either her iPad or my iPad.

I want to try uninstalling and reinstalling on each device that doesn’t fully see all the other Roon-installed devices in the distributed croon environment first - make sense?
Thanks in advance,
Michael Bade

This afternoon (Pacific Time, US) I tried deleting Roon from my Mac Pro and reinstalling it - the configuration did not change - I still cannot output to the Mac Pro headphone jack. (BTW, this was not he case for the first several years of my use of Roon - this particular configuration came with the 1.6 build).

Next, I will switch the Core to my MacBook Pro and report back.

1 Like

Hi @Michael_Bade.

I just wanted to check in with you here, have you had a chance to perform this test?

Not yet. I hope to this evening or tomorrow.

1 Like

Hi, Noris - what displays in Roon on both my MacBook Pro and Mac Pro are that Sonictransport is the Core and I’m signed in under my Roon alias (my email account). I have output options on my 2019 MacBook Pro of
a) System output (through a Thunderbolt connection with a dongle);
b) MacBook Pro speakers
c) ‘Lyngdorf’ (which is the stereo, via network connection through a Sonore UltraRendu).
d) AppleTV

On the MacBook Pro, Settings/About lists the MacBook Pro as the Remote and the Sonictransport as the Core (which is as things should be).

On the Mac Pro Settings/About ALSO lists the Mac Pro as the Remote and the Core is Sonictransport. However, under Audio the output options are listed as Lyngdorf and AppleTV, and output to the 3.5mm jack does not appear. However, the 3.5mm jack works just fine - I play AppleMusic through it, and I use it for audio (mic and sound) when I use Zoom or similar.

I installed the most recent.Roon update on both machines today. I have also checked System preferences to make sure that Roon is enabled whenever it appears. I have uploaded screenshots of Settings/About and Settings/Audio from Roon in my Mac Pro.As you requested (if I understood correctly) I have also disconnected and reconnected each computer from the Core. This did not lead to a change of state.

The endpoint I am trying to achieve is to have each computer be a remote, and display all output options. Now oddly enough I occasionally see the System output and PacBook Pro Speakers output of the MacBook Pro on the Mac Pro under Audio - this has happened for brief periods, once or twice - but never the other way around. It comes and goes, and is never stable.

Hi @Michael_Bade,

Thanks for sharing those screenshots. Typically when you cannot see audio outputs on a PC running Roon Remote, there is a networking or firewall issue preventing Roon from starting properly and running device discovery.

Do you happen to have any additional firewalls on the Mac Pro that you don’t have on the other Roon Remote? Are you using a VPN or firewall software like McAFee, Bullguard, Little Snitch, ect. on the remote with the issues?

In both cases (Desktop and Laptop) the Mac OS firewall is ON. In both instances, the firewall is set to allow incoming connections to Roon. (Same setup on both machines). I am not using VPN software. I am using Netgear Orbi as my internal router, and all machines show up as normal on the Orbi network management software on my phone, or when I log in. The key here is that both machines run exactly the same configuration, and I keep everything up to date.

Here’s what I have been mulling over: The Mac Pro used to be the center of my Roon setup - Roon ran on the Mac Pro, and I used my NAS as the data source for playback. When I got the Sonictransporter that changes. I started running Roon Server on the Sonictransporter, and I converted the Mac Pro to a remote by selecting that in the software. In the case of the laptop, I got that machine long after I had the Sonictransporter up and running. My question is: Could there be some legacy bit of code that is preventing the Mac Pro from fully and correctly functioning as a Remote? Is there some way of scraping Roon out of the Mac Pro’s SST and re-installing it from scratch, and seeing if that fixes things? It kind of feels like a hall of mirrors, but this is the one area where I can point to a difference between the two machines and their setups.

Hi @Michael_Bade,

I have provided instructions for this in the past, you are welcome to give this another try:

I looked over the thread and I didn’t see a mention of this, but how do you have your Orbi IGMP settings configured? As per our Networking Best Practices Guide:

Netgear Orbi Routers

If you’re making use of an Orbi router, we recommend unchecking Disable IGMP Proxying in your router’s settings. This setting can interfere with the ability for Roon Remotes to connect to the Roon Core.

Thanks, Noris - I will check the Orbing protocols tomorrow. However, all our other devices work fine (in addition to the Mac Pro, we have 2 MacBook Pro laptops, 2 iPhones, and 2 iPads). I don’t think the issue is in the Orbi, or it would manifest on all devices at the same time.

I will uninstall and reinstall on the Mac Pro on the weekend and let you know how it went. Sorry if I missed your earlier post.

1 Like

I upgraded the OS on the Sonictransport to V2.8 (a rather involved and tedious chore in 3 steps), and likewise updated Roon to the latest version on all devices. The Mac Pro was suddenly able to play music to the System Output. So, unless things revert unexpectedly the issue with the Mac Pro looks like it has been solved.

A note about the upgrade process. (I don’t know if what follows is due to the OS upgrade, the Roon upgrade, or synergistically a product of the two upgrades). As a result of the upgrades, I lost all references in Roon Storage to the folders on the Sonictransport watched by Roon. As a result, I had to re-identify the folders, and re-import all the “songs” (tracks). The outcome was that all of my carefully-assembled multi-disc Albums (those that I ripped from CDs) broke apart into individual CD equivalent individual ‘discs’. For instance, the 103 Symphonies of Haydn by the Austro-Hungarian Haydn Orchestra comes in something like seven (7) 4-disc and 6-disc sets. Each set of Haydn symphonies is now anywhere from a collection of single discs to a collection of a few two or three disc sets. All of these have to be re-assembled. That is just a single example - I have ripped something like 20,000 tracks and have 1.2 TB of music data . The album artwork is now a mess as well - all of the carefully-assembled artwork is now broken apart too. If the team could figure out how to avoid that in the future your customers would be grateful. I don’t want to be faced with this at each upgrade.

In any event, thanks (as always) for your help.