Cannot play Tidal music through Roon

I am having the same problem. I have reset my router and that did not help.
I have noticed that if I use a VPN things start to work and work for a few seconds and then fail again.
If you have any suggestions of what I can do I would appreciate it.

To add some more detail.
The problem is only with streamed content from Today and not content in my library. Tidal as a stand alone app on my M1 MacBook Air works just fine.
I added Qubuzz to my services and I have no trouble streaming content form Qubuzz.
This would appear to point to a network problem with Roon communications with Tidal.

Moved to its own support thread.
Please provide details of your setup, Core, Ethernet connection etc so support can better assist you.
Thank you

1 Like

I could never solve this problem when using my imac as a roon core. Switching to a sonictransport seems to have totally solved it. In my view, roon on macos is not a 1st class citizen…

1 Like

Hey @Robert_Swartz, thanks for letting us know. Also, thank you, @AceRimmer for moving this into it’s own thread :smiley:

As TheHammer mentioned in their reply, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Additionally, as a first step, are you able to change the DNS? We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS. Can you please give this a try and let me know if it helps?


My Configuration is M1 MacBook Air
Montery 12.1
16 Gig Memory
Library is on my machine
Roon .18 (884)
NAD M10 Amp
Using Wifi
Ubiquity Router
AT&T fiber Internet
I I changed my DNS to Google with no change.

When I installed Cloudflare’s Warp software and changed my DNS to, my Roon started working again.


Thanks for sharing! As a test, could you please try connecting your MacBook Air directly to the router via a wired connection to see if you’re able to start playback?

You can also try @Donald_Laackman’s suggestion, as well (thanks, Donald!)

I look forward to seeing how this goes! :pray:t3:

1 Like

I tried using a wired connection no luck it still does not work.

I also changed my DNS to Google and that did not work either.

Installing Cloudflare seems to fix the problem but it breaks the Mac Private Relay.
When I disabled Private Rely before the problem remained.

Roon suddenly is having issues with the Tidal connection.

CORE MACHINE - Innuos Zenith Mk2 (ver 1.4.9), 8gb Ram, Intel Core
REMOTES - Macmini M1 (macOS Monterey 12.0.1) with Roon Build 1.8 (build 884) / iPhone 11plus (iOS 15.1)
NETWORKING - Bell Home HUB 4000 gigabit 1.5 ethernet connection and multiband router
AUDIO DEVICES - Adi-2 Dac and Chord Hugo TT2/Innuos Zenith Mk2
LIBRARY - located on synology Diskstation NAS

ISSUE - I cannot play or search my Tidal library/account. I can see albums (total symbol) and sometimes when selected they play, but most often they do not. When I select artist discography there is a long delay and then the notice “Discography Unavailable - make sure your storage is connected or check your internet connection and streaming service settings”. My Tidal account is in good standing and works in the Tidal app and when I log in through my browser.

Can you please assist? Just happened very suddenly.


Roon prompted me to reconnect tidal a moment ago. Then it sort of worked intermittently. Then it seems that I’m getting an error connecting to Roon search, whatever that is - screenshots below. I note that Plex had issues with Tidal integration last week also - it was stopping people from logging in.

Screen Shot 2022-01-10 at 1.59.42 PM
Screen Shot 2022-01-10 at 1.59.47 PM

I tried everything and could not get Tidal to connect. Finally pulled the plug on Nucleus and turned it back on and it works.

Sometime a Full Reboot clears things up.