Cannot restore Roon to the same Windows machine


My Windows 11 based HTPC that ran Roon core/server and also served as an endpoint had crashed due to SSD failure. My music files are still in the same location - Drive F which is an external USB drive. After replacing the SSD with a new one, and reinstalling Windows 11, and making sure my music is still at the same path (drive F), I’ve installed the latest versions (same as before) of Roon server and roon media player. I had a recent backup at drive D, which is still there. After the installation was finished and Roon server was launched, I run Roon medial player.

At first screen I selected restore backup and pointed to the last backup. Roon started the restore process and finished “successfully”. After hitting “relaunch” , I ended up in a clean Roon installation asking me to log in. After logging in, I get a fresh install of Roon as if I didn’t just restore a backup.

I tried restoring once again but the same thing happens. Roon thinks restore was successful, but I end up starting from scratch.

What am I doing wrong here? Even the PC name is still the same. It’s the exact same machine only with a fresh Windows 11 installation on a new SSD drive.

Is my backup corrupted or is this a bug?

So far what you experiencing seems normal. After you restored and logged back into Roon, did you confirm your music library path and import your music from your Drive F? The database restore still needs to see the music, and you may need to verify the path to your music library to complete the restore.

1 Like

OK. It seems that Roon did restore my music, but it kept asking me to select a core from 2 identical ones. I tried once again and still ended up having to log in, but this time I was able to see my music. Also, for some reason, not all settings are restored. The theme for example had reverted back to white. Not sure why it keeps asking me to choose a Roon core from 2 identical options, in which one causes Roon to discard the restoration and the other doesn’t (after the 3rd try one core option could no longer be selected which made things easier). Perhaps It would have been a better idea to use a different name for this PC because Roon kept looking for the old one?

Hey @Eli_Barbie,

Ben with the support team here, how are things going? Are you still running into restoration issues?

Did you use any sort of time machine or backup cloning tool to format your new computer?


Thanks. This issue was resolved/ It was my mistake because after restoring the backup, Roon’s theme reverted back to white (this is most likely the only true bug) and I was asked to login, but after login in, I noticed that all my music and settings (except for the theme) were there. You may close this thread thanks.

I’m now experiencing a different problem where I cannot play “all tracks” or “albums”, or “artists” entirely (in sequence). Roon will only pick about 5050 tracks out of 100K+

Please see the last message here:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.