Can't connect to new install of Roon Core on NUC

Roon Core Machine

NUC7i3, 8gb RAM, 256 M.2 ssd with a fresh ROCK install

Macbook Pro M1 running Roon 2.0 build 1143

Networking Gear & Setup Details

Netgear unmanaged switch, Netgate SG-1100 router

Connected Audio Devices

Nothing connected yet

Number of Tracks in Library


Description of Issue

During initial setup, Roon on Mac and iPhone sees the Core, but says that it needs an update. I’ve updated the software a few times via the web UI and restarted everything, but it still won’t connect.
Any help appreciated!

You’re running a very very old version of Roon 1.7 on your Roon core (from June 2020). Where did you get that? Try downloading Roon 2.0 for your core from Roon Labs downloads site.

That’s approximately the age of the ROCK image. As ROCK is a closed OS, I don’t know what the OP should download from Roon’s download page – he can’t use any of that to update his ROCK AFAIK.

What’s wrong with this?

That he obviously already has done that (installing ROCK) and the ROCK image from August 2020 comes with exactly that old Roon 1.7 build 571?

That wasn’t obvious to me because I have no idea what version of Roon is included with that download.

I used this in early October to reinstall ROCK on my Nucleus. Then, Danny did the conversion from ROCK to Nucleus.

Try to follow the instructions found when you follow the link below, maybe this will allow your ROCK to update to Roon 2.0:

Thanks for these suggestions. I did get the link to the ROCK install image from the ROCK Install Guide.

I’ve followed the instructions on the Roon 1.8 <-> 2.0 Migration FAQ- adding a branches folder and then copying the roon_2-0 file into that and renaming it to ‘roon’. Rebooted, reinstalled the OS using the web UI button, but everything is still the same as before. Roon on the Mac and also on iPhone won’t connect to Core, saying it needs a software update.

Hi @Sean_Dungan,
I’m tagging Roon’s @support team for you, hopefully they will be able to diagnose why ROCK will not update to Roon 2.0.

1 Like

After the weekend debacle where Roon downgraded a working ROCK with Roon Server 2.0 to a 1.8, I downloaded ROCK from the install guide.

That image of ROCK is for RoonOS 1.0 with Roon Server 1.7. I successfully updated to Roon Server 2.0 when prompted. So, until Roon sees fit to update the ROCK image, it must be done that way.

Before I did all that, I tried to follow the instructions in the Migration FAQ. They didn’t work for me, nor for some others. Dunno why.

Doesn’t matter, just install ROCK from square one and update when prompted. If you’re prompted to retry, do so.

Thanks for these ideas. I’ve re-installed everything several times, including re-flashing the usb drive from a newly downloaded image. Hit all the update buttons, rebooted multiple times, unfortunately getting the same results.

Did you change any network settings, or move to a new subnet or VLAN before installing on the ROCK?

I had the exact same issues after moving my ROCK to a new network. After reinstalling I couldn’t get the ROCK to update to v2. Once I moved it back to the original network it happily updated.

Ideally the ROCK image would be the current version rather than 15 months old.

Interesting that you had the same symptoms… I haven’t moved it. Installed ROCK in this LAN and it’s been here the whole time. No VLAN.

I’m going to take it to work today and see if it’ll connect there.

Have you done a re-install from the admin page?

Yes, when I do this it says that the system has been updated successfully, but nothing changes.

Well, that was interesting. I took the ROCK NUC to work, fired it up there, and was able to log in, everything seemed to work instantly. Brought it back home, reconnected to the LAN here, and it worked immediately. No idea why!

However, something still seems to be amiss. After adding music files (25,182) via attached usb drive, Roon has identified none of them after 45 minutes, the wheel is just spinning. Also, Roon can’t connect to Tidal. I can login to Tidal successfully w/in Roon, but back in the app the wheel just spins. Still some kind of trouble connecting to the outside world? I’m wondering if there is some setting in the Netgate firewall that needs to be changed… any help from @support will be appreciated!!

There is nothing you can change in Roon. It may be that Netgate should be where you seek support if you don’t know how to enable it to let Roon through.

Hi @Sean_Dungan,

Here is our document on what should be allowed via your firewall or AV. I hope this helps!


But there is no firewall on a ROCK, as the OP can connect a (remote) Roon to control the ROCK (not an issue with the remote), the issues regarding Tidal and music identification are between Core and internet and nothing (no ports) should be required to be opened on the edge firewall (router) for basic Roon Core functionality, I don’t see how this should be useful for the OP.

I go with Henry here. Something in the OP’s network is blocking access (specifically to the Roon Labs cloud [still hosted by Google cloud?] maybe?). So maybe the router (Netgate) or some additional security device (like a Pi-hole for example).