Can't connect to Roon Core from Android remote. Roon Server log files with errors every 10 secs

Core Machine (Operating system/System info/Roon build number)
Core Machine: An up-to-date Windows 10 PC: Intel i7 4770K APU, 32GB ram. Runs 24x7.
Roon Apps Roon Server and Roon App on Core Machine, version 1.8, build 764. Roon Remotes on Laptop and Android / iOS phones.
Library: FLAC files on Roon core machine + Tidal. Roon database on Samsung 256GB SSD. FLAC files on separate hard disk.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ASUS AC3200 router, Roon Core on 1GB ethernet. Multicast routing enabled. Remotes on Wi-Fi. No network problems.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

KEF LS50W, KSF LSX, headphones on PC/laptop/phone - sometimes via Chord Mojo. Speakers on ethernet or power line.

Description Of Issue

My Samsung phone can’t find the Roon Server unless I start the Roon App on my PC first. The Roon App and Roon Server are on the same PC. Also it takes ~15 seconds for the Roon App to start on the PC. Once the PC Roon App has started Roon seems to work OK and plays music and can be found by my phone. I’ve also noticed that roughly every 10 seconds the Roon Server is generating a new log file with the error ‘Object reference not set to an instance of an object’ - see log extract below.
Although I’ve seen similar errors reported elsewhere, I couldn’t find a fix. Which is why I am reposting.

Log File Extract …

Exception Source: Roon.Broker.Core
Exception Type: System.NullReferenceException
Exception Target Site: State…ctor
Exception Message: Object reference not set to an instance of an object.
Exception Data: none

–[ Stack Trace ]------------
Sooloos.Broker.State…ctor(BrokerConfig config, StorageManager storage)
Roon.Broker.Core.DLL, IL 228, N 777
Sooloos.Broker.Modules.Core.Create(BrokerConfig config, String platform)
Roon.Broker.Core.DLL, IL 108, N 244
Sooloos.Application.Main(String[] argv)
RoonAppliance.exe, IL 888, N 1324

03/12 11:18:02 Error:
Local Time: 03/12/2021 11:18:02 +00:00
Device Serial Number: 51AE585B-BE1E-449F-9ADB-607CB49EEFD4
Roon Version: 1.8 (build 764) stable
OS Version: Windows 10

Hi @David_Burdett,

Thanks so much for sharing details about this issue - sorry you’ve ran into it in the first place and for the delay in getting back to you :pleading_face: I wish it was going to be much sooner.

I was wondering, when did this behavior start? Were you ever able to use your Samsung phone as a remote with Roon? Have you taken a look at these troubleshooting steps?

Thanks in advance :pray:

Hi Rebeka

The problem started about a month ago. I’d had to stop using Roon for a while, so I’m not sure of the date. My Android phone has been working successfully with Roon for several years and I haven’t made any changes to the network. I’d already tried the suggestions in the “Why can’t Roon Remote Connect?” post before I posted the original details of the problem.

Anyway, I can connect with my Android phone sometimes under specific circumstances as described, i.e. when the Roon App [1] is running at the same time on the same PC as the Roon Server [2]. Note both apps are currently version 788.

To try to help I’ve just tried the following:

  1. Checked I could connect remotely. I could connect with my Android phone if both apps are running.
  2. Stopped the Roon App. I couldn’t connect from my phone. Note, I couldn’t connect from my laptop either.
  3. Checked the Roon Server Logs. The error I had before was not shown.
  4. Restarted the Roon App. It took about 10 seconds. I can now connect from my phone.
  5. Stopped the Roon App again without quitting my phone app. The phone shows a “lost connection” screen and asks me to select another core.
  6. Stopped (quit) the Roon Server, using the task bar.
  7. Restarted the Roon Server. Checked the Roon Server Logs and it looks like it’s done an upgrade.
  8. Tried to connect using my phone. Screen shows “Remote Connection. Waiting for remote core … It’s taking longer than normal …”. I gave up after ~ 1 minute.
  9. Started the Roon App on my PC. I can now connect from my phone.
  10. Rebooted the PC and checked the Roon Server Logs:
    • The first Roon Server Log after the reboot had the same error as I originally reported.
    • The second (current) Roon Server Log (started 6 secs later) and seems to have no errors
  11. Tried to connect using my phone again. It won’t work as it can’t find the server
  12. Started the Roon App on my PC. The phone app then immediately conects



[1] C:\Users\David\AppData\Local\Roon\Application\Roon.exe
[2] C:\Users\David\AppData\Local\RoonServer\Application\RoonServer.exe

Bumping this problem as it hasn’t gone away. I still can’t connect to my Roon Server unless the Roon App is also running on the same PC.


Hi @David_Burdett

When you launch the Roon app on the PC, can you go to Settings > General and share a screenshot of what you see here?

Hi Dylan

This is what I get …



Hey @David_Burdett,

I wanted to thank you for following up and sharing everything that Dylan’s asked for. Not only has the weekend come in the way (support is open Monday-Friday), but also Dylan had to take the week off as he was not feeling well.

Please, bear with us a little while longer. You should hear back from him soon :pray:

I think I might know what the problem is, i.e. I have two copies of the core running on the same PC: one as a Roon Server and one as a Roon App.

The problem above occurs because my phone can’t always find the correct version of the core.

I don’t think there is much value in Roon Support chasing down these now, non-existent, problems, so let’s close this topic and continue in this new one.