Can't enable MSB Analog DAC via USB on windows 10 PC

I’m trying to connect my MSB to Roon via USB using a windows 10 PC.

I can’t ‘enable’ the MSB via the ASIO driver that shows up in Roon audio settings. I keep getting an error saying failed to init device.

Can someone please help.

Hi @Aditya_Munim ---- Thank you for the report and my apologies for the slow response. May I kindly ask you to please try the following to see if we can trigger a change in behavior (see below). Thanks!

  1. Open the “audio” tab found in settings and disable any WASAPI zones.

  2. Make sure that the ASIO zone is engaged.

  3. Try to playback and confirm if the device initializes.


Eric thanks for the email, however, I tried your suggestions and could not get the DAC enabled.
There are two issues Im facing in the “audio” tab.

The Output settings- I can’t enable it. I get an error saying “device not found.”
I tried to restore default settings but still face the same problem.
I reloaded Roon software, but that to did not help.
Can you please walk me through settings for this section.

The MSB ASIO driver- when I try to enable it i get an error saying “device can’t be initiated.”
I have no problem with using my MSB DAC while playback through USB on JRiver. Not sure what settings are needed here.

Appreciate the help.

Hi @Aditya_Munim ----- Thank you for the follow up and the feedback. Both are appreciated!

ASIO is a pretty old audio interface, and has no ability to track “who” is in charge of the audio device at the moment and switch to the other devices that are requesting control. Based on your observations this feels like the problem here. ASIO is getting confused because of multiple request from various devices.

I would suggest making sure that nothing else is trying to access ASIO while roon is running. Disabling JRiver for example would be a good place to to start and any other applications or programs that may try taking control of the system. Then I would turn the DAC on and off, launch roon and try to reproduce.

To better understand what may be causing this behavior, may I kindly ask you to please describe your current setup, in detail, as seen here. You’ve already made mention that you are making use of an MSB DAC as well as JRiver :thumbsup: :clap: I would like you to please expand on this information, as the more detailed and specific you can be, the better.