Can't find Core on Android (Existing issue for a while)

As an alien I can’t survive outside of area 51 so I’m afraid that’s not possible


Hi @Nyquist,

Apologies for the radio silence on my end, we have been quite busy over the last few days:
(Roon 1.7 (Build 505) Is Live!)

I would like to escalate your case to the technical team for review. I’m still going through all the information you posted above and writing up a ticket for this issue, but let’s start off with some timestamps.

Can you let me know the exact local time + date when you next experience this issue? Preferably if you can let me know 3-5 timestamps of when this issue occurs I can enable diagnostics and take a look to see if there are any additional clues in your Core + Android Remote.

As of now, first timestamp.
local time 21:19. November 26.
No connection

More will follow

November 26 - 21:25
It made a connection after 6 minutes searching

21:32 after being in standby, no connection, this time it stays unconnected
Audio playback works, I can see my phone as endpoint but not as remote.

21:45 still searching - rebooted Roon server, my phone instantly made a connection again
21:47 after android standby, no connection, rebooted Roon server again and voila connection. I’m beginning to see a petteren here. Will try this over a longer period of time. Will report back tommorow

Hi @Nyquist,

Thanks for sharing those previous timestamps. I was wondering if the pattern is still on-going? As a side-note, I have activated diagnostics mode for your account and what this action does is automatically upload a set of logs to our servers for analysis.

Hi Norris,

I have been very buisy, but yes it still goes on in the same pattern. I will make more logs wednesday when I have a day off. Thanks for your help

1 Like

Hi Norris,

Just started Roon core at 11:25 (dec 4)
android phone cannot get a connection. I’m just testing with my Sony Xperia Compact phone now, the other android devices are not mine, they belong to my family.

11:45 phone is still looking for the core, will try rebooting the core
after rebooting Roonserver there is a connection. Same patteren as always. Lets see how long it stays connected

11:56 lost connection to the core after accidantically killing the android app and starting it again. Unable to find the core again. After rebooting Roonserver it does find the core. It seems that it can only find the core if the android app is running before Roonserver starts. If Roonserver is allready running it is not able to see the core. It stays connected when the phone is standby untill android goes into a deeper sleep state.

what are your DNS and DHCP settings?

DHCP server is my ASUS rt-ac88u router. Roonserver PC has a fixed IP, android phone via DHCP
DNS server is (asus router ip)

same DNS entries for the core? you should also have an external DNS like or for public discovery

if you run an app like fing or lanscan does it see all the devices on the network including the core?

The DNS server is obtained automatically, works for each and every other device and app I have.
Just discovered the core computer isalso on DHCP, must have changed that a while ago while trying to fix the android connection problem


13:44 after the phone has been a sleep for a while, no connection. Well, I think the patteren is clear by now.

Yes core is discoverd by any networking tool, it is discovered by samba share, be remote desktop, by any othere roon remote.

I have just tried changing the DNS server from the ISP dns to Google dns, same pattern. Right after changing the dns server android connects but it can not connect again after that. Same patteren.

Hi @Nyquist,

Thanks for sharing that additional information. Interesting observation that restarting RoonServer appears to allow the Android device to connect. Do you by any chance have any active firewalls on your Core? I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path. I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have.

If that doesn’t help, I can confirm I have the necessary logs and have asked QA to review them.

Hi Norris, thanks for your reply.
I do have native win10 windows defender running, no other firewalls or virusscanners on the core. I also have Asus AI protection running on my router. I have dissabled both a couple of times but that did not help. I guess it is still a good idea to add Roon to the exeption rules.
Since the 1.7 update I have at least a connection about 50% of the time and it stays connected as long as the app is running. Before that it was simply impossible to get a connection 90% of the time.


Last week I discovered that one of the two cores on my Asus router had a constant load of 100% after a firmware update that I did a couple of weeks ago. This is a known problem with Asus routers it seems. In an effort in trying to fix it I gave the whole Aimesh setup (three asus routers) a factory reset and reverted back to the old firmware. This solved the problem and so far it looks like my android devices are working stable now for the first time in years. Prior to 1.7 release nothing ever worked, it all seems to be o.k. now.

Hello @Nyquist,

Thank you for the update here! It does seem like the network is playing a part here, so do let me know if the system remains stable after further testing with the old router firmware.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.