Can't find Core on Android (Existing issue for a while)

Well, that didn’t take long. Android was working for about two hours and then all of a sudden, pop, can not find Roon core anymore, just like in the last four years.

1 Like

Hi @Nyquist,

I have split your post into a support thread so that we can take a closer look here.

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Is the behavior the same if you reboot your Core, Networking Gear and Android device?

That’s got to be your network or device, I’ve had zero connectivity issues with Pixel 2 since installing Ubiquiti kit throughout all running the same SSID. Same with Fire 10 and Galaxy 18". What device are you using?

My FiiO M11 is a happy camper too

Well I give it a try.

I mainly use an Sony Experia Compact model H8324 with Android Pie 9 latest version.

  • My core computer is a ASUS ZM-87M-plus motherboard with a core I7 -4770-s quadcore desktop processor running windows 10 education edition version 1903 build 18362.476. on a samsung 256 GB 840 pro SSD

  • Music is stored internally on a 1TB samsung SSD

  • Playback device is a Yellowtec PUC2 LEA connected to a JCAT pcie USB card. No other hardware is attached to the computer (well except for screen, mouse and keyboard offcoarse)

  • This PC is dedicated to audio and runs besides Roon my DEQX control software, various loudspeaker measurement software, various music tagging software, various music players and also Tidal, Deezer etc. No office, no netflix, no plex etc.
    No Audiophile optimizer of any kind, just plain windows.
    No antivirus etc execpt from the build in firewall and windows protection (does not help when turned off)

  • I’m running Roon server on this machine as well as the full Roon app

I do not use a streaming device as my main listening device. I do use a raspberry pi and a chromecast in other rooms.

  • Library consist of 4420 albums of which 298 come from Tidal

Network: Mesh network with ASUS RT-AC88U main router with two RT-AC66U B1 mesh nodes. Network is rebooted regurlary to keep thing up to speed. The core computer is connected via ethernet. Before this I had one router, ASUS RT-AC87U, same problem. There are no switches in the network, only routers.

The problem:

The problem persist over 4 years now, so also with different windows OS builds, different Roon OS builds and different Android OS builds.

Things I have tried thus far.

  • Moving Roon core from my windows PC to my macbook pro. Did not help.
  • Moving Roon core to a mac mini running Linux. Did not help
  • Connect a router directly to the core with nothing else on the network connected, did not help.
  • Tried two other types of routers, did not help.
  • Tried every possible solution to be found here on the forum, did not help either.

Android sometimes connects and when it does it is lightning fast. Sometimes it will stay connected for a few hours and then it pops out and cannot be found for days, even weeks in a row. I use Remote Desktop nowadays to connect to the Roon core computer which just allways works. I had high hopes when I saw that Android made a direct connection after updating to 1.7 but it only worked for an hour or two, again. So the problem is not with build 500 like the topic title suggest, it is persistent among all build the last 3-4 years.

Before I had a Samsung Galaxy phone which also never worked. My girlfriend has a Sony Xperia compact that does connect more often but allways had a playback problem. Have not checked it with 1.7 release yet.

Hi @Nyquist,

Thanks for letting me know those details and for confirming that this issue has been ongoing, I have updated the thread title to reflect this.

Since all of these are ASUS routers, have you made sure to “Enable Multicast Routing” as per our Networking Best Practices Guide? It sounds like something might be going on with the multicast routing in your setup, I would also try toggling IGMP Snooping and/or IGMP Proxying to see if that helps.

Hi Noris,

thanks for your reply. I have allready done that some time ago.
Here are my router settings for the 2.4 GHz band

and for the 5 GHz band

I would have tried with IGMP snooping disabled as a test.

Tried that, does not make a difference

@Noris, Did you have time to look into this? Yesterday Android worked all day long, lightning fast with not any hickup at all. Today it can’t find the Roon core anymore, again. Nothing changed in the mean time. Haven’t touched anything. It’s behaving like this since the first time I got Roon. In the mean time I had moved to a different core computer, bought new routers, a new android phone and new cabling, basicly a completely different system than three years ago but the problem still persists. It leaves me clueless.

Maybe move from Area51!

As an alien I can’t survive outside of area 51 so I’m afraid that’s not possible


Hi @Nyquist,

Apologies for the radio silence on my end, we have been quite busy over the last few days:
(Roon 1.7 (Build 505) Is Live!)

I would like to escalate your case to the technical team for review. I’m still going through all the information you posted above and writing up a ticket for this issue, but let’s start off with some timestamps.

Can you let me know the exact local time + date when you next experience this issue? Preferably if you can let me know 3-5 timestamps of when this issue occurs I can enable diagnostics and take a look to see if there are any additional clues in your Core + Android Remote.

As of now, first timestamp.
local time 21:19. November 26.
No connection

More will follow

November 26 - 21:25
It made a connection after 6 minutes searching

21:32 after being in standby, no connection, this time it stays unconnected
Audio playback works, I can see my phone as endpoint but not as remote.

21:45 still searching - rebooted Roon server, my phone instantly made a connection again
21:47 after android standby, no connection, rebooted Roon server again and voila connection. I’m beginning to see a petteren here. Will try this over a longer period of time. Will report back tommorow

Hi @Nyquist,

Thanks for sharing those previous timestamps. I was wondering if the pattern is still on-going? As a side-note, I have activated diagnostics mode for your account and what this action does is automatically upload a set of logs to our servers for analysis.

Hi Norris,

I have been very buisy, but yes it still goes on in the same pattern. I will make more logs wednesday when I have a day off. Thanks for your help

1 Like

Hi Norris,

Just started Roon core at 11:25 (dec 4)
android phone cannot get a connection. I’m just testing with my Sony Xperia Compact phone now, the other android devices are not mine, they belong to my family.

11:45 phone is still looking for the core, will try rebooting the core
after rebooting Roonserver there is a connection. Same patteren as always. Lets see how long it stays connected

11:56 lost connection to the core after accidantically killing the android app and starting it again. Unable to find the core again. After rebooting Roonserver it does find the core. It seems that it can only find the core if the android app is running before Roonserver starts. If Roonserver is allready running it is not able to see the core. It stays connected when the phone is standby untill android goes into a deeper sleep state.

what are your DNS and DHCP settings?