Can't find roon ready devices

I’ve just begun trial period with Bluesound Node 2. Core is on 64-bit Windows 10. ROON version is current. Other player is NAD T758 V3, with up-to-date firmware and installed Bluesound upgrade. The Node 2 also has most recent firmware version. Temporarily using Android phone for controller with BluOS and ROON apps.

Configure found both players the first time I made a brief test from PC. ROON played something on Node 2, couldn’t switch to NAD receiver. This was the case for both phone and PC. Didn’t try again for a few days. Now Node 2 is gone, T758 zone is still listed, still doesn’t play. Tried configure on both phone and PC, ROON hangs in search on both. PC is only working player.

Bluesound works with phone app. Both players OK with TIDAL, my music files, Tunein and Spotify, so it doesn’t appear to be network problem.

Have you got internet over mains device? I had to reboot one of mine last night when I lost a zone.
I’m no expert, just an idea.

Hi @Ron_Bierman ----- Thank you for the report and sharing your feedback with us. Sorry to hear of the troubles.

Moving forward, to help me better understand what could’ve happened here, may I very kindly ask you to please provide me with the following:

“Configure found both players the first time I made a brief test from PC. ROON played something on Node 2, couldn’t switch to NAD receiver.”

  • When you say that NAD receiver could not be selected, what exactly did you notice in app? Was the NAD still present in your “audio” tab? If you went to the “zone” picker, were you not able to click on the NAD zone?

“Now Node 2 is gone, T758 zone is still listed, still doesn’t play.”

  • When the T758 refuses to play, do you recieve an error message in Roon? Does the cursor/time counter move? Does Roon skip over the track(s) completely?

  • Please provide screenshots of your “audio” tab and your “zone” picker.

  • When you notice this behavior, ONLY Roon is running, correct? In other words, there are no other applications (i.e BS app) trying to take control of your audio zones, correct?

  • During your troubleshooting of this issue have you tried power cycling your Roon core, endpoints, and networking gear?


Chris, Thanks for taking time to make the suggestion. I do have Internet on core device. No problem getting TIDAL, etc.

1 Like

I get “Transport couldn’t connect to HQPlayer” when I click to play in zone with NAD receiver. The zone is listed with the track that would be played. I’ve never tried to use HQPlayer, as far as I know.

The indicated “Black Codes” was playing on my PC when I took these screen shots. “Family Room” is NAD receiver.

The receiver and PC have been recycled, not Node 2 and router. I’ll recycle all after I send this reply.
No BS network shows when I display available networks on PC or phone. But I don’t understand how BS network integrates with my Wi Fi, so I can’t say there is no interference.

After the reply above the line, I shut off power to router, Node 2, and NAD receiver, and rebooted PC. Same result. I cleared cache and rebooted ROON. Still can’t find Node 2 or switch to receiver (Family Room Zone). Same HQPlayer error on latter.

Hi @Ron_Bierman ---- Thank you for the follow up and providing the requested feedback, both are appreciated!

Moving forward, I can see that there is some confusion here, as “HQPlayer” is not your T758. HQPlayer, as stated in our knowledge base, is a separate piece of software that integrates with Roon and can act as a separate audio zone(s). Based on your screen shots, it is apparent that neither of your network endpoints (T758 v3 or the Bluesound Node 2) are being discovered by Roon.

In light of the above, can you please provide me with the following:

  • Please describe your network configuration/topology, as well a providing insight into any networking hardware you are implementing. I want to have a clear understanding of how your devices are communicating and what tools (i.e router, switches, repeaters, extenders, etc) are being used to make these connections possible.

  • During you troubleshooting of this issue have you tried testing with either the Node 2 or the T758, hardwired directly to your router to see if the application is able to discover the devices on your network?

  • You can also try and app like FING on the phone to scan your network looking for devices that it can see showing up its self in the process. If you are going to give this a shot, please make sure your Roon core is active, as well as both of your endpoints (T758 v3 & the Bluesound Node 2)


Thanks again for quick response.

Both Node 2 and NAD receiver have wireless connection to Netgear R700 dual-band router on lower speed band. Node 2 also has RCA connection to Onkyo receiver which is hardwired . PC (core) is hardwired to same router. Node 2 and NAD receiver appear in connected devices list of router, though only by MAC address. Both are used successfully for Internet access. I’m not implementing any new network hardware, and have no network hardware other than router.

Hardwire test of NAD would take more work than I’m going to do because of its connections and distance from router. I may try hardwiring Node 2. But it was discovered the first time I searched with ROON, and I was able to play something from TIDAL. I haven’t changed any hardware or software or connections since then. Both players continue to work with BlueSound.

I’ll try FING on phone.


The T758 is listed as networked. Node 2 remains undiscovered.The receiver does play a TIDAL track, but note the red “Uncertified.”

FING (neat app, thanks for suggesting) finds both ROON Ready devices–T758 and Node 2.

Hi @Ron_Bierman1 ---- Thank you for the follow up and sharing the observations you have made.

Moving forward, from my understanding the T758 is a certified Roon Ready device but I am curious if there is something about “V3” that we should be aware of. In light of this I have placed a note with our techs and await their feedback.

Furthermore, in regard to the FING test, just to confirm. Your core machine appeared in the list of devices discovered, correct?


Yes. The core was on the list of devices FING found.

As you probably know, the V3 hasn’t been on the market for very long.

Hi @Ron_Bierman1 ----- Thank you for touching base with me and providing the requested feedback. More importantly, thank you for your patience. My apologies for the wait here.

Moving forward, I can confirm that the “uncertified” message you are seeing next to the NAD T758 has been addressed and a fix has been set into place pending our next release.

Furthermore, our techs would like to take a look at your Roon and RAATServer logs, to see if we can determine why the Node 2 is not appearing as a “networked” endpoint in Roon. Please use the instructions found here and upload us a copy of your Roon and RAATServer logs.



It would be helpful to newbies if the otherwise well-written instructions for sending the log files were more complete in the knowledge-base “logs” entry, for Windows anyway. It took me a while to realize I had to change the hidden files option and then zip the logs. The latter will take me a while, since I haven’t zipped anything recently and need to review how to do it.



I have the zipped logs in Dropbox. Not sure what address to share with.


Hi @Ron_Bierman ---- Can you please create shared dropbox link containing the logs and then provide the link here?


Awesome, thank you @Ron_Bierman! Confirming that the logs have been received and are in our queue to be evaluated by a member of our tech staff.

Once my report has been updated and passed back, I will be sure to share the team’s thoughts/findings with you in a timely manor. Your patience is very appreciated!


Hi @Ron_Bierman ---- Thank you for your for your patience while our team has been looking into to this issue with the Node2 not appearing in the application.

Moving forward, our techs have noted in their update to me that they are seeing various traces in the logs that indicate a refusal to connect with the device. In light of this, the team has asked if you are by chance making use of any security settings or application that could be having influence on the softwares ability to communicate with the Node2.

Additionally, our techs have also asked if you could please share a screenshot with us from the FING application on your phone and if you don’t have the Bluesound app already installed on your core machine, would kindly do so and verify that application is able to discover the Node2 from that device.


I do use Norton on phone and PC, but that doesn’t interfere with BlueSound for Tidal or Spotify. I don’t have the BlueSound app on the core machine and haven’t gotten to that or Fing screenshot yet. Will do in coming week.


Sounds good @Ron_Bierman, I will be on the look out for your follow up!

Furthermore, while I understand Norton is not having any affect on your TIDAL or Spotify usage, I would still recommend temporarily disabling this function on the mentioned devices to see if this action triggers any changes in behavior with the Node2.


ROON app on core does find the Node2. Core (a PC) is running Norton. I didn’t turn it off.

I only recently installed Norton on the Samsung phone and the ROON app wasn’t finding the Node before it was installed. I did a force stop any way, still no luck. FYI, via PC ROON app, I’m listening to TIDAL the Node2 zone the Android app can’t find as I type.

The Fing sees it this way:

Network Name 6/7 (Devices connected, NAD is offline)

R7000 (Gateway) Netgear R7000
Speaker/Amp Logitech Squeezebox
Samsung Galaxy S7 Samsung Galaxy S7 Edge
Node2-CEEB BlueSound
TX-8050 Onkyo
T758 Wistron Neweb