Can't get apple music/itunes over to nucleus+

nucleus+ roon version 1.7 build 571 ethernet connected
ITUNES on MAC desktop with CATALINA OS 10.15.5
[Added by mod from duplicate post]

so I jumped in with both feet trying to set up a system apart from my home MAC computer and bought the nucleus+ put in a samsung 860evo ssd 4tb drive and got the lifetime subscription–totally enjoyed music on tidal subscription but then tried to get my large iTunes library from my MAC on to the nucleus and hit a brick wall

the roon documentation I have found so far talks about going into iTunes and authorizing 3rd party apps to access my iTunes library xml file but when Apple changed from iTunes to Music, one of the things that changed is that option to go into the advanced setting and check a box to do this is gone

even called apple support and was told no such access allowed and would have to go back to ROON
for help. So what now since I can’t access this XML file which is what the nucleus seemingly uses to import songs and playlists created in iTunes/Music.

also should have said my MAC has the Catalina OS

Have you followed this?

tried to but that solution assumes you can share the xml file with 3rd party apps which you can’t do now with catalina ØS

Hi @clyde_rickard,

As mentioned in the article that Ged mentioned, you’ll need to export the library to an XML file. The XML file just needs to be in the Roon watched folder where your Apple Music library is. The XML file can still be imported like it was with iTunes, but it just doesn’t automatically update like iTunes did.

but that is where i end up stuck as the KB description talks about checking a box that does not exist or that I cannot find–maybe this is easier, do you know anyone I can hire, and pay either by the hour or a reasonable flat rate price to get on the phone with me and walk me through step by step getting my iTunes library over to my 4tb hard drive in my nucleus plus so the nucleus plus will operate as a stand alone core that can access both the ROON/TIDAL material and my iTunes library and playlists

Hello @clyde_rickard, I’d like to give you a hand with this one. You’re looking for the “Import iTunes Content” option, right? Once you’re in Roon, you’ll want to go to the “Settings” window by clicking the 3 horizontal lines at the top, left-hand corner of Roon. From there, settings is the 3rd option from the bottom.

You’ll need the options under “Settings > Storage” to get to the place where the guide is showing you to click the vertical ellipses and enable the setting. Of course, this is if you already have a watched folder set up for the location where you’re storing the tracks. If not, please let me know and I’ll make some more screenshots!

thank you so much for responding and taking an interest on helping me reach the point where I can enjoy the full function of your software product and hardware. My iTunes tracks (15,500 songs -375 GB) currently reside on a IMAC desktop machine running Catalina OS 10.15.5— my ROON core is of course the nucleus plus I purchased from your company two weeks ago on which I have mounted a Samsung EVO 860 4TD SSD

so i guess the first step i need help with is this issue of a watched folder—not sure how to set that up and does that mean we cannot get my iTunes library either transferred entirely off the desktop or copied and added to the SSD on my nucleus —my goal is to have your hardware accessing both music from TIDAL as well as my old iTunes library of songs and playlists in a stand alone fashion without having to access the IMAC desktop machine-can you help me do that or will we always need to link your machine with the desktop so that both of them have to be turned on and be running to hear my old music library

Hello @clyde_rickard, let’s get you set up! I do recommend taking a read of our Nucleus guide in general, but let’s focus on the step of getting the watched folder going before we start moving files.

Make sure your SSD is ready to go with this guide.

Once that is done, you should be able to access the watched folder (called “Music Folder” in the screenshots) over the network and you can drop in your files and XML playlists. Take a look and let me know if you get stuck at a step. You can copy the name of the text or send me a screenshot and I’ll do my best to explain.

Nuwriy–thanks for the update i will try this right now

i completed the formatting and the storage tab now shows the nucleus+Internal storage label so I guess the next step you could help me with is finding/accessing the folder to watch so I can get the nucleus core playing my iTunes library

Please follow up with me this week so that we can try to get my iTunes off my MAC and ported over to the nucleus plus—my ssd is formatted so the next step I need help on is getting the nucleus to look at the right folder

Hello @clyde_rickard, you can do this via SMB! Here’s the article. Let me know if you get stuck and I’ll help!

Finally making some progress on my end–found the music folder and got it to be showing on the shared folders screen and then moved on to do the things outlined at the end of your article, and when went through the process to add network share and filled in the boxes with the smb info and username and password and then hit the blue tab at the bottom of the add network share screen i got an error code in red that said
“There was an unexpected error: Invalid Network Path”

I tried the cure mentioned to uncheck and check the box in file sharing screen and then re-entered my info in the add network share boxes and got the same code

Hey @clyde_rickard, can you send me a screenshot of what you’re entering? Usually one of the items is out of place and should be easy to fix if we take a look at it. Thanks!

screens for the main actions

![IMG_2551|666x500](upload://v1N 5o6bw1soDMgz6cKWoujbweVS.jpeg)

Hey @clyde_rickard, I’ll run this by the team so we can see what’s going on but I do notice you have “usrs” instead of “users” in that path. Does changing that help?

I stared at that myself when i tried set to this up originally and used that version of that word because the that was the way sharing screen showed it for my computer name----but since “usrs” did not work i just tried it again with “users” instead–sadly, it still does not work

In the Network address field, you seem to have just specified the remote computer (usrs-iMac-2.local). You don’t seem to have completed the address with the name of the share folder itself…

So you’ve specified the town, but not the street and house number?

1 Like

OK so do i just add after iMac-2.local a location such as


or do I add an entire folder address after iMac-2.local such as