Can't get Web Display with 2.0, Roon Server

Roon Core Machine

Windows 11 10.0.22

Networking Gear & Setup Details

Ubiquiti Edge Router 4 - hardwired to the Roon Server

Connected Audio Devices

4 Sonos, Windows 11 PC (also running Roon Server),
Pixel 6 Pro with Android 13, Pixel 2 XL with Android 11, iPad Pro with iOs 15

Number of Tracks in Library

31,184

Description of Issue

I recently installed Roon 2.0 and decided to switch my set up to run Roon Server instead of full Roon. For the moment this is also my main PC. I’ll eventually migrate Roon Server to a separate NUC, but everything is working fine except I’d now like to have a UI on the machine with Roon Server running on it. I can connect to the the Roon Server from Chrome and see the Roon entry page, but none of the Apps ( Android 13 or iPad ) give me the option of using the Web browser as a display in the settings, even if restarted.

Anyone using Web Displays with 2.0? Anyone using Web Display anywhere at all for that matter? I’ve tried 2 different systems and can’t get either of them to show as a display in settings on my Android or iPad though the Roon logo comes up on both Web Browsers

Works for me using 2.0 on ROCK.

You see the ROON logo, so that’s a good sign. Have you told Roon to “Display Now” on the target device?

That’s the problem, there is no way to tell it to “Display Now”. The 2nd step in the linked instructions for Web Display never shows the device that has the Web Display running.

I also cannot get Web Display working with 2.0, it worked in previous version.

Using the link from Settings > Display shows the black screen with the Roon logo. Then when I click on speaker icon > display icon the Web option isn’t listed.

Chromecast plays back fine btw, its just the web link that is broken.

Then please reboot your Roon Core and try again, it might “fix” the issue like it did for other users.