Roon Web Display Does Not Work

Roon Core Machine

Linux Ubuntu running Roon Core - Hardwired to router

Networking Gear & Setup Details

Router is Asus RT-AX88U, latest firmware, tried restarting router

Connected Audio Devices

Roon Bridge on Allo USB Signature running Moode Audio - Hardwired to router, Musician Audio Pegasus DAC connected to Allo via USB

Number of Tracks in Library


Description of Issue

I have been unable to get Roon Web Display to work. I have followed the steps at this site:

I have tried it using the following browsers: Chrome, Firefox, Safari
on the following devices: iPad Pro latest version-wireless, MacBook Pro-wireless, Windows 11-hardwired to router.

The Roon logo is displayed when navigating to but the Display does not show up in Settings->Displays on the Roon Controller installed on my iPhone 14.

All devices are on the same subnet -

I cannot figure out what could be causing this to not work?

With your Core running and a Remote running (e.g., an iPhone or iPad in your case), what happens when you select “Enable” on either the Shield or Shield Android TV? Can you also open a browser (I just tested this on Firefox on iOS on my iPhone) on any of your devices and type the address My web browser became an available display option and the Roon logo popped open in the browser window.

I am able to enable Shield and can successfully display now playing information on my Shield TV, but even with this enabled the web display options don’t show up.

I can’t open port 9300, only 9330

Same as here

and here

Where as in the last case, a simple reboot of the Roon Core resolved the issue.

PS: I can’t see any issue with Roon 2.0 and its Display feature. It works for me with a Google ChromeCast and web browsers as well.

1 Like

I restarted the computer running the Roon Core, and it works now. Thank you for the help. Not sure why I didn’t think of that. :relaxed:

Glad it is all sorted for you @Christopher_Houseman.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.