Can't locate Roon Core

Hi All,

No matter what I do, I can’t log on because I keep getting the message that it can’t locate “roon core.” The message is “serching for devices” but nothing happens. The system worked fine, then just stopped. What can I do? Can I uninstall and then reinstall? WHY DOESN’T ROON HAVE A TELEPHONE SUPPORT STAFF???

Replace the Ethernet cable, check link lights are on, run a network scanner program such as AngryIP or Fing. If its powered up and healthy, its gotta be out there somewhere!

I’ve moved your post to the Support category of the forum where it will be seen and responded to by the support team. Someone from the support team will be along shortly. In the meantime, you might want to describe your setup (what is your Core running on, what devices you are running Roon on, and your network configuration) to help them diagnose the issue faster.

Hi @Russell_Reising,

Sorry to hear about the difficulties here. We do not offer telephone support but I can certainly assist you right here on the Community website. Can you please let me know some more information regarding your setup?

  • What is your Core model/manufacturer?

  • What is your network setup like, please let me know the router model/manufacturer and model of any switches, range extenders, powerline adapters in use

  • What are you connecting to the Roon core with, what model of Roon Remote are you using?

  • If you have multiple Roon Remotes, is the behavior the same across all of them or just one?

  • Have you made sure that you’re on the same network as the Core and not perhaps on LTE or a guest network of sorts?

Is your remote using WiFi for connection? If yes, do you have more than 1 WiFi router/extender? If yes, have you tried connecting the remote to each router/extender. (I had a problem where the remote wouldn’t find the core unless I used a certain router.)

Hi Norris,

I’m a complete idiot with tech matters. I can’t remember if my “core” is my iPhone, my Asus laptop, or my Wyred4Sound MS unit. In any event, I don’t think I changed anything, but now neither my phone nor my laptop can find/connect my core. Please help.



Can I simply uninstall everything and then reinstall to start over?


Roon lingo:
Core is the machine that is doing all the music management, taking inputs from the clients (or remotes), and feeding music streams to your endpoints. In your case, it’s probably your laptop. It would be most helpful if this is connected to your router or switch by ethernet (at least for trouble shooting).
The remotes (or clients) are what you interact with outside the core. Its your iPhone, iPad, or could be another laptop.
Your Wyred4Sound is an endpoint (at least as I understand your setup). It gets a music stream from the network and ultimately sends it to your speakers.
One is not an idiot if they don’t understand the lingo.
Noris will need more details to troubleshoot your problem.

1 Like

Thanks grossmsj, I will check all that.


Hi @Russell_Reising,

Thanks for listing your devices.

Your Core in this case would either be the Asus laptop or the Wyred4Sound MS unit since both are capable Roon cores. I am not sure how you have this setup, but do you recall if your Asus was running as a Roon Remote (connecting to the MS Core) or if it was a standalone Core?

On your Asus laptop, if you go to the Roon Menu (top left-hand corner, looks like a sandwich with 3 layers) -> Settings -> General, do you see “This PC” underneath Core or Wyred4Sound listed there? If it says “This PC”, do you see your complete Roon library on Roon? If so then the Asus is your Core.

If you do not see your complete library when the Asus is running as a Core, the Wyred4Sound is acting as your Roon Core. In this case, you will want to connect the Asus laptop as a Roon Remote to the Wyred4Sound core by clicking on the “Disconnect” button next to this PC and selecting the Wyred4Sound Core on the “Select your Core” screen.

If you are not sure or in doubt about any of the above, please share a few screenshots as this will help clarify. You can upload screenshots here by using these instructions (<-clickable link).

OK: the Asus is my core and it shows my entire library, but somehow, roon can’t find it! What to do next.


Hi @Russell_Reising,

We have established the laptop is the Core, next we need to take a look at the remote that is not connecting. When you try connecting to your core (I assume from your iPhone?) are you presented with a “Choose your Core” screen? Do you see the option to go back to the main menu and select for a Roon Core? A screenshot would be of great help to clarify what exactly you are seeing, if you can please use my previous instructions it would be appreciated.

thanks, Noris,

Here’s the screenshot:

This is all I can get.


There may be two possibilities here:

  1. It’s possible that your iPhone (if it is in fact connected to your home network via wifi) may be connected to a different subnet? Are you able to say what the IP network addresses are for both your iPhone and your Asus laptop (where your Core is)?
  2. Your firewall software on your laptop does not have exceptions for Roon in its list of applications permitted through the firewall. Are you able to check this?

I will check both, but everything worked fine until it didn’t. I’ll post my findings later.



I checked both of those and everything is configures properly.

Hi @Russell_Reising,

Thank you for sharing that screenshot. Since the Asus laptop is acting as the Core here, this issue may indeed be the firewall and we should investigate this aspect a bit further. I know you mentioned that everything looks configured properly but let’s be sure:

Let’s start off by rebooting everything to ensure a fresh state. By this I mean: Power off your Asus laptop, wait 30 seconds, power back on and open Roon. Power off your router, wait 30 seconds and power back on. Power off your iPhone, wait 30 seconds and power back on. Verify if the behavior is the same afterwards.

What is your exact router model/manufacturer and how is the Core connected to it? Is it using WiFi or a direct Ethernet cable link to the router? If it is using a WiFi connection and you have an Ethernet cable that you can use to temporarily connect the Core directly to the router, can you please give this a try?

Can you please use these instructions (<-clickable link) to ensure that you have added both Roon.exe and RAATServer.exe as exceptions to your Windows firewall?

We have sometimes seen that even if they were added as exceptions, it is possible that a windows update may revert these settings, so I would pay close attention to this aspect.

If Roon.exe and RAATServer.exe are not listed as exceptions in your Windows Defender, you can find them by navigating to the Database Location/Applications folder path and add them.

Can you please confirm if you have any kind of antivirus or firewall tools running on this Asus PC? The same exceptions have to be added to any firewall on the PC as it is possible that this separate firewall may be the one blocking your Roon Remotes from connecting.

Can you confirm that the Roon Remotes you are using are not on an LTE connection or guest network of sorts? Do you see the WiFi indicator in the top left of your iPhone and can confirm that both the iPhone and Laptop are on the same WiFI network?

Thanks again, Noris. I will check all these issues tomorrow. Conversely, is there any way I could change my core from my laptop to my Wyred4Sound unit (it is compatible with Roon).



Progress so far: I don’t have "RAAServer.exe. Mine says “raatserver.exe.” is that a problem? REboots did not fix issue. I’ll check the other things.


Hi @Russell_Reising,

Yes, you should be able to do this, but the Core will have to be listed in the “Choose your Core” screen and you will need to set it up as the Core if it hasn’t been set up before. By this I mean: you will need to transfer your database over by performing a Backup and restore of the existing Asus PC database and configure the Audio Zones.

This was a typo on my part, apologies. Yes, it should be listed as RAATServer.

One other thing that you may want to try here after going through the list:

Re-installing the Roon app on your iPhone. You can do this by press and holding the Roon app until an “X” appears next to it, then delete the app and re-install from the Apple app store.

Do let me know how it’s going as you progress through the list.