Can't Login to Last.FM [Resolved - Build 234]

i tried as described… but during authenticating… Failed to log into …
any idea? pass provided is 100% correct.

Scrobbling right now…

Log out of everything - & Roon.
Make sure you’re not logged-in somewhere else (other computers / phones / etc).
Reboot your machine(s).

Log back into Play around in to ensure you’re logged-in correctly & that your account functions normally.
Log back in to Roon & follow the instructions from Kevin :-

“Yes, click your name at the top of the sidebar (when Roon is running) to open the profile picker. Find the profile you want to add a account to, select it and press the pencil icon on the profile photo. Here you can add and save your account information to enable scrobbling.”

I dont know… my works properly, email was validated and i can login into it etc…

I control roon via android app… and when im proceeding by Kevin - howto - it just doesnt work… all the time same issue …
“failed to log in to”. Also i think required to auth app that tries to login/scrobbling … hmmm really no idea where is an issue…

Have you tried installing the App on to your core machine.

i cant confirm that it doesnt work via android app but it works from my desktop where i have roon installed in windows.

To be clear @Patrik_Lenart – you’re trying to log in to Last.FM in Roon, right? You’re clicking the pencil on your profile?

@mike exactly; but using my android app… with windows/osx app it works fine.

Ok, we’re going to do some testing and see if we can reproduce this issue. You should only need to log in once per profile, but maybe there’s an issue on Android.

Thanks for the report!

Hey @heap.

I was able to reproduce the issue. Thanks for the report.

Hello! Is there any update on this (I too can’t log in with my details). Thanks.


I have same issue, I cannot to login to via Roon but it works well from website. I have copy-pasted the password so there should be no any issues with that. Also tried password for two different browsers (because I have saved my login to another so it might autofill the correct one), but no issues at all on login. Only issue is happening on Roon.

I have tried this with laptop (OSX) which is connected to Roon Core (Mac Mini). It should be the newest version or at least second newest.

Is there any logs where I can check exact error (network issues, routing or whatsoever)?

Same problem here. Trying (and failing) to log in to and getting the message “failed to log in to”. Double checked the user name and password of course. No problems logging in from the website and also no problems when I log in to through the sonos app.

@Yiannis_Kouropalatis @Aleksi_Rasanen – I was having trouble on both their website and in Roon, but now it seems to work.

Before we investigate further, can you both try again? I just logged in without issue, so a description of your setups (as described here) would be helpful.

HI Mike
Many thanks for getting back to me so quickly. Much appreciated.

I have just tried to log out of and then logged in again without issue. Same thing with through sonos. Tried to log in to via Roon and I am still unable to (“Failed to log in to” message).

Below is the info about my setup. Hope this is the information required but happy to provide more if needed.

Describe Your Setup

• Roon Version 1.3 (build 218) Stable (64bit)
Core running on laptop. Sonos Play 5 and Sonos Connect End points.
• Operating System: MacOS Sierra Version 10.12.4
• Hardware: MacBook Pro (Retina, 13-inch, Late 2013)
Processor 2.6 GHz Intel Core i5, Memory 8GB 1600 MHz DDR3
• Music stored in Default iTunes folder.
SSD Drive
• collection size 7000 tracks (Apple lossless)

Describe The Issue

Unable to log in to Attempting to enter username and password before clicking ‘save’. ‘Authenticating’ is displayed for a few seconds before the message “Failed to log in to” is displayed.
I have double checked on the user name and password being correct.

Weird, definitely working for me now.

Would you mind sending over some logs? Instructions are here.


Same here. Tried login via Roon fails, but through website it works. In logs it says (if related) that Remote Server returns Bad Gateway, like this:

04/21 09:41:29 Warn: Error in web request NetworkError (The remote server returned an error: (502) Bad Gateway.)
04/21 09:41:29 Trace: [push] request to manager failed

I have tried to check that site via browser and yes it indeed gives me 502.


  • Roon is on 1.3 (build 218) stable (64 bit)
  • OSX is 10.11.2
  • Mac Mini mid 2014, 8 GB 1600MHz, 2.6 GHz Intel Core i5 and Intel Iris.
  • Music is stored on inner hard disk, same than where Roon is
  • Collection size is a little less than 700 albums, 8266 tracks

I try to make Scrobbling work. I can login via website without issues, but from Roon it never works, “Failed to log in to” or what that exact error message is.

Also I have tried to change password to and it does not work with that either. In password there is no any non-UTF8 chars.


I use Freedome VPN by the way. Does not seem to make difference turning it off.

My network goes like this:
Mac Mini is connected via WiFi to WLAN router which also works as a cable modem. Cable modem gets IP from ISP via DHCP.

All devices connected to that Mac Mini Roon is on wifi, none is connected through cable.

Hi Mike,

I have zipped and uploaded the Logs folder on OneDrive. You can access and download through this link:!Ag_QB40n-e8AjLR8ry2HB0pU3IqYjg

Hope this helps
Many thanks

Hi @Yiannis_Kouropalatis ----- Thank you for the follow up! Confirming that logs have been received and are in our queue to be evaluated by a member of our tech staff. Once their analysis has been completed and my report has been updated I will be sure to reach back out with their thoughts/findings.


1 Like

All ----- Please be advised that the issue has been tested and a fix is set into place pending our next build release. Thank you again for you feedback and more importantly your patience!


I have this problem as well. iPad controller, Linux sever, Bluesound Node 2 streamer.