Can't map NAS drive to Roon

Same problem as this poor fella:

smb://NASdrive/sharedmusic begets “Could not connect to share: host not Found”
Adding Password: same thing. Adding admin as username on top: ditto

smb://192.168.1.175 begets “There was an Unexpected error: Invalid Network Path”
Ditto on adding username admin and password

smb://192.168.1.175 begets " There was an Unexpected Error: Unexpected Error"

\192.168.1.175 begets “There was an Unexpected error: Invalid Network Path”

\192.168.1.175\sharedmusic begets “There was an Unexpected error: UnexpectedError”

Save me!!! Ready to jump out of first floor window!!!

Many thanks,

John

@John_Bartlett try
smb://192.168.1.175/begets
You may require the NAS admin user and password, so try it with and without.

Several things come to mind. Hope to help, so just some ideas.

smb://NASdrive/sharedmusic begets “Could not connect to share: host not Found”

Taken at face value, this means that NASdrive doesn’t map to a host that can be connected to. I find this not unusual in LAN setups, since it relies on local DNS to work correctly. Oftentimes this is not the case after restarts of various components etc.

smb://192.168.1.175 begets “There was an Unexpected error: Invalid Network Path”

I suspect you guessed or knew what I just said above and tried this instead, but you didn’t include the share name this time (at least not based on what you wrote here). So it’s true, this is not a valid network path – consider trying smb://192.168.1.175/sharedmusic.

In addition, perhaps it makes sense to question the network setup. What system are you on, anyway? And is it certain to be able to contact 192.168.1.0/24? I have machines on my network that can use both ethernet and wifi, and sometimes they switch unexpectedly and suddenly have an IP address in a different subnet than I thought.

\192.168.1.175 begets “There was an Unexpected error: Invalid Network Path”

True, still missing the share name. Also, \\<host>\<share> is the correct (Windows style) syntax, note the double backslash.

\192.168.1.175\sharedmusic begets “There was an Unexpected error: UnexpectedError”

Still the double backslash issue, who knows…

I would try:

  • Run ipconfig or ifconfig or whatever (depending on your OS) to make sure that you’re on the network you think you’re on
  • Run ping 192.168.1.175 to see whether your NAS can be contacted at all
  • Try to connect to smb://192.168.1.175/sharedmusic from any other system on the network to make sure it works
  • Try to connect to smb://192.168.1.175/sharedmusic from the operating system level on your Roon machine to make sure that this works
  • If all of the above work correctly and Roon still fails to make the same connection, that would be a support case…
1 Like

Please keep in mind that if you don’t use preformatted text option that \\ will display as \ (yes I typed double quotes, the forum software will remove one). So, It is possible that the OP is using the correct syntax.

That did cross my mind, but then I forgot about it. Good point. So if \\192.168.1.175\sharedmusic didn’t work, then we’re back to the suspicions about the network setup – or the system in question doesn’t like that Windows-style share syntax.

Make sure you use the username/password on the account on the NAS drive, if it’s something like Synology/QNAP.

1 Like

I can’t speak to either a QNAP or Synology as I use a ReadyNAS. And, when I have setup shares for Roon on it as a test [I greatly prefer to keep my music on the Roon Core], the basic syntax you presented has worked. Although, as others have mentioned, I believe I did need to enter a username/password.

I can’t check until 6 pm EST when I am home, but, will then verify.

Agreed. Of course you need a username/password if the share is not publicly readable, but these do not have to be incorporated into the initial connection string. I use a QNAP myself and any necessary prompts appear after the initial connection.

That said, I usually allow read access without password protection on shares such as sharedmusic – not a problem on my LAN and it saves the hassle of logging in. Anyway, given the error messages we saw I don’t think this is relevant here.

Hey @John_Bartlett,

Following up on this thread, I wanted to check in to see if you were still running into mapping issues? Let me know if the above information was helpful.

I’ll be on standby for a status update :+1:

I am haveing all of these same issues. I run a NUC Core Rock with latested upgrades. Here are the core deets System Status

Serial

Operating System

Reinstall

OK

Version 1.0 (build 254) production

Running 1 hour, 4 minutes, 25 seconds.

Roon Server Software

RestartToggle Dropdown

OK

Version 2.0 (build 1193) production

Running 45 minutes, 30 seconds.

Roon Database & Settings

Reset

99% of 469 GB available.

Internal Music Storage

Format

OK

2000GB, Samsung SSD 860 55% of 1848 GB available.

Things were great a couple of weeks ago I had shared folders on my synology 1821+ running dsm 7.1.1.1 ++
Can’t hit shared folders on my win 10 pro latestbuild either
My core cannot resolve host names or IPs but everything is availible from win 10 pro
This build is busted . I need a fix
I blew away the existing shares to try recreating them an no love
I’m copying over everything I list to to interal store on core
Half of my most important playlist shows cut as “Unavailible”
I have enabled SMB and NFS on the synology …no love

Tried that, Nope!

Adding this to problem statement.
All remote sessions to core work
I can browse to Rock/core web server
I’m thinking this pretty much rules out basic network connectivity.