Can't play live radio on Netgear ReadyNAS [Resolved - fffmpeg issue]

Hi all, I cannot play Live Radio in Roon. The only one that is working is the
MQA Live - Test

All others give me this error: Playback was interrupted because a track failed to load.

I use my NAS (Linux) as a Core for ROON and I have no issue running Roon.
I also have the Ffmpeg installed by using this command:

apt-get install ffmpeg

Only the Live Radio that is not working.

What do you see if you run
ffmpeg -version ?

What’s the brand and model of the NAS? How was Roon Server installed on it?

ffmpeg version 3.4.4 Copyright © 2000-2018 the FFmpeg developers
built with gcc 4.9.2 (Debian 4.9.2-10+deb8u1)

I install the Roon Server on a Netgear ReadyNAS Pro Business Edition (6 bays drives)
I have upgrade the CPU (Intel E7600 DUAL Core) and the memory to 4GB.

To install Roon server on the NAS I use these command
SSH as root (root@

Installation (nouvelle)
cd /data
mkdir Roon
cd Roon
apt-get install bzip2
apt-get install ffmpeg
chmod +x
ln -s /data/Roon/ /var/roon

Using the command: ln -s /data/Roon/ /var/roon
this making a soft link to redirected from /var/roon to my share folder /data/Roon
this will prevent the OS system partition to get filled from the Roon database

Hi @SylvainP,

I have moved your post over to the #tinkering section since we do not perform any testing on ReadyNAS nor do we have this device in-house to confirm compatability.

You should be aware that this CPU does not meet our Minimum Requirements, so there may also be performance issues at play here.

Does playback of TIDAL/Qobuz/Local content work as expected? From your post it seems like it does, but I want to explicitly confirm.

Are you able to play this radio station properly?

This should stream a FLAC file and would help sort out of the issue is with a codec.

I have no problem playing my local FLAC files, MQA and DSD 64 with this CPU on the NAS.

I have tried to load your radio station url and Roon said it doesn’t detect any radio at this URL.

Is the web URL good ?

I’d say no. I get a “404 - The file you requested could not be found”.

However Roon radio can’t play these streams (this one uses chunking). If you can stand the loss in quality you could try
Instead. This plays in Roon.

PS my chrome browser does not like the https protocol here, it complains the web site sends unusual and incorrect credentials.

Hi @SylvainP,

Sorry about that, it looks like the radio station address doesn’t work any longer and has changed.

The idea here is to try a FLAC encoded radio station and one which does not rely on codecs (as MP3 and AAC stations do). Perhaps any of the stations from this thread will help clarify this aspect:

You could try, as that seems to be a popular one.

Of course it is. Sorry, I must have been asleep.
I misinterpreted who was posting. (this one is not working)

The Radio Paradise (Flac) is working. Also JB Radio (Toronto)

So must be a codec i’m missing if I cannot play the MP3 and AAC radio station right ?

Which one I need to install ?

Hi @SylvainP,

Yes, it sounds like your Codecs are not working properly in that case. As per our Linux Install Documentation:

For ffmpeg :

$ sudo apt-get install ffmpeg

For avconv :

$ sudo apt-get install libav-tools

If your distribution supports neither option, and you’re staring down the barrel of building one of these things from source code, you can always grab statically linked copy of ffmpeg here and drop it into /usr/local/bin as a last resort.

I would try running sudo apt-get install ffmpeg and if the issue is still the same afterwards, you can download a manual copy of ffmpeg and drop it in usr/local/bin.

When I do apt-get install ffmpeg I already get the latest version from (Debian Jessie) which is 3.4.4

I could try to manually copy the ffmpeg v 4.xx as you said.

Just copy the static ffmpeg from :

and copy it to the /usr/local/bin

when I do ffmpeg - version

ffmpeg version N-52056-ge5d25d1147-static Copyright © 2000-2020 the FFmpeg developers
built with gcc 8 (Debian 8.3.0-6)
(remove the rest of details)

Looks like only the radion broadcasting (FLAC) are working.

I have tried a few with MP3 or AAC and the same issue.


Did you manually dropping the ARM64 bit version into your /usr/local/bin? I would also try rebooting the Core after you install ffmpeg, sometimes it needs a reboot for Roon to pick up on the codec.

I have a 64 bits processor in my NAS so I got the AMD64 version. Yes I drop the ffmpeg manually because I don’t know how to get the latest version using apt-get install ffmpeg always get the version 3.4.4

Probably something to do with the sources.list that I need to update. Not a pro in Linux.

So after your recommendation I reboot the NAS and Bang ! It work now !

Thank you

1 Like

Glad to hear it worked after the reboot @SylvainP!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.