Can't see RPI on Roon


#1

Hi all,

I just bought a new PSU, an official RPI one as I seem to have mislaid the last one. Anyway, I have put the latest version of RoPieee onto the microSD card and the RPI seems to boot fine. In fact I can log in via http://ropieee.local/ and I can see the RPI under settings and ‘about’ in Roon (build 167). The RPI is connected to a local switch and also via usb to my Arcam IrDACII.

However I cannot see to select the RPI as an endpoint, it isnt there as an option in Roon, am I missing something?


(Nathan Wilkes) #2

Is the Arcam powered on? And is the endpoint enabled in Settings —> Audio ?


#3

Hi @Nathan_Wilkes - yes the Arcam is powered on but the RPI is not present in settings > audio to enable.


(Nathan Wilkes) #4

And the USB box ticked in the RoPieee settings? Hostname set? (Sorry to ask basic questions.)

You might also submit feedback (in the Advanced tab) in case there is something else going on.


#5

Hi Nathan,

Something weird is definitely going on. I took the memory card out to try dietpi and I couldn’t get that to work either, although the rpi does power up. I also managed to fire the memory card across the room followed by some choice words, and I can’t find it. Luckily I had a spare, so I put ropieee back on the new card. It installed and I could see it in Roon, also via the web browser there is no hat configured and audio usb is ticked. I could select the rpi as an endpoint and configure it. However when I try and play something Roon loses control and I can no longer see it as an endpoint to select. Although I can still access via the web browser.

This is a new ‘official’ rpi power supply which arrived today, could it be at fault? I have changed Ethernet cables as well.

I actually have a new IFI power supply arriving tomorrow as I was planning to add an digione hat to the rpi and use it in a headphone set-up, so i can try a new PSU tomorrow in theory.

Could the rpi itself be at fault? How could I check?


(Nathan Wilkes) #6

Ross — I’d be tempted to rule out some possible network issues. I’d try, in no particular order, and off the top of my head:

  • Try a different switch port / Ethernet cable
  • Verify using an IP scanner (Fing or similar) that there are no IP or hostname conflicts
  • Reboot everything, from the router out, to ensure no arp craziness
  • Use wifi to connect (RPI Ethernet shares the bus with USB, and this sometimes is a problem)
  • If you have one, use a HAT to output S/PDIF rather than USB to your DAC

Nathan


#7

Like to join in and contribute what I have learned so that we may get to the bottom of this issue - Roon not recognizing the device.

I have a stable of pi 2b nd 3b with hifiberry and allo dacs. Network is a managed Mikrotik environment.

Observations:

Most stable is to install volumio and then roon bridge.

Pi 2 b are more stable then Pi 3

When I watch RoPiee interface uing wireshark and it is not being recognized by Roon the Gratuitous ARP request from RoPiee flood the interface.

Tried Diet Pi and had the same issues as RoPiee so I stopped using Diet Pi in my testing.


#8

Thanks @villageworker. I can install volumio, but I can’t find a good guide to install roon bridge, are you away of any?


#9

Hi @Nathan_Wilkes and @villageworker,

I installed volumio and then installed Roonbridge via the Roon LinuxInstall instruction page, I used putty and ssh. It all looked good. I restarted the RPI, the Core and I could see the endpoint in Roon. I could set it up and then select it but when I go to play a track the end point disappears from Roon. The same thing happen with Ropieee.

I am going to try and change all the cables again, just to be sure!

Is this symptomatic of a hardware error? Any thoughts?


#10

Update: Retried all the cables, new PSU, new ethernet cable, no dice! However I had not changed the usb cable, so I swapped out my audioquest pearl for a generic cable and…it worked!! I just swapped it back and it worked too.

So, perhaps the issue was a loose cable?? Not sure as they all seemed well plugged in. Anyway, its running now, lets see how long it lasts. Thanks for your help.

I have an Allo digione on order, so I need to fiddle again in the next week or so. Should I start again with Volumio, a fresh install and reinstall Roon bridge?


#11

There is a long thread here : https://community.roonlabs.com/t/roonbridge-on-volumio-raspberry-pi-image/10170/24

Quick Start:

log into your pi using your ssh app (terminal on os x) and run the floowing commands. Password is volumio

enable ssh http://yourRpiIP/dev
ssh volumio@yourRpiIP
sudo apt-get update
sudo apt-get install bzip2
curl -O http://download.roonlabs.com/builds/roonbridge-installer-linuxarmv7hf.sh
chmod +x roonbridge-installer-linuxarmv7hf.sh
sudo ./roonbridge-installer-linuxarmv7hf.sh

Optional Volumio confguraiton
Set Player name so in your router DHCP leases the Rpi has a relevant name
Turn off Volumio serices: UPNP, Shairport, DLNA

Having said all this I would still like to get RoPieee working as it runs in memory and therefore immune to SD card faliures for the most part.


#12

Thanks @villageworker. This is what I did, so I am glad I got it right.

I just made these final adjustments!


#13

Glad you have it working. I still have to fiddle ith it once in a while. Hence my interest in a memory based solution. ie: RoPieee.

If you stay with Volumio image / roon bridge install suggest trying diffrent SD cards in the RpI.

Allo sells as eMMC card but it is ugly and prone to falling off the Rpi SD slot. Hope Allo is reading this and can comment.


(Nathan Wilkes) #14

RoPieee works very well as a dedicated Roon end point, with no/low maintenance required, and at worst a re-flash.

I am biased, being a relatively early adopter, and now with 7 of them.


#15

agree with your assessment re: RoPieee.

I know the network topolgy/devices play a big part in stability/reliabilty of the Roon system. Probably a different/new thread but would be intersting to understand the network parameters yield the best results.
ex: MTU, IGMP snooping, spanning tree, vlans ect.

I know Roon want to keep this simple and recommends a ‘flat’ network topology. Unfortunately in many modern home networks this is not possible as security requirements, broadcast traffic level, mutliple Wan, VOIP, QOS, bad cable runs etc require a more managed solution.

My measurement goal is turn on music and have it play continuously for a week. Right now my average is around 8 hours before music stops and has to be restarted.


#16

A trusted source for SD cards I use


(Martin Webster) #17

I have a similar issue from time-to-time with my RPi endpoints and Ropieee. My workaround is to momentarily disable the firewall on my Core. My Core is on Ubuntu, what do you use?


#18

Hi @Martin_Webster - I have ROCK installed on a i7 NUC accessed over Ethernet.


(Nathan Wilkes) #19

I am not a network expert, or at least enough of one. I used to use managed switches at home, thinking that I knew enough of what everything needed and that my experience building data centres around the world would be sufficient, but I couldn’t find the exact right set of controls / firmware / blah blah to make it work well. Hubris is a master teacher.

The best thing I did at home recently was to rip out every piece of cable (I found a Cat5 from the late 90s!), replacing everything with new cat6a (a few cat7 for some longer runs runs). And, only use wifi for control devices (eg iPads, Surfaces etc). And, I went flat, dumb, name brand, new switches. And now everything is under a millisecond on average (yes, I use rrdtool to keep track).

So, I tend to agree with Roon on this one – networking is actually hard, and even if you understand what is happening on the wire that that doesn’t enable everyone to create a config that works well (YMMV – some people can, but alas not me).

To someone starting out, without deep networking skills, I would suggest something like:

  • Buy only name brand, un-managed switches. Buy twice the capacity that you think you need.
  • Buy a set of new cat6a cables from a reliable source for every connection (all the same, all new). Use Blue Jeans Cable if you want something tested for spec.
  • If you can’t run ethernet in the walls, run them on the wall (white cables in corners or low to the ground can work in many situations.)
  • Don’t use wifi for audio endpoints if at all possible, only for control devices.
  • Don’t use ethernet over power.
  • Test using ping from a wired device: everything should be within a millisecond or two within a normal home wired network most of the time. If not, resolve (remove a link at a time until you isolate the problem).

#20

@Nathan_Wilkes

Good advice on creating a reliable home network. Using a network monitoring sstem is valuble for troubleshooting. I too am a big fan of rrdtool.