CD Ripping No Longer Working At All [Solved]

Want to add that I am having the same problem. I have ripped over 1500 cds in the last three months, but now the cd ripper is not working. I put a CD in the drive, it spins around, and then just stops. This happened many times, and I was disconnecting the cd drive from my NUC (running ROCK) and then reconnecting, and this would get it to work. I did this many times. But now even that trick no longer works. I even bought a new cd ripper. nothing is working except ripping to my computer and then dragging over to roon.

Enough storage space? Try another CD-unit? Make sure it’s powered properly!
And, please post a screenshot of the ROCK GUI so we can see that the opticla unit has been identified.
(And of course, have you rebooted the ROCK since reinstating the optical unit?)

No, this is a known issue with the most recent builds of Roon running on Roon OS (e.g. the Nucleus/Nucleus+ and NUCs running ROCK). It’s been reported a number of times recently, and is under investigation by the Roon Labs team.

Two things appear to be associated with the issue when it occurs:

  • The CD Ripper stops working
  • The Web Administration page stops working properly, e.g. the Eject button no longer works and a Reboot says that the system has successfully rebooted, when in fact nothing has happened.

I have also noticed that the permissions on the folder of the cd that was last ripped as it gets the bug after ripping are locked until you reboot. So something in the process is not exiting correctly.

1 Like

Geoff_Coupe has it exactly correct. Everything he described is what happens. I’ve rebooted a couple more times and I’m ripping CDs again, but I’m sure it will fail again. It also seems that it is more likely to fail if I haven’t ripped a CD for a few hours.

1 Like

I can only rip one then it locks up and won’t rip another till I reboot.

I think that this issue started with build 227 of Roon OS. @dylan ?

This issue can’t be the same for everyone, as I know I have ripped multiple CDs recently (in the past 2-3 weeks) without such hiccups. Not saying the issue isn’t there of course, but only that it is not treating everyone the same way.

Do you still turn your NUC off every night? Perhaps that’s a clue. I leave mine going 24/7, and I’m seeing the issue…

Impressive memory Geoff!

Actually no, after moving to a new place I have the possibility to leave it outside of the listening room and now it is mostly on. The NUC has been on continuously for the past weeks now.

Um, OK, something else must be the cause, since I have a NUC7i5BNH also. Admittedly, it has been transplanted into a fanless case, but that’s all.

I am waiting for a few CDs in the mail now. I will wait for all to arrive and then see if I just got lucky.

Hello @Martin_Friberg, I’d like to speak to my team about this issue. In the meantime, please let me know what happens with the new CD’s!


@nuwriy most post started this thread (after being moved from a similar thread). i’ve had lots of issues ripping cds in the last two or three weeks, see above. I continue to have them. rebooting has mostly worked. Prior to having issues, I ripped hundreds of CDs in the last couple of months using the Roon ripper without any problems.

Loving roon, and have been enjoying the enhanced performance with my new Nucleus having installed a 2tb SSD. But - it’s not all fun - I’m using the Apple CD to rip to the SSD. This works most of the time, then it dies.

A couple of times a week I need to move the CD drive from the Nucleus to the Mac Pro to eject. The ‘eject’ button on the roon web admin panel does nothing, I must physically unplug the usb CD drive and use the Mac to eject the CD. Very frustrating.

Does anyone have any idea when this will be fixed? It’s causing me real issues…

try turning you NUC or Nucleus off and then on. that has been working for me the last few days.

I had the same issue. Switch off and on the nucleus fixed it.
But my nucleus couldn‘t switched off by the typical way. Only pressing the bottom on backside for ca. 10 seconds switched it off. After that all works correct now.

It will only work till next time. I can’t rip more than one album even then jts not guaranteed to finish then it locks up, webui won’t clear and it won’t rip again until reboot.

Yesterday I ripped two CD‘s without problems. Now I tested the third rip. You are right CrystalGibsy, it doesn‘t work. I had to switch off and on and than the first CD was ripped, the second, the third, the fourth and the fifth… (and the next ones too?) were ripped. Is it a daily problem?
A bug which have to be fixed by Roon.
It‘s not really a big problem for me, since I have ripped almost all of my CD‘s at the time.