Certain Airplay 1/Airplay 2 Dual-Compatible Devices: Playback Bar At 0:00, Airplay Failure Despite Compatibility Mode[Ticket In]

What best describes your playback issue?

· Playback starts, but I don't hear any music

Is there a specific error message you see? If so, please select from the following options:

· Other

Please try to reboot your Roon Server and check to see if this helps.

· Rebooting my Server had no effect, the issue remains

Please try to reboot and unplug/replug in your affected audio device and check to see if this helps.

· Rebooting and unplugging/replugging my audio device, the issue remains

Please open your Roon Remote and select the "System Output" Zone and try to play to it. Do you encounter any playback errors with this Zone?

· I don't have a System Output available, but I'd like to keep troubleshooting

Please try fully rebooting your network equipment

· No, I'm still having trouble

An issue with playback on System Output and another zone often indicates a network security problem. *Check your firewall(s)* to ensure that *Roon*, *RoonServer *and *RAATServer* are allowed to properly communicate

· I'm still having problems / This isn't relevant to me

Does the issue happen with local library music, streaming service music, or both?

· Both local and streaming content are affected

Please try playing content of a lower sample rate (44.1kHz or 48kHz). Do you still have the same issue?

· No, lower sample rates are still affected

What is the model/manufacturer of the affected audio device(s) and the connection type?

· Naim Muso & MusoQB

Describe the issue

The initiation of playback no longer switches the muso’s out of standby. When manually powered up Playback momentarily starts but there is no sound, after a few moments the playback stops

No playback to Muso or MusoQB

Describe your network setup

Control clients iPhone 15 Pro & iPad Pro 12.9 Network = 2 x unmanaged 1GB switch. Router to Server via Ethernet.

1 Like

The symptoms are identical to those experienced with Airplay implementation a couple of builds ago

Are those Mu-So 1 or Mu-so 2?

IIRC the Mu-So 1 supports only AirPlay 1 and IIRC from Early Access testing it might need the compatibility mode now after the Roon update for AirPlay 2. In the Device Setup under Advanced:


Perhaps some mention of compatability mode should have been made in the release notes. I can guarantee most users won’t know it’s there as won’t have used EA.

1 Like


1 Like

I hadn’t mentioned (foolishly) that I have tried compatibility mode (or that both Muso’s are Generation 1) but still no joy.

The blue icon indicates playback is in progress but the progress bar doesn’t shift off zero minutes/seconds.


Thank you! After the update, my Mu-so 1 stopped working because Roon clearly tries to use Airplay 2 by default. Compatibility mode fixed my issues but honestly, this should be enabled by default on devices that are clearly too old to support Airplay 2. Maybe Roon should change the defaults.

That’s debatable, especially as compatibility mode hasn’t worked for either of my devices. It’s rumoured, but not proven, that Roon’s version of AirPlay is reverse engineered and hence subject to compatibility issues.

Hi, I have two first generation Naim QB zones in my system (out of 6 zones) and they are no longer working after the latest update. The other four zones are fine. The original Naim QB doesn’t support Airplay 2 and that is what my signal path says is being delivered. I have enabled ‘Compatibility Mode’ but to no effect. One of my other zones is a Second Generation Naim QB and that’s working fine. Any help or insight would be gratefully received .

I’m experiencing precisely the same issues as PixelPopper with Airplay2 over my Marantz ND8006 streamer. Play appears to commence, no music comes out, then track switches off (play arrow displayed). It is able to stream Tidal directly from the app, or via HEOS, but not through Roon. This is true using every Roon Remote on several Apple devices, and from the Roon app on my iMac, where my Roon core is located.

Rebooting my Orbi mesh system had no effect, nor did rebooting the core (twice in a row) or any of my Apple devices. I can connect to my BlueSound Pulse M speaker to Roon either via AirPlay2 or as a Roon endpoint, but connecting Roon to the Marantz completely shuts down playback (again it’s available normally via both HEOS and the Tidal app).

There are no issues using any Roon Ready equipment, only the Marantz using Airplay. The ND8006 uses Airplay2, but I tried Compatibility Mode in both settings with no effect.

Anything else you need to know?

The Marantz signal path shows up green for several seconds then grays out. The same is true for 44.1 streaming, like Radio Paradise.

Naim’s 1st gen Musos had a firmare update some years ago to add Airplay 2 support, so check that yours are up to date. Do they work if you play to them using Airplay from an iOS app other than Roon?

Have you checked that the two devices are visible as Airplay endpoints in the Roon settings menu under Audio? Sometimes after a Roon update I’ve seen devices disappear in which case they can usually be reinstated from here.

I’m pretty sure Muso & MusoQb generation 1 aren’t compatible with Airplay 2 and there’s been no firmware update to change to Airplay 2.
That said, I would be happy to be proven wrong & update my devices…

EDIT: I was wrong, apologies, after adding my Muso devices to Apple Home they now work to Airplay 2… :roll_eyes:

Can the Gen 1 Qb devices be added to Apple Home? I have some original LSX and their AirPlay support was not working correctly with the latest Roon AirPlay 2 updates until I added the LSX to Apple Home. Now everything works as expected.

I don’t have any Naim Qb systems, but it may be worth checking if they can be added to Home and see if that works.

Excellent @Robert_F that worked, I’m not sure if that is a fix (or workaround) but i have music again.


Many thanks, I’ll leave this thread open for now & hopefully we will get some feedback from support.

1 Like

Glad it worked for you @PixelPopper. I saw something about it in another thread regarding the newer JBL Authentic AirPlay series, and didn’t even think I needed to do so or it was possible, but as we see, it does the job.

1 Like

Seems an odd one. What if you don’t have a Mac or iPhone you can’t use them as you won’t have access to home.

It’s certainly a bizarre fix, I’ve no idea why it worked. As it’s apple only “fix” I guess the Roon developers have some more work to do…

1 Like

I don’t know why but the thread was „resolved“, not sure if that’s right