Certain Airplay 1/Airplay 2 Dual-Compatible Devices: Playback Bar At 0:00, Airplay Failure Despite Compatibility Mode[Ticket In]

Not really as it doesn’t explain why you have to add them to Apple Home for them to work.

1 Like

I did say I would leave the thread open pending some clarity as why such action (adding devices to Home) would “fix” the problem.

@Robert_F could you please re-open (unresolve?) this thread to allow @support to respond and clarify the situation for the benefit of others. Thanks.

2 Likes

Hi @PixelPopper, @Terry_Smith,

@Robert_F’s suggestion is a helpful workaround, but the team is still ticketing and investigating a regression related to earlier Airplay-compatible devices. We’ll post updates here.

4 Likes

What’s happening?

· I'm having trouble with my DAC, speakers, streamer, etc.

What best describes the issue with your audio device?

· Other

Describe the issue

My Marantz NA7004 Streamer used to play Roon over Airplay. This has stopped since the latest update. After an earlier update this year it already showed issues: when starting a track via a Remote, it would remain stuck at 0'00" until I dragged the time indication. Now it does not seem to receive a signal from my Roon Rock at all. The device does show up as enabled. I also have two Sonos Play:1 speakers in my network. They work without issues.

Describe your network setup

Router: Arcadyan Experia V10
2x Sonos Play:1 via wifi
Marantz NA7004 connected via utp, with the wired signal running through an Experia wifi extender functioning as a network switch.

1 Like

Hi @Cam_B,

Thank you for your post. When you say the device doesn’t receive a signal, do you mean that the Airplay Zone for this Marantz NA7004 is no longer appearing in Settings → Audio?

We’re tracking an issue with certain Airplay 1 devices in which the playback bar remains at 0:00 despite a play command. We’d like to verify whether you’re encountering this symptom, or the disappearance of the Zone entirely.

If the former, please try bypassing the Experia extender and connecting the Marantz to the main router for troubleshooting to stabilize network conditions.

Thanks @connor, this helps. (Feeling slightly guilty you’ve picked this up on the weekend :flushed:)

The Marantz NA7004 always appears in Settings → Audio, via Airplay. So you’re right, the issue wasn’t a complete lack of signal.
I connected the Marantz directly to the utp wall socket, which leads to the router. Now music plays again!

The issue of the playback bar remaining at 0:00 is still there, but I can manually move it to start playing and hope it can be fixed in a future update.

Thanks for helping out!

What’s happening?

· I'm having trouble with my DAC, speakers, streamer, etc.

What best describes the issue with your audio device?

· I see my device in Settings > Audio, but I can't enable it

Describe the issue

Since the last software update my apple airports express 2 are shown in the audio properties. They are activated, but if i want to use them, the music don‘t start. Only my HomePod works. I tried everything, like downgrade the firmware version, reset, newstart Airports and router, activating compability modus ….please help me!

Describe your network setup

Router Fritz box; Nuc roon server connected with cable, airport express via wlan 5 GHZ

Hi, same issue here, I have two Gen 1 Naim Muso qbs on the latest firmware.

Following the Roon Airplay 2 update I was unable to stream directly to them from Roon (only way was to get roon to stream to my iphone and then airplay from there).

The gen 1 Naim muso devices do support Airplay 2 provided you have the latest firmware.

Adding them to Apple Home has also sorted the issue for me, @Robert_F thanks for the workaround.

Hello @Sebastian_Stegmaier ,

Thanks for reaching out with your report. I’ve activated diagnostics mode for your account, but it doesn’t look like your Roon Server has been active recently. Also, I do not see any other reports of Airplay issues with these devices. If you try to play to your iPhone in Roon and then use the Airplay iOS built-in feature (from the top-down menu), is that still working as expected?

Thanks for your reply.


My Roon Server is active now and will be activated. In my IPhone i see my 2 AirPort Express devices Küche an Wohnzimmer.

In Roon i see both devices activated. In the Info box i see that the graph is jumping, but the music don‘t start :frowning: .


Hi everyone,

Thanks to those of you who have helped spread known workarounds on Community.

This regression is tracked and ticketed and a fix is in the pipeline. We will announce updates in this thread.

We’ll sort this out as soon as possible. Thank you again for your patience.

Hi @Sebastian_Stegmaier,

Thank you for your patience. We’ve examined diagnostics with development and concluded your encountering a known regression with Airplay support that was introduced in the most recent release. We have a fix in the pipeline for this issue and will announce a release here:

Have you added this Airport Express 2 to the Apple Home app? Other users who share symptoms of this regression have reported that as a workaround.

1 Like

Good to hear conner , in the meantime the workaround is working for me so thanks to Robert_F for that

It works. Thanks. I erase the Airports in my Home App and added them once again. Now it works. Perfect!