Chord Electronics 2GO Roon endpoint "and Server"

Already discussed in the past:

So why you want to drop this model and have an all-in-one DAP instead?

would be nice if they make streamer for qutest dac
with dual bnc output

1 Like

Because sometimes I leave the house. And I actually don’t want an all-in-one DAP, because I want to use a well-written iPhone app as a controller.

I discovered Roon as I was casting around for a decent MPD controller app for my home setup. I wasn’t happy with any of them and happened upon Roon. It was just a UI that was leaps and bounds ahead of any of the MPD apps. I’d love to use that same UI on the road.

1 Like

Wouldn’t we all? Sadly it’s not possible at the moment.

As a TT2 owner I am extremely disappointed, cables coming out of 3 of the 4 sides, power provided by micro USB and the form factor isn’t a match for the TT range.

When the Chord POLY came out some time ago, I had dreams of using it with my Mojo where I could use the MojoPoly as a standalone DAP and wireless with my home network. Boy oh boy, after a few months of constant playing around trying to get it to work, downloading multiple apps, etc…I gave up and never looked back in the Chord rear view mirror.

Life is too short to be playing around with a $1,000+ item that didn’t quite work for me.

Perhaps the Hugo 2 - Poly is better but I have no desire to go backwards.

Just my two cents…

I don’t know about you, but the 2.4GHz band where I live is a Mad Max like wasteland and unusable. The lower range of 5GHz is precisely why there is less interference.

1 Like

Yes. I have an Onkyo DP-X1 with two 500GB microSDXC cards and I’d love some sort of Roon app to sync with my Nucleus and give me the same UX on the road (well, the Tube, really).

Alternatively some sort of mobile battery-powered Nucleus in the same form factor as the DP-X1.

1 Like

But it doesn’t resolve the technical and physical limitations of the 5GHz WiFi. There is maybe no working WiFi solution for mobile use then where you live. I’ve already wrote about how one can make use of the 5GHz WiFi for stationary use in the other thread.

My Roon audio path is all wired, apart from the iPad I use for control.

I have had confirmation from Chord that it is a Roon endpoint; however not not a Roon server, which could be Inferred.

Still an interesting proposition as I am a DAVE/Mscaler user and have not heard an improvement over direct to MScaler from a QNAP TS-473 NAS running Roon server connected with USB, when home demoed a Pro-ject UItra Streambox 2 or Auralic Aries G1.

1 Like

An expensive boat anchor, imo

My experience with USB connection to DAVE / M-Scaler is similar to yours. My Roon server is a 5th generation i5 NUC in a fanless Tranquil PC enclusure (no WiFi or Bluetooth) running ROCK with internal SSD storage.

Like yourself, I also tried a Project Stream Box S2 Ultra to facilitate a network connection from NUC to M-Scaler and found no improvement over direct USB connection. However, more generally, I think the Project makes an excellent Roon network end point and I kept mine for use in a different zone.

1 Like

Got my 2Go today. Works fine with Roon but not certified yet. Come on Roon! :smiley:

Are you seeing a max Sample Rate of 384 and a max of DSD256?

The 2o and Hugo 2 support 768 and DSD512 but Roon won’t let me set that.

Acdemic for me considering the library I have, just worndering what else is not correct.

Same here.

I’m having real problems setting the 2go up with Roon in that I can’t access any of the advanced settings.I think its because I was using Airplay in the 2go when I was setting the audio device up in Roon. This is what I have got for the Icon and advanced settings below. As you can see no DSD etc…

I’ve tried uninstalling and the installing Roon but that didn’t work. I’ve looked at trying to delete an AudioDevice on Roon, but can’t find out how to do that. Feeling a bit thick so would appreciate some help.



Use Gofigure to configure the 2Go (enable Roon support).


Thanks, but when I go to the music page I can’t see Roon. This is what I get. I have the Roon Core turned on and the 2Go is on the same WiFi network.

I know it must be something simple, but it’s not idiot proof clearly!