Chord Hugo TT - ASIO/WASAPI issues

Core Machine (Operating system/System info/Roon build number)

Qnap - TS-1685 Intel XEON with 32GB RAM
Version :** 1.7 (build 571) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connection via Netgear M5300-52G
No Wi-Fi is used

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PC running Windows 10 Pro 1909
Roon v1.7(build 571) stable 64bit
Roon Bridge v1.0

USB to Chord Hugo TT

Description Of Issue

Have newly installed Chord USB Windows 10 drivers in a Lenovo Tiny M900 i7 16GB RAM.

ASIO - Device is not recognized. The choice of options while Chord hardware does not included the TT only the TT2. Choosing TT2 also causes Device is not recognized. Then Roon closes.

WASAPI does not even appear as an option to activate.

I have also tried renaming RAATServer to RAATServer_old and have the system recreate the RAATServer folder. This did NOT work either.

I can only get ASIO to work with EuphonyOS with ROON core via ALSA.
EuphonyOS with Stylus has the same Windows 10 issue. Device not recognized. Then Roon closes.

I have rebooted many times, installed the full Roon package as well as the Bridge. None of these options have worked.

Suggestions please?

1 Like

Hi @rpadole,

Is the behavior the same if you try to temporarily host the Roon Core on your Lenovo?

  • Create a Backup of your Roon database (as a precaution)
  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Made the Lenovo the core. Two things occur with ASIO.

  • ASIO shows list of Chord products but NOT the Hugo TT but all other devices. Once a choice is made (does not matter which) - Device Initialization error occurs. Then Roon crashes

  • Other times the ASIO feature Enable button will just immediately crash Roon

WASAPI however did finally appear as an option this time. But not a viable solution as the Lenovo will not be the Core.

Hi @rpadole,

Can you please reproduce this behavior, note the time of the crash and send me a copy of your Roon logs by using these instructions? Via Dropbox or Google Drive is best, but if you don’t have either just let me know.

Link from OneDrive via the QNAP Ambulance button.
(2) attempts 7/01/2020 at 12:07AM (Central Time)

https://1drv.ms/u/s!AvVqBiDMp8zNgP9MQ9wCslM_GDO-vg?e=2Ezofi

Tested the same Lenovo with the Anthem STR Integrated USB DAC and Anthem drivers. Both WASAPI and ASIO are recognized. Although WASAPI stops at 192kHZ for whatever reason. So the issue appears to be Chord Hugo TT DAC. The Chord also works with Auralic Aries device via USB with no issues.

Hi @rpadole,

Thanks for sending those logs over, but it doesn’t look like they contain much info. Can you please also send the Roon controller logs? They should be under %localappdata%/Roon/Logs, same instructions as before can be used. I would also try re-installing the Chord driver.

I had already created this at the same time as the Ambulance button used. I thought to include it last night but 2nd guessed myself. Oh well.
Here it is. Same time frame of course.

https://1drv.ms/u/s!AvVqBiDMp8zNgP9LrWKdydh523KTlw?e=7kbKqv

Hi @rpadole,

I’m still not seeing the logs from the Mac in the folder you sent unfortunately, they still appear to be QNAP logs. The ones I am looking for are under your %localappdata%/Roon/Logs on Windows. You can open a Window Explorer instance (the app you usually use to navigate through C:) and type that in the header: %localappdata%/Roon/Logs

4 posts were split to a new topic: App Crash - ASIO Qutest