Chromecast Audio , connects but will not play

Core Machine (Operating system/System info/Roon build number)
Asus Zenbook, Core I7 gen 8 ,Windows 10 pro, latest build, 16 gigs ram,gigabit ethernet via usb c to gigabit converter/adapter, to Orbi satellite. I am also using a Netgear gigabit switch.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Orbi with 2 satellites. Core laptop and Arcam hooked up to ethernet via Netgear switch and Orbi satellite. All gigabit.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Chromecast Audio pucks via wifi, Google Home via wifi, Google home Max via wifi, Arcam SA 30 via ethernet.

Description Of Issue
I have one day left in my trial. All has been working pretty well except I was using a older Mac Mini as the core. It was too slow. 2012 model. So I moved the core to this laptop.

After the move, the Google home models work fine. But the Chromecast Audio pucks will connect, I hear them change volume via Roon, but when I start the music, it does not play. I have 3 of them, all the same problem.

If necessary, I can start from scratch and reload a new copy of Roon and not use the back up. The Arcam SA 30 Roon endpoint works great and sounds incredible via Roon. It is hooked up with ethernet too.

Hi @Kenneth_Kirkpatrick,

Welcome to the forum!

As per our Networking Best Practices Guide, can you please check this setting?

Netgear Orbi Routers

If you’re making use of an Orbi router, we recommend unchecking Disable IGMP Proxying in your router’s settings. This setting can interfere with the ability for Roon Remotes to connect to the Roon Core.

Is there any difference of where the pucks are connected vs the new Core connection? Was the old Core on the same access point as the pucks?

Yes I had unchecked Disable IGMP Proxying last week when I first set up the Mac Mini. It is is Auto mode.
The Chromecast Audio pucks have not been moved. They connect to either the router or one of the Satellites depending on location via wifi. The Google Home speakers and the Google home Max speakers are problematic too. All work fine via Google Play or the Tidal app. Also my iPhone is have trouble connecting to the core. I was only experiencing slowness with the Mac Mini. It was connected via ethernet to one of the Satellites. I have the Asus Zenbook running as the core connected directly to the router. I can move it back to a Satellite easy enough. I discovered Macaffe was running on the Asus, so I uninstalled it. I also turned off Defender firewall. Nothing helps. Fortunately the MacBook and iPad connect to the core fine and no trouble streaming to the new Arcam SA 30. Sounds fab! This has to be a network issue. I think next unless you say otherwise I will uninstall Roon on the Asus and do a clean installation and not restore from back ups but let it start clean and add the endpoints and 4tb’s of music from scratch. If it is still a problem, then I buy a Nuc or a new mac mini and start over. Thanks for any help.

I’d do this. It puts the network topology back to where you know it worked.

Have you tried the following …?

I rebooted it. But the problem is not just one Chromecast, its most of the Google toys on the network…3 Chromecast Audio’s, 2 Google Homes and 2 Google home Max’s. Some will work with Roon sometimes, others not at all. They all work perfectly with Tidal and Google Play etc. They also worked with Roon when a mac mini was the core. They just don’t work correctly with Windows 10 Pro running the core. You can hear them connect, you can hear them changing volume with Roon. But when the music starts, the curser sits at 0 secs. They won’t play the music most of the time. I can just use the Tidal App on my iPhone to stream to them, but I can’t send music from my hard drive to them with Google play after December. They will shut it down and charge 10 bucks a month to use Youtube music to cast my personal library. So I need to get this sorted out. Its something simple… just have to find the right switch to throw. I did notice after I installed the core on the Windows laptop and restored it, the defaults on the Google pucks were incorrect. The showed them as MQA renderers etc and MQA decoder was activated under advanced. Wishful thinking. I wonder if they are re added to Roon following a fresh install it will sort them out…

Update. I noticed if I scrub the music forward and back while streaming to a Chromecast Audio puck, the music will start to play, then stop. I could skip forward to next song etc, the music will start for a second, then I see the message that Roon is starting the device and this might take a moment, as soon as I see that the music stops. So it appears to be a sync problem. I went into the Chromecast Audio settings and fiddled with the resync delay, setting it the to the longest delay and it started to work. Its still glitchy, but maybe this information will point the engineers in the right direction to the source of the problem.


A post was split to a new topic: LG Soundbar doesn’t work in Roon

Hi @Kenneth_Kirkpatrick,

If the issue only occurs when Windows is the Core, I would check the firewall settings you have in place, perhaps there is an antivirus interaction.

Is this a managed or unamanged switch?

Unmanaged switch. I disabled the firewall, same problem. No problems with Tidal app or Google Play apps etc. only Roon. If I toggle pause, play it works for a while. Then stops usually after 5 tracks or so. I can then restart by hitting pause then play. As soon as my Arcam SA 30 gets certified I plan to build a Nuk and maybe it will solve the problem.


Hi @Kenneth_Kirkpatrick,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the issue occurs as well as the track you’re trying to play. Then respond here with that time & track, and I’ll make sure we review the diagnostics related to that timestamp.

Hi, the time here is Mountain time 7:56AM, the track is Take Five by George Benson from the album Bar Jazz Cafe.

I have 3 Google Chromecast Audio pucks. I have noted that one connects directly via wifi of course to the Orbi RBR 50 router. The others connect via one of 2 satellites in the mesh. The one that connects via the RBR 50 router will not appear in the audio settings. If I move it so it connects through one of the satellites, it will appear and can be enabled. When I move it back where is belongs, it reconnects to the RBR50 Orbi router and disappears from the audio zones. The CCA that I use the most connects directly to the same satellite that the core connects to. The core is on a Asus Laptop running win 10 pro, SSD HD , core I7 8th gen, 16 gb ram, latest updates and the Orbi is running latest firmware. Toggling pause and play is repeatable and works.


1 Like

Hello @Kenneth_Kirkpatrick,

Thanks for letting us know those timestamps!

These symptoms sound very similar to an issue we are already investigating, I have added your report to this investigation please see for any updates, please refer to this thread:


Well the problem seems to have resolved. I don’t know if my Orbi mesh routers updated their firmware, or what changed. But for the last few days the CA pucks and other Google speakers are working fine. Now if I could just get the last CA to show up in the Roon zones.


1 Like

Hi @Kenneth_Kirkpatrick,

Thanks for letting us know that the issue resolved itself!

If you haven’t tired it yet, a factory restore of the puck might help.

I have 3 CCA pucks They all appear and work perfectly with other apps and Google Home app. But the other 2 pucks connect through the satellites in the mesh and are available in Roon. This one puck is close to the router, so it connects though the router. If I move the puck to a room close to one of the satellites, it will connect through a satellite and will magically appear in Roon audio and was enabled. But when I moved it back to where it belongs, it reconnects through the router and disappears from Roon, but is available to other apps. The Roon Core connects via ethernet via one of the satellites. When the core computer is wired directly to the router, big problems occur connecting to any of my Google speakers or CCA. So I moved the core computer back to connecting through a satellite via ethernet. There has to be a switch I can throw in the Orbi software that will fix this. Tidal, Spotify, Google Play all connect to the Google toys with no trouble. I have unchecked “disable IGMP proxying” whatever that is…



The Orbi mesh router and satellites updated their firmware this morning. The last CCA puck now appears in Roon and I can play it from Roon. So everything is working. Fingers crossed! Thanks!


1 Like

Hi @Kenneth_Kirkpatrick,

Thanks for letting us know the firmware update resolved this issue on your end, that’s fantastic news!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.