Chromecast track to track failing with build 610

Core Machine (Operating system/System info/Roon build number)

Lenovo TS-140 running Win 8.1 latest fixes
Roon version 1.7 build 610

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Vodafone hub (Huawei HHG2500) (no WiFi running)
BT Whole Home Wifi attached via ethernet and providing all wifi connectivity
Core machine attached via ethernet
Chromecast devices via WiFi
Chromecasr Audios running v1.42.172094
Onkyo VC-GX30s running v1.40.168834

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

TOSLink to Cyrus 6DAC

Description Of Issue

Since installing v1.7 build 610 there are issues playing track to track to Chromecast devices. According to the display ROON moves from say track 1 to track 2, the little blue spectrograph shows up at the side of the track BUT on the now playing part of the screen the time played does not change nor the cursor move down the track line and nothing is streamed or at least heard. Sometimes it can be cleared by switching around tracks or devices or sometimes even just by pausing and playing the track. At times have resorted to quitting and restarting Roon Server. The problem can occur as natural progression from one track to next, or when track advanced through next track button, or when using mouse to click forward in track.

The same problem occurrs with Chromecast Audio devices and ChromeCast Inside devices such as Onkyo VC-GX30.

There have been no known network or hardware or software changes elsewhere, the only known change is moving up to version 1.7 build 610 of ROON. In fact if possible I would very happily revert to previous build so I can start enjoying the music again because this is driving me nuts.

1 Like

The more I play with this the more it resembles 2 other support topics, namely:

[Kenneth_Kirkpatrick] [Chromecast Audio , connects but will not play]
(Chromecast Audio , connects but will not play)

[Jonas_Soderlund] Tracks don’t start playing from Tidal without pressing pause and play (Chromecast Audio)

I wish there was a clearer pattern to what’s going on but it’s random, Sometimes a track will play, sometimes not unless I pause and restart. Whether this be from initially selecting a track, auto advancing to the next track, manually skipping to the next track, switching to another album, advancing the timeline, etc.

What I do know is that PLEX and Spotify work fine to the same CCAs and ChromeCast Inside devices.

1 Like

And here’s another topic reflecting the same problem:

[Jim_schneider] Roon stops playing after each song

Is anybody getting any news on this ?

And here’s the one where Craig is in touch with Norris:

[Craigio] Roon radio just stops

Norris, if you need any more examples just let me know. We’re getting them on a regular basis.

I am working with norris on this issue, i still have it, its not roon radio but i think more to do with chromecast audio. Can we also check that no other software is set up on chromecast such as spotify and tidal etc, as this is a area we are looking at.
I have spotify, but i am pretty sure that this not interferring with Roon.
The more people who report this the better the feedback to solving the problem:)

Hi everyone,
I don’t know if this could be helpful but just want to report:
Having the same Chromecast issues after last ROON update - either devices were not displayed at all or the groups I created in HOME had disappeared or only the first few bars of a song were played and the connection stopped with the message:
Audio Device refuses to switch input to Roon, or disconnects.
Strangely enough, only with Chromecast Audio and a Beosound2 Chromecast built-in, but not with a Raumfeld Connector Box with Chromecast built-in, this box alone played flawlessly.
My fix:
I finally discovered that I had configured two different homes in the Google Home app, each with a different network, which had worked fine for years until then …?
I tried to delete one of the two homes in the Home app and only kept the one that I’m currently using ROON with:
Lo and behold, suddenly everything works again!
Flawlessly without a single dropout so far.

Maybe it will help someone here.

1 Like

Hello @Axel_Lesch / @Axel_Lesch / @Craigio,

We are actively looking into this issue, for any updates, please refer to this thread:


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.