Chromecast tv not showing in audio devices neither is my Onkyo TZR50

Roon Core Machine

Windows 10, Core i7, 64GB RAM. I am running roon server and also roon for windows on that machine and that is where the Core is located. I primarily control Roon through my google pixel 7 phone. But also sometimes on the windows machine when at my desk.

Networking Gear & Setup Details

Archer AX50 wired/wireless router. Chromecast tv connected via ethernet

Connected Audio Devices

My primary audio streamer is a cocktail time N15 into a Parasound P15 Preamp.
Chromecast TV is in a different room with my home theater.

Still waiting for a response.

Number of Tracks in Library

10000 or so

Description of Issue

When i go into Roon settings, audio, the dac to my pc, the cocktail time, the Sonos soundbar (in another room) and Nvidia show up (one of them is probably nvidia shield in the home theater); but my HT receive Onkyo TZR50 and the Chromecast do not show up as audio devices although both are on ethernet. I did unplug the chromecast and let it restart.

still waiting for a response

Do any other apps see your TV as a Chromecast device? What is the amp and what protocol do you expect it to be seen via Roon ?

Can you confirm that the amp and Tv are both on the same subnet of your network as the Core and other zones. Post ip adresses for core Tv and AvR. What’s your network kit as it may be blocking the multicast traffic required for CC to work.

1 Like

For example in Roon, settings, audio devices, my sonos on a different tv shows up fine, my bluesound node in a different room shows up as does my cocktail time N15 in a different room yet. The chromecast tv is hooked into the wired network and does not appear in the roon audio devices list; neither does HT receiver into which the chromecast is plugged in (which is also hooked into the wired network. The HT receiver is an Onkyo TZR50.

What do you mean when you say network kit? as before, the sonos, cocktail time, and node are all plugged into the wired network and all show up in Roon…just not the Chromecast or the Onkyo.

You won’t see your reciever unless it supports AirPlay or Chromecast, having a Chromecast connected to it will not make it visible to Roon.

As I asked can other apps see the TV as a Chromecast to play to? And please list your ip address as asked for. Just because some devices work does not mean others will. Some protocols such as AirPlay and Chromecast use different discovery methods that often are blocked over wireless connections or by the router until enabled. You may also be unknowingly to you have devices on different subnets. We can’t help if you don’t help us diagnose.

Do you have the Google home app? Does your Tv show up in there.

the receiver probably does not…but that is not important…I would just like Chromcast to show up in Roon.

Interestingly when i look at the google home app on my phone, my chromecast and nvidia shield both show up there. I dont really use google home for anything. The nvidia shield does appear to show up in roon…but there are two nvidias there (one is graphics card), but I cannot tell which is which from the roon display.

I have a similar issue. My Pioneer Elite VSX-LX704 receiver has Chromecast and Airplay. Both used to be available thru Roon and both showed up in the “Audio” heading of the Roon Setup. Since Roon became Internet-only Chromecast does not show up. However, the Chromecast option found in my Sony Bravia TV does show up.
This is not a huge deal for me since I stream thru my DAC but if I was strictly going wireless thru the Pioneer this would be more of an issue since Chromecast supports 24/96 while Airplay is 16/44.1

Jim, I’m extremely confused. In your original post, there’s no Onkyo mentioned under audio devices. And it sounds like there are two Chromecasts? One TV, and one plugged into the Onkyo? Is the TV “Chromecast Inside”, or is it a separate Chromecast dongle plugged into it? And what exactly is plugged into the Onkyo? A Chromecast Audio? Or what?

The chromecast tv dongle (I have only one) is plugged into the Onkyo HT receiver via hdmi, but an ethernet cable is attached to the chromecast. I just use the Chromecast dongle to get tv via youtubetv, peacock and F1TV. Since it plays through the Onkyo HT receiver, it would be nice if the Chromecast was visible and accessible through roon to play my Roon library through the Receiver.

OK, now I get it. Yes, if the Chromecast TV dongle is on the same subnetwork as the Roon Core machine, and is powered on, it should show up. Can you see it from the Google Home app?

yes, i can see it on the google home app; but not in roon / settings / audio

Hi @Jim_Fuerstenberg,

After reviewing your posts, the tech support is suspicious that your endpoints are connected across multiple subnets.

Is this Chromecast TV visible as a cast destination from a web browser (for example, within YouTube or Netflix)? This will help us distinguish whether the Core computer can connect with the device at all.

We’ll review diagnostics in the meantime from your account. Please keep your Core online for the next several errors so the report can reach our servers. Thank you!

yes, when I open the Pixel 7, which I also use to control Roon; and open Youtube on that phone, i can cast to the Chromecast.

did you find out anything from the diagnostics?

still hoping for a solution

Hi @Jim_Fuerstenberg,

Please accept our apologies for the delay. We’ve reviewed diagnostics from your Core and have several next steps and suggestions to try.

  1. Firstly, Roon is unable to locate the Chromecast dongle connected via ethernet. I recommend trying a different ethernet port on the router, as the router or your ISP may have reserved assignments in the range you’re attempting to use.

  2. There’s evidence of routine requests from your Core to Roon’s servers timing out or failing. It’s possible a firewall is interfering here. Have you added RAATServer as an exception to your Windows Firewall (see here). Do you have any enterprise-grade security or VPNs on this network?

  3. Lastly, there are unrelated IO failures that appear to be due to an extant old install of RoonServer on the same machine. After you’ve checked the above networking steps, you can take a more heavy-handed step to fully refresh both RoonServer and RAATServer to stabilize conditions in your system by deeply uninstalling/reinstalling both. This will eliminate any cached data interfering here. Be sure to create a reliable Backup to retain your library, customization, and DSP settings.

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

While the support team is wrestling down a longer queue than normal this week, we’ll do our best to be more prompt in our next response. I’ll personally keep an eye out for this thread. Thank you for your patience.

Thanks for the suggestions

I tried switching ports which go to the chromecast with no effect

I made sure no firewall or vpn was on. I also checked exceptions to the windows firewall and roon and raatserver are set as exceptions. we did that to solve the prior core not being found problem

when we were trying to solve a prior problem with the roon core not being found, we did go through the renaming as old sequence.

I also made sure the chromecast was awake and running and restarted my roon for windows. I did not restart the server…although that has been done during recent reboots and did not change the issue.

I have not yet done the reinstall process.

btw, when I am using my pixel 7 (which is my primary roon remote); and open my podcast app, it gives me the option to cast to my chromecast. I tried it and that worked fine…

one more issue…when i uninstalled an reinstalled the roon app on my Pixel 7…it asked me to choose which core (they both looked identical). I am running roon server and the roon windows desktop on my pc. Now, whatever I play using the pixel 7 roon app does not show up in my history on the roon windows app. The pixel app has no problem accessing any new music which also shows up on the windows app.

You appear to be running two cores which may be part of your problem. If you’re running Roon server then when installing the full Roon app for control you need to ensure your only set it up as a remote it gives you an option on install as it sounds like you have it running as the core as well. You don’t want this at all.