Click between tracks using Musical Fidelity MX DAC [Artifacts] [Solved]

I’ve got the same problem, but it’s not just FLAC, it’s also DSP and playing Tidal albums. And the click also happens upon pausing, or using the button to advance tracks. And similar to Roland (rolski), I’ve swapped my Roon NUC out with a Logitech Media Server device and none of these sonic artefacts occur. And that swap means using the Roon NUC’s CAT5 cable, its USB cable to my DAC, and its AC outlet. A perfect in-place swap, with no clicks.

I’m running RoonSever, the most recent build (55). Any additional info I can provide, am happy to do so, as this is ruining the inky black silence that my system can normally produce. Thanks.

Hey @scolley – which Meridian device are you using? Are you running the latest firmware?

I’m sorry Mike. I’m not using a Meridan device. So maybe this is a different problem to you guys? If this is better in it’s own thread, I’m happy to start one. Just let me know.

But the symptoms sounded SO similiar, that I figured I should just pile on to this one.

FWIW in both scenarios (Roon and LMS) the devices pull music from my NAS or Tidal, off a Cat 5 cable. And run through a Jitterbug and a Shiit Wyrd to a Musical Fidelity MX DAC. I suppose what’s upstream of the DAC is irrelevant, other than to say at ear splitting levels, when there’s no music (or silence in a passage), you can hear a pin drop. Unless I’m playing an LP. :wink:

Please let me know if this needs to go in a new thread. Thanks.

No, I really appreciate you searching and finding a similar thread – very helpful. I’ll move this and we’ll figure out what’s going on.

One thing that would be a good initial test would be to simplify the USB connection – could you try without the Jitterbug and Wyrd and see if there’s any difference?

Also, can you let me know how you have the MX DAC configured in Roon? A screenshot of the settings under the gear would be great, like the one shown here.

Finally, can you let me know how consistent this is? Does it happen with every song? All kinds of content? Certain formats? Certain tracks? Every time you take an action on the transport?

Thanks Mike. I’ll do as you suggest. And thanks for starting the thread. But before you spend anymore time on this, I’ve GOT to mention that I’m also running Fidelizer. In fact, I’m in contact with the author to see how to turn the d*mned thing off once it’s installed. So until I can do that, there’s no way we can know whether or not it is a part of the problem (I’d be shocked if it is, but it need to be ruled out).

Due to the Fidelizer issue, I was not going to post at all until I could turn it off. But then I saw the thread I originally posted in, and realized that since other people were having the exact same symptoms, maybe I should post.

So… I’ll do as you request AND figure out how to get Fidelizer out of the loop, then confirm the problems is still there without it, and get back to you. Thanks for the help. :slight_smile:

OK, got Fidelizer uninstalled - which puts everything back like before. And have also removed the Jitterbug and the Wyrd box. Now it’s the NUC RoonServer connected straight to the MX-DAC. And to confirm when the clicks have always been, and remain…

  1. When I press Pause on a remote Roon (iPad mini 2).
  2. When I skip forward (or backward) to the next (or previous) track on a remote.
  3. A second or two into the new track when Roon finishes one track and moves to the next in the queue.

And here’s those settings…

And to your final question, this problem generally consistent across Tidal, DSF and ALAC files. However, the click one or two seconds into a track is difficult to confirm in FLACs, as most of my FLACs start with music immediately, which generally plays over the click. It’s a pretty soft click. But on some quiet FLAC tracks I can hear it. I just happen to have quite a few DSF tracks that begin softly, so it’s easy to confirm with that format.

Ok, that’s really helpful troubleshooting, even if the clicks persist :frowning: We may need to dig in a little further, but I’m sure we can get this worked out. Would you mind trying two more things for me:

First, can you confirm that the clicks persist when you set the Resync Delay to something other than zero.

Second, it would be great if you could confirm it there’s any change when you run using ASIO – I would disable the WASAPI output first, then enable ASIO and see if things are any better.

Finally, any additional information you can give us about what the clicks sound like would be helpful – I know that’s sort of weird question, but it helps us get a sense of where things are going awry.

Appreciate your patience here Steve!

Mike - I’m happy to help. I spent many years of my early career either writing software, or managing that process. And what I’m hearing is definitely some little gremlin that’s in there somewhere. Granted, I’m being really, really picky. But I know that if I were you, this is something that I’d be wanting to chase down. So…

The sound of the click varies. Typically it sounds more like “tick” than “click”. And sometimes it is accompanied with a very short burst of something that sounds like white noise. Less than a second, but audible. As far as volume, it’s never loud. But definitely audible, even at low volumes. When the music is turned up to “artists are in the room” levels, it’s about as loud as someone speaking softly. Maybe a little more.

And to make matters worse, it varies. Sometimes it is a very audible click. You can do the same thing a few seconds later, and it’s very soft. And one more thing on volume… the click that starts at the beginning of tracks - that’s very, very quiet. Always. Now for the test.

I tried different Resynch Delays; 0, 50, 1000, and 5000 ms. The click remained, though it seemed to be less pervasive at 5000 ms. Maybe. But the real hoot is that after one of the changes to the Resynch Delay on my iPad Mini 2, Roon crashed (it does that sometimes). And when I started it back up, the quiet click in the first second or two of new tracks was GONE. And after a good bit of testing, it’s still gone. Even with Resynch Delay back to zero.

I also tried the ASIO driver. Like the 5000 ms delay, my impression is that the clicking may have been a somewhat less pervasive. But it’s definitely still there.

If needed, I’m happy to be a bit more scientific about this… creating a defined (repeatable) set of testing activities, running multiple tests, recording (counting clicks) the results, and comparing between the different conditions (0 vs. 5000 ms, or WASAPI vs. ASIO). But did not do that yet, for all I know the fact that the clicking still persisted in the two test might have been all you need to know.

Please let me know if I can assist further. And thanks for the help. :slight_smile:

Oops! Left out an important detail. I discovered that “click plus white noise” while testing, after I reported this. And that only occurs when I let go of the pointer after dragging the position pointer to another spot in the song. I’m referring to the little line on the track time-line, that you can drag to a new spot in the song. The moment of letting go is often accompanied by the “click plus white noise” or just white noise alone. And now that I think about it… it sounds a lot like the quiet spot on an LP with the volume up.

So is this support request dead? I think I’ve been able to demonstrate that it’s not WASAPI, not Resynch Delay, not Fidelizer (uninstalled), not Jitterbug (removed), and not Schiit Wyrd (removed). That leaves RoonServer, Windows 10, and my Intel NUC - and how they all play together.

Would love to see this sonic gremlin disappear. Thanks.

Have you tried:
Removing Roonserver from the equation and play music using JRiver from the NUC to the DAC and see if you get the “click”. If you already tried this, I must have missed it.

Thanks Daniel. Yes I did that - in a manner of speaking…

I don’t use JRiver. But I do have Logitech Media Server and Squeezelite running on a Cubox-I. Both that setup, and the RoonServer get all their music from the same network shared folders on my NAS.

I unplugged the NUC running RoonServer from my network (cabled, not wifi), then unplugged it from the USB cable to my DAC, and finally unplugged it from that AC outlet in my wall. Then I took the Cubox-I and used all those same connections (the same CAT5 cable, same USB to the DAC, and same wall outlet). Then I played the exact same music, but using the Cubox-I this time, and no clicks. No noise.

It’s pretty iron clad proof that the problem is somewhere with RoonServer, Windows 10, the NUC, or how they work together. Thanks for the suggestion though. It was about the first thing I did to confirm to myself that the problem was real, before I reported it.

1 Like

Hi Steve,
You may have checked this also but any chance Musical Fidelity have updated a drivee for Windows 10 ?

Andybob - I did do that. Thanks.

However I appreciate the fact that you made me remember something that had slipped my mind… The problem could ALSO be in the Windows DAC driver.

The driver(s) (both ASIO and WASAPI) are Win 8.1 drivers. No Win 10 updates released yet. Granted most 8.1 drivers are supposed to work in 10, that’s NOT the same as having an approved Windows 10 driver.

In fact, you can see at the top of this thread that this was moved from another thread. That’s because I was not even going to bring this up until I had a good set of new Musical Fidelity Win 10 drivers. However, I found a thread where someone - with very different hardware - had the same problem. So, thinking that it MIGHT be a hardware independent problem, posted the issue.

Sorry, long answer. Short answer, “No, no updated drivers yet”.


Sorry if I wasnt clear. What I meant was to use the NUC to play music with a different music player. Thus same hardware as Roon same connections, just a different playback software. Thus isolating the problem to Roon or to the NUC.

1 Like

Ah… Thanks Daniel. And apologies for being a bit thick. :wink:

As I understand it - having zero JRiver experience - your suggestion is to install JRiver on my NUC, plan on it using the same drivers, and THEN compare the sonic experience.

Without having researched what using JRiver entails… On the surface that sounds brilliant. Thank you!

Will definitely investigate that on the morrow. Your plan sounds like a perfect way to narrow down where the problem comes from. Thank you. :smile:

PS - I’ve been very clear in my documentation of this problem that its direct sonic impacts are minor. So I’d like to take this opportunity to say it’s not the minor changes I’m hoping will be corrected. Instead, I recognize that at a certain level, sonic impacts can be subtle - but important. If I can hear small clicks and noise, what other sonic impacts might WE ALL benefit from if the developers at Roon Labs can find the problem? For all we know… It could be a very important clue into significant sonic improvements.

Otherwise, why bother?

It’s GONE! :smiley:

Rather than installing JRIver, I shut down RoonServer, fired up the Groove Music app that comes with Windows 10, pointed t to my NAS, and started playing music. No clicks. No noise.

So I rebooted, and played the music that easily caused trouble previously… no noise. No clicks! Where did they go? I’ve got a reason, but I’m not sure how much sense it makes…

I changed my NAS.

My old Network Attached Storage devices were getting a little flakey, and running out of room So I a couple of days ago I bought a bigger, shiny new NAS, and copied all my music to it. Then I pointed RoonServer to it, and disabled its connects to the old NAS. And now the artifacts are gone.

I tested this, by going into RoonSever’s storage settings, and disabled the connections to the new NAS, and reenabled the connection to the old. And guess what? The noise is back. But now I know how to make it go away. :smile:

So I guess this can explain why there was no problem playing LMS on my little Cubox-i. It’s running on Archlinux, and clearly has a very different network stack than what on Windows 10 on my NUC. Why it would be responsible for these artifacts is anyone’s guess. Clearly something’s not right. But what? Both of my NAS’s are running some form of Linux, but the old one’s running a build that’s several years old. Maybe it does not behave as well with Windows 10 as the newer build on my new NAS.

With my problem now gone, my suggestion to anyone having similar symptoms would be to try moving a copy of the offending music to a different location, and see if the problem persists. For myself, I should have thought to move copies of the music to the NUC, or maybe to a directly attached USB drive. But that didn’t occur to me because I assumed - mistakenly - that since the Cubox-i pulled the music off the NAS just fine, the NUC should too. I guess not.

Well, all’s well that ends well. Thanks for the help everyone. :slight_smile:

1 Like

YAY!!! Glad you got it sorted.

But this doesn’t explain the difference you experienced with LogitechMediaServer / Squeezebox (same NAS ?), or am I “missing” some detail ?

Thanks Daniel! :wink:

And Roland… let me be clear, there was never a problem with the LMS/Squeezelite. And yes, it was on the same old NAS as the NUC/RoonServer. So it would make sense to think that if the NAS really was the problem, then LMS/Squeezelite should have had a problem too.

I’m going to go out on a limb here… but the only explanation for that that I can think of, it the possibility that since my LMS/Squeezelite runs under Archlinux AND that the old NAS was running some form of Linux, so they had similar enough implementations of their network stacks (and file access methods) that they did not run into trouble. And that further implies those same differences somehow caused an issue for RoonServer running Windows 10.

But that’s just my guess.