Clicking track tags on some songs opens incorrect tag page. [Ticket in]

Roon Core Machine

M1 macMini on Ethernet

Networking Gear & Setup Details

UniFi Dream Machine Pro SE with UniFi Access UAP-AC Pro

Connected Audio Devices

2 Raspberry Pi RAAT to S/P-Dif

Number of Tracks in Library


Description of Issue

  1. I noticed in b-884 the clicking area of the assigned tags is not correct on my iPad. In this example a click on Genre: Gothic leads to the list of tracks with Genre: Post-punk etc.

When playing Roon Radio I sometimes want to assign tags to the playing track.

But when I have already added that album via Tidal in the past that the album shows as not in my library. I checked if there are probably more versions, but that is not the case.

Re-opening that album shows it as added. See the two examples below.

First click:

After re-opening the album it is shown as it has to be with tags assigned:

Hi @Paulb

We’re sorry to see that you’re having a few issues and apologize for the delay in getting back to you.

Issue 1:

When you try to click the tag link on a different remote or on your Core do you still have this problem? Could it be that Post Punk is accidentally be clicked on the iPad by mistake due to their being several tags applied to that track selection?

Issue 2:

Can you tell us a bit more about the sequence of events that precede what you’re seeing here Paul?

The song plays on Roon Radio, then you…

This will help us take a closer look, thanks!

Thanks @jamie,

Issue 1
In the video (iPad 9.7 5th) I clicked on track 2 (2 tags) and track 3 (4 tags) in order of appearance of the tags.

Clicking on the tags on track 2 sometimes leads to the correct tag-list, track 3 with 4 tags never and always leads to the wrong tag list.

On my iPhone (12 mini) the same behaviour occurs.
On the desktop it is working fine.

Issue 2
I thought it happened on my desktop only,I’ll try to reproduce that issue tomorrow.

Issues 2
It happens when Roon Radio is playing.

I click on the album as you can see in the video and it looks like it is not my library (track 7 has been played 17 times).

I add it to my library and nothing happens. I Need to stop Roon twice, because my iPad is not recognised as endpoint the first time and then the album shows as adopted in my library as it should.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.


Why is this closed? I still have these problems:

Hi Paul,

I don’t know why or by whom but your last post in this topic has been marked as the solution, and then after a period of inactivity the system automatically closed the topic.

See image…

I’ve reopened it and merged your recent post.
Let me tag @support so they read this and follow up with you.

1 Like

Hey @Paulb,

I’m sorry about the confusion here, not sure what happened. Thank you for the assist @Carl! :pray:

Thanks for the videos Paul, those were very helpful.

Issue 1: happens primary on touch screen devices, but not on your desktop. Correct?
Issue 2: is pretty clear to me.

Let me touch base with the team on next steps and get back to you. Thanks again for your patience.

Hi @jamie!

Issue 1.

EDIT: I just saw it happens on my desktop too (MacMini M1) instead of my earlier answer.

Also on my mobile devices like iPad and iPhone. Even with 2 tags, see screenshot I don’t get the right tag-list. Clicking on the beginning (OCC) of the second tag (Occassion: Party) leads to tag Occassion: Friends.

Can I get an update @jamie?

More than six weeks ago I started this thread and I still don’t know nothing.

HI @Paulb,

Can you try something for me? Please try the tag links again for the track you posted above: Born Slippy to see if they still open the incorrect link page.

Then remove the tags, and reapply them. After doing so click the newly applied tags and see if the corresponding tags page is launched.

Please let me know what you see. Thanks!

Hi @jamie,

I tried that and those tags launch the corresponding page.

Don’t tell me to do that for the other tags. I have thousands applied over about 85 main tags.

Thank you for testing it @Paulb! I appreciate your effort and the update. I’m checking with the team to see if there’s anything they can recommend. I’ll be back in touch.

1 Like

Hello again @Paulb. We think we know what the problem is here. We’re putting in a ticket. :+1:t2:

Hi @jamie,

Ok thanks! Would be great if it is solved.

Hi @Paulb,

A fix for the tags issue you reported was included in our latest build. Can you install the latest build on all your devices and see if your issue is resolved, please? There could be a slight delay in the availability of the remote app in Apple store.

1 Like


As soon as it is available I will try it out.

1 Like

Hi @jamie,

Problem solved both in mobile, iPad and desktop!
Newly created tags also working fine.

Thanks, and compliments for the new bug fix cycle.

1 Like

Excellent news, @Paulb! Thank you for confirming! :pray: