Clicks and Pops on New 7i5 NUC

Not sure what I’m doing wrong here.

I was running Roon on my Mac mini - and all was well. But I kind of wanted my mini back - not in the middle of the stereo!

So I got a new NUC 7i5BNH from Amazon, with 8 GB, 256 GB M.2 boot drive. Flashed it up to the latest, and installed ROCK. I can see it on my network, restart it from a browser, and use a Roon Remote on my iPad or MBP.

I have the NUC on Wifi. But it has the music files attached to USB - I’ve tried a 256GB flash drive, and a 1 TB USB LaCie HDD. And it is plugged right into the USB input of an Audiolab M-DAC - the original one.

Backup restored fine, and music files are seen and working.

When the music was on the hard drive of the Mac mini, and the Mini fed the USB connection to the M-DAC, the sound was excellent. And the Mac mini was on Wifi as well. With the DAC direct attached, and the music files direct attached - surely Wifi or wired makes no difference.

But now with the NUC replacing the Mac Mini, I have constant clicks or pops - almost one every couple of seconds.

Any ideas? Something I should know about NUC USB config?

(Also have to say - very disappointed at fan noise from the 7i5 NUC - almost constant.)

I know you restored a backup,but, check to see if there is audio analysis going on.

I think it shows here if that’s happening ?

By the way - in case its relevant - I’m playing ALAC files - and have installed the ffmpeg codec from

When I google “audiolab M-DAC linux” the results are not good. The easiest thing to do seems to be to install Windows on the NUC then run Roon there.

As for fan noise, you can check out Akasa Newton S7 fanless case.

1 Like

Interesting! I’ll check out both of those - thanks!

I would run on a lan cable first before installing windoze to ensure it’s not the nuc’s WiFi signal…WiFi is such a troublesome tech for a music server more often than not

1 Like

If you can, test the NUC wired. I have read elsewhere here about a lot of Wifi issues. Not an expert, but if you can wire it, do so.

I have the exact same machine, I also just bought it to move off a Mini. I run WIN10 on it and Roon core.

When trying to use it as an endpoint, I experienced the same clicking and popping. Wired or WiFi doesn’t matter; I tried both. I changed my endpoint to am SMS-200, although an RPi or Allo would have been just as good. With the change the pops and clicks stopped.

I conclude the USB ports on the NUC are sub-par. It is disappointing as it requires yet another device in the chain, which I was trying to avoid.

Oh yeah, before someone brings it up, I tried with music files on both a NAS and a local USB attached drive.

Interesting, I’ll test out on my 7i5 and see if I get the same.

Guys, you’re doing something wrong. I’ve had a NUC 7i5BNH for a year now running ROCK, and feeding multichannel via HDMI, and it’s been rock-solid.

So far, I’ve done the wired test and still much the same for clicks and pops.

Made myself a Windows home 64 USB key and got the download license - so that’s the next experiment :frowning:

After that - if still broken - it seems I could try inserting an endpoint, or trying a new DAC. JOY.

Does make me wonder about the Nucleus - you’d think it would have this same problem. Is it no good as an endpoint as well? Or would it simply dislike feeding an M-DAC (original version)?

So many options - so little time for pure audio enjoyment …

Off to try the windows experiment. At this point I suspect Peter Lie has put his finger on it, but we’ll see :slight_smile:

I guess you’re saying using USB instead of HDMI is what’s wrong?

It won’t make a difference.

OK, so I plugged in an Audioquest Dragonfly into a USB port, and that also works perfectly. Tried it with FLAC 16 and 24 bit, MQA 24 bit and DSD64 files. All fine.

Like to know what it is then. Any ideas?

I’m thinking some NUCs, by paticular device not model, have less then acceptable USB ports.

Let’s see how the OP makes out.

Oh yeah, before someone offers it up, all my drivers are up to date.

Just thought of one other thing, I upsample to DSD256.

No idea what’s going on with your NUC, but I suspect that Peter is right concerning the sub-par Linux driver for Michael’s DAC…

1 Like

Hmm, we’ll see. I don’t use linux.

So before I report - let me say - while it’s nice to document this for anyone for whom it may be useful, it may be that my experience is just my experience, and not universally relevant!

That being said - I’m now the proud owner of Windows 10 Home - burned it to a key formatted as FAT32 using this link - the only way that actually worked to make it from a Mac (and have a NUC be able to boot it). Then imaged up the NUC - and now I have a real live Windows 10 PC for my first time - I’ve always run it for software testing within Parallels. I can now clean that off my MBP! :slight_smile:

Connected up the music external LaCie 1TB drive via USB-C (an advantage for Win-10 on this H/W over Roon OS BTW). Set it up on the local Wifi. Inserted it into the Stereo system (with monitor, ugh - and Mac wireless kybd/trackpad) - had it chew through my paltry 5000 tracks - then it was time to listen and see if it was all worth it … Connected to the Audiolab M-DAC it drove my restored Celestion Ditton 25’s like a trouper! Year of the Cat gave a Cheshire grin and rejoiced in its excellent imaging and clarity :slight_smile:

So for me at least, I think the truth seems to be that the original Audiolab M-DAC does not like a linux USB feed. And as a dedicated Cupertino fan who diarizes every Keynote in advance - I have to give brownie points to Redmond here - the codecs and USB feed out of Windows 10 are if anything better than those from the Mac - the sound is everything I could have wanted. More than I could have imagined, really - so I celebrated by signing up for a Roon lifetime :slight_smile: (on top of the CDN$165 for a Win10 license - sigh)

All that’s left is perhaps to move to the fanless case at some point.

Thanks very much to everyone who chipped in - what a great, active community you have here!


You are a lifer now Michael! So it’s ‘we have here’. Welcome!

1 Like

Please confirm you’re using Windows 10 built-in USB audio driver, not another driver installed separately.