Clock displays wrong time after update from legacy to 2022.11.2

My legacy ropieee setup on rpi 3.b with touch screen displayed the correct time for 2 years.

This morning I upgraded to 2022.11.2 and my clock is off by -1 hour. I have changed the time zone to different locations in my time zone (Europe Luxembourg). But still the same result.

This makes me think I am missing a setting somewhere…

Any ideas anyone?

Can you send me feedback?

Setting the timezone should be enough…


I did some more testing…
It seems the time display is stuck on the time it displayed right after the first configuration of v. 2022-11.2. :

  • Timezone selected was Europe Amsterdam
  • Display showed GMT+0 (which -1 hour for the timezone selected)

Since then I have tried several other timezone selections. Some related to my actual location and some random selections. Each time I first [Save] the new value and then run [Configure] before checking the time. I even rebooted a couple of times. Warm & cold reboots. No change in the time.

I followed the boot sequence and I see no error messages, also not when the system syncs time.
I only get a “under voltage detected” warning with a yellow lightning bolt in the middle of the boot sequence. But this does not stop the process. I use the standard RPI 3.b power supply.

Let me know if you need more info.


I guess, with sending feedback @spockfish asks you to click the button in Ropieee’s advanced tab, as in my screenshot below, and then paste the identifier string into your post here.

Here is the feedback code : 99ca8bd402e77489

Thanks for pointing trust out.
I will repost directly to Harry.

Here is my feedback code : 99ca8bd402e77489

A couple more observations:

  • The uptime displayed in seems to be stuck on 6 minutes.
  • The screen saver timeout is set to 10. But the screensaver does not activate.

Both these are also related to time. Coincidence?

I’ve got the same RPi model and don’t experience what you’re seeing.
I’d suggest you reflash your SD card…

Double checking my last observations before starting from square 1.

  • Uptime is now updating. No idea why.
  • Screensaver works. Previously I was waiting for it to start from the default state (toggled) being ROON display. Screensaver (i.e. time display) will only auto activate if it was first toggled and ROON display was activated by playing a track on the linked endpoint.

So, only one problem: displaying the correct time for the time zone selected.

I’ve just tested this here and it works like it should. Not sure about Luxembourg (as it it the same time as in NL), but trying other timezones it works as expected.

So… what do you mean exactly with ‘off by -1 hour’?

Regardless of which time zone I select the time is stuck on GMT time (= NL time-1hour). I tried several random time zones and followed instructions for SAVE and CONFIGURE.

Hello Harry,
My time display issue remains.
After double checking everything it basically comes down to the fact that the timezone setting has NO effect on the time being displayed. Regardless of the timezone chosen, the displayed time is always GMT time which is -1 hour to Luxembourg time.

As I seem to be the only one reporting this issue, I don’t think there is an issue with Ropieee. So the cause must be with my setup (network). But I am running out of ideas on what it could be.

This is my setup:

  • Recent router (FritzBox 7590)
  • Roon Core installed on InnuOS Zenith MK3 running version 2.2.5 in Squeezelite mode
  • RPI 3.b with 7" touch screen + FLIRC reomote receiver, connected to the network over WiFi running Rpopieee
    ** Before upgrading to Ropieee 2022.x, the legacy version was running flawlessly and displaying the time correctly.
    ** When I upgraded to Ropieee 2022 (2022.11.2. V. 661) nothing else in the above setup was changed.

I tested with Ropieee in wired and wireless mode. Same result on both: GMT time is displayed.
All devices in the network which have a time setting are setup to auto update over the network and all of them display the correct time: GMT+1.

I did another feedback dump. The code is: 85ce7fd2fc8cf3d8

Any ideas?

Thanks in advace.

Do you have DHCP option 101 (timezone) setup or something like that?

Not sure where I should check this.
On router the Ropieee is set up to receive a fixed IP address. No DHCP. It has been like that since I installed it with the legacy version.

I found this setting in the FritzBox.
Screenshot 2022-12-27 at 12.02.42

But this setting was not changed

Hmmm… your network does provide an NTP server (I expect the router itself:
I also see that your configuration is still on ‘dhcp’.

This is also the difference with the ‘old’ RoPieee version: it does not support this functionality with providing your own NTP server(s).

However, it requires your router to be in UTC. So I suspect it is not, which results in the wrong (local) time.


OK - We are getting somewhere.

In practical terms, what do I need to change?

  • On the FritzBox: Turn off “Make FRITZ!Box available as a time server in the home network” ?
  • On the Rpopieee: ???

I would suggest this. Let’s first see if this makes a difference (I expect so).

OK - I turned this off and applied the setting.
Then I rebooted the Ropieee, but still GMT is displayed.