Collection and audio devices disappeared from Linux Core

(Marcel van Tilburg) #1

Today when trying to access Roon from tablet it connects to server, but all my music is gone. Both file locations say ‘watching for new files in real time’. All audio devices are also gone. Please help!

Running Roon Server Core on:

Ubuntu 18.04.2 LTS
AMD Ryzen 7 2700x 8 core processor x16
16GB memory installed

(Noris) #3

Hi @Marcel_van_Tilburg,

Can you please provide some more info here? Where is the library stored, is it on a NAS, internal drive on the Core or an external drive? Can you share a few screenshots of how your Roon Settings -> Storage tab & Roon Settings -> Audio tab looks like from the tablet? Have you tried rebooting both your Core and tablet to see if that helps?

– Noris

(Marcel van Tilburg) #4

Hi Noris,

Thanks for the quick reply! Library is stored on two internal drives on the Core. Both can be accessed without problem with file browser. Both locations are still intact in Roon settings, but as said, waiting for new files. Audio tab from tablet is completely empty. Home screen from tablet shows 0 albums, 0 files et cetera. Have rebooted Core and tablet and also tried accessing Roon with smartphone, all to no avail. Yesterday it all worked fine and I didn’t change anything in the meantime. Am now away from home, but could upload screenshots in a few hours. Thought I let you know already…

(Marcel van Tilburg) #5

(Marcel van Tilburg) #6

(Marcel van Tilburg) #7

(Noris) #8

Hi @Marcel_van_Tilburg,

Thank you for sharing those screenshots!

Can you please let me know how you installed Roon on that PC? Did you use the EasyInstaller mentioned in our Linux Documentation or did you use a piece-wise install?

We can also try using a fresh database to see if it will help with this issue. Instructions for doing so are as follows:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart/Reinstall Roon to generate a new database
  • (optional) restore from the backup made in step 1

Can you give that a try and let me know if it helps with the issue?

– Noris

(Marcel van Tilburg) #9

Hi Noris,

I installed it using the Easyinstaller. I should go get some sleep now, but tomorrow evening I could try your suggestion, but I also lost the audio devices. Are you sure this will also be solved by this method?

Many thanks and kindest greetings,

Marcel

1 Like
(Noris) #10

Hi @Marcel_van_Tilburg,

There is no guarantee that it will resolve the issue, but it is the next step here that we should try.
If things are still not working as expected with a fresh database then we will have another good data point for this issue and will eliminate one variable.

– Noris

(Marcel van Tilburg) #11

… couldn’t resist trying to repair over breakfast. Everything went as expected and could use most recent backup. During setup I also could select all audio devices. Only after finish and restart it gave the message below and it seems to be exactly as yesterday: empty database and no audio devices…

(Noris) #12

Hi @Marcel_van_Tilburg,

Sorry to hear that the issue is still occurring after starting fresh. I have a few further suggestions here:

  1. Can you please send me your Logs from that Core? You can use these instructions to get them over to me.

  2. Can you perform a disk check on the Ubuntu Core? Often times when issues like this occur, we have traced them back to a hardware issue, so it will be good to start checking this aspect.

  3. Similarly, you may want to run this tool to check the Core’s RAM to make sure it is intact.

– Noris

(Marcel van Tilburg) #13

Hi Noris,

Here’ s a wetransfer to the zipped logs: https://we.tl/t-iTU5fLMRJT

Am now looking in to the other two things and will let you know!

Best wishes,

Marcel

(Marcel van Tilburg) #14

this is the result of fsck


I’m no expert, but I guess something is wrong?

now waiting for memory check…

(Noris) #15

Hi @Marcel_van_Tilburg,

Thanks for submitting that log file, I do see error related to the database but I will need to consult with the QA team on how to best proceed, I will be sure to update you after my request reaches their queue.

I have not previously ran a disk check in Ubuntu, so this might have changed. Ubuntu’s documentation mentions that you can also perform a disk check by using the following steps:

  1. Open Disks from the Activities overview.
  2. Select the disk you want to check from the list of storage devices on the left. Information and status of the disk will be shown.
  3. Click the menu button and select SMART Data & Self-Tests…. The Overall Assessment should say “Disk is OK”.
  4. See more information under SMART Attributes, or click the Start Self-test button to run a self-test.

Can you give the disk check a try that way instead?
Do let me know the results of the memory check after that completes as well.

– Noris

(Marcel van Tilburg) #16

Disks seem okay:
Operating system (fsck via ubuntu live) :

Collection 1 (after self test) :

Collection 2 (after self test) :

Memory check takes longer than expected: 40 minute for first pass. 5 minutes into 2nd pass it found 6 errors. Can you believe this: this memory is not even 1 year old!


I broke it off to do the fsck first and let you know. Will now start over an give you complete report. Any suggestions for trustworthy new memory?

(Marcel van Tilburg) #17


Did only 1 pass and it found 17 errors. This is the summary. I wouldn’t know to interpret it. Am I in trouble?

(Marcel van Tilburg) #18

(Noris) #19

Hi @Marcel_van_Tilburg,

Thank you for sharing those screenshots!

Generally, we can’t make recommendations regarding which brand of RAM to use for your specific Core, but you may want to take a look at a few reviews online before deciding on one and also make sure that it is compatible with your motherboard type.

Based on your screenshots above, this does appear to indicate that there are some hardware issues with the RAM so my suggestion here would be to replace the RAM, confirm that it properly passes the RAM test and then verify if Roon is performing as expected afterwards (and possibly start with a fresh database once more).

Do let me know how it goes and if there are further issues after correcting the RAM hardware aspect, please let me know.

– Noris

(Marcel van Tilburg) #20

Dear Noris,

Thank you for your advice. I am having a hard time convincing retailer to replace my RAM. I will not give up but I was wondering if in the meantime the log files I sent were already analysed?

With kindest regards,

Marcel

(Noris) #21

Hi @Marcel_van_Tilburg,

Sorry to hear about the issues with the retailer. As for your question, you will have to replace the failing RAM modules before we can continue with troubleshooting your Roon installation.

In an environment with corrupted system memory, it’s impossible for us to say with any certainty what issues are caused by the corrupted RAM vs. any possible issues with the Roon installation or configuration.

Malfunctioning system memory can cause issues with everything from file system integrity to program instruction execution. Because of this, we cannot trust the Roon Core logs to accurately reflect the state of the Roon database, nor can we trust the Roon Database itself.

– Noris