Connect a Nucleus to a Synology DS216 NAS share

Roon Core Machine

Roon Nucleus - with internal Samsung SSD 870 EVO.
Windows 11 Computer with Roon app.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

For two hours tried to have it connect to a Synology DS216 NAS … no luck … powered off the Nucleus and then powered back on now I can’t get back in … keep getting a message saying I am already logged in and hit the back button.

Running me in circles … is there anywhere to get live real time support …?

I demo’d an Aurrender last week and was literally up and running in 5 minutes … I can’t figure out what is happening with this Nucleus - HELP !!!

Is this a screen that also has an “Unauthorize” button on it? If so, just click that and it will resolve the glitch.

Thanks Geoff … clicked “Unauthorize” and finished the set up and updates

The Nucleus still can’t find my NAS … I click add folder and get a “choose folder” screen but my NAS isn’t there … click add network share and ente rthe infor from my Synology NAA app but keep getting “Unexpected Error: Invalid Network Path” … Synology says my info is correct …isn’t there a way I can get my drive to show and then simply click on it ?

Can you post a screenshot of the Roon “Add network share” screen where you add the details for the shared folder of the NAS?

You’ve only entered the host name; both host and share need to be added, e.g., \host\share.

\host\share\MegaMusic … still didn’t work but we are getting closer – LOL

\MegaMusic\host\share … didn’t work either but the warning drooped “unexpected Error”

You need to substitute host and share with the values for your setup. It would seem that host=MegaMusic. What folder contains the music files?

Further to the observations from @Martin_Webster, since you are using a NAS, you should probably also use the smb://host/share form of the network address. See this article:

Um. If you have installed an additional drive in the Nucleus, is this where you intend your music files to live? If so, I don’t understand why you want to configure a watched folder on the NAS. Do we understand correctly what you are trying to do?

(… and apologies if I’m missing the point entirely)


Ok … Roon found my NAS and is scanning … for the record it was simply MegaMusic/Music … I guess it is simple when you know how (or when you know folks that know how) - Anyway playing music and sounds good - Thanks everyone !!!

Now to Andy’s point about where I want my music to live - In the add NAS directions it sent me to the add network share so I thought I was copying the files from my NAS to the SSD and it would establish a link so when I update the NAS it updates the internal SSD - I take it that is not what I did … or did copy them to the NAS with an auto update link ?

Most people go the other way around, i.e. add to internal drive and backup to NAS.

If you don’t want Roon to access files on your NAS, then you don’t need that in Settings==>Storage.

The music on your internal drive is accessed by Nucleus Internal Storage (something like that. I use ROCK, so I don’t know the exact name for Nucleus) entry in Settings==>Storage. That is given to you when you have an internal drive connected. You don’t have to add it.


Nucleus exposes a network Share. Use another device to copy your music there. Here’s mine on WIN11. You want to copy to the ‘InternalStorage’ folder. -


No. But you aren’t the first, and won’t be the last…

Roon will be busy analysing your files on the NAS and building your database. It won’t (by design) change or move anything. If you have a huge set of files, it might take some time because it’s having to work across your network, but it will get there.

I’d probably let it finish, and listen to some music in the meantime. The additional internal drive in the Nucleus is probably a ’better’ location, but it will likely work fine from the NAS. You can migrate your files when you are ready; several ways to do it, the knowledge base explains better than I could, but if you want to avoid repeating the analysis stage, take a backup of the database when it’s finished importing.

This has been a painful process

  1. So I understand there is no real time support - The knowledge base documents have conflicting info so it’s better to post a message here and wait for replies
  2. The current advice is wait until Roon analyzes my files that I shared from the NAS - Make a back up in drop box - Kill the shared folder then drag and drop the music folder from my NAS onto the Roon home page …???
  3. Wouldn’t it be easier to uninstall and start all over …

I suggest, in addition to DropBox, you consider the NAS your Backup.

If you’re not going to put the NAS in Settings==>Storage (and really all that has to be there is the internal drive), then there’s no need to do any analysis until you put the files on the internal drive.

No. You want to reinstall the OS on the Nucleus? Don’t do that.

Roon isn’t difficult, but it is different, and doesn’t necessarily work the way you might expect. I’m sorry it’s been painful. I think it’s worth persevering…

  1. Yes. Support is this forum. Roon staff will see yours posts and respond, but problems are often solved by users who’ve seen the problem before.

  2. Well, that’s more or less what I’d do, except I’d probably make the backup locally on the NAS, and use file manager to copy the music files - I think drag and drop into the Roon window might be a bit fraught. Copy the files before you tell Roon to look for them.

  3. Starting over is an option, but as @xxx says, don’t uninstall the Roon OS. Starting over might take longer, but is probably the ‘sure’ way and avoids backups and restores for now. You should set up database backups once you’re sure you’ve got everything running to your satisfaction though.

Already have my NAS is a mirror back up - The knowledge base says drag and drop is preferred but reading various articles in the forum a lot of folks agree with you that it doesn’t work

I’m ready to kill the share folder then move the files from my NAS to the Nucleus and see if that works … to be honest the hassle of trying to get this operational is wearing thin - It’s been to many hours without success … maybe if it get working I’ll think better of Roon

opps … double posted reply… ignore