Connecting Cabasse Pearl to Roon (via Airplay)

Hi @benjamin,

It’s me again, Walter - same topic as before.

After having a chat with the Cabasse support, they told me, that to enable the Airplay-functionality, I need to use an iPhone and the home app, as referred in your knowledge base article. Most important information to do this was, that this is a one-time-action only, so after having done this exercise, it should work with Roon… so far so good, in theory. The only problem: After step 5 in your knowledge base article, unfortunately there is an additional step “to enter your PIN” – and I couldn’t find a way to disable this request page in the home app, and I don’t have a PIN either. So the process stops and that’s it…

And after asking the cabasse support again, why they are requesting a PIN, they told me, that the request to use the home-app in iOS and to enter a PIN is coming from Roon-software, not from the device…

So I come back to you once again - what I need to do, that it will work?
Any idea what to do to overcome this problem?

And seriously: Why isn’t it possible to have some kind of default configuration in Roon, that even a PIN isn’t needed, or just a default PIN is set, so that the installation process has a chance to work without using an iPhone (as with me, as I’m using Android only), or that by using an iPhone, the PIN to type in would be written somewhere… Or do you have maybe a QR-code to work with the home-app?

Please check, maybe with your development team, how to overcome this issue - and to get the pearls working with Roon as well…

Thanks
Walter

This is the previous relevant thread.

Hi Martin,
thanks for adding at least the last part of recent conversation. And as stated, I tried it with the iOS-device, but as described, it’s not working either…
That’s why I started again this thread to continue…
Thanks
Walter

The previous thread is relevant since it includes details of your setup. The upshot is that you device isn’t Roon Read, and therefore can only use Airplay.

Roon will see an Airplay device under Settings > Audio, and this should be enabled before use. Roon does not require a PIN to use Airplay.

However, from the previous thread, it seems that you first need to setup the Pearl to use Airplay. Please see the post by @BlackJack.

Hi Martin,
what shall I say… I’m using an i-phone, and a PIN is required… No PIN, no progress - and setup of the pearls in the home-app is stopped…
Where do you find the airplay-device not activated? Going to settings - audio, there are 2 devices (Diele-Marantz and Cabasse Pearl), both with airplay, and both active…and a lot of intel PCH HDMI-“devices”, not enabled. But I guess it’s not about these HDMI-devices…
If this initialization procedure with an i-phone is needed - not nice, but even this is not working - I’m really sorry…
Thanks again
Walter

What happens when you select Cabasse Pearl, and play music?

This doesn’t seem to have anything to do with Roon, but please share a screenshot.

I don’t know how you see this, but as an Android user (information from your other thread), your current issue with setup, the limitations of AirPlay in general and that it seems the people working for Cabasse don’t know what they talk about (my concerns about the content of the help page in the other thread, your answer from support from this thread), I think that you were much better off using some bridge device to connect your Pearl(s?) to Roon for the time being (unless you need the ability to group with other AirPlay devices). Maybe at some point they might become Roon Ready, then you can still decide to drop the bridge and connect directly.

I’m sure a not too expensive RaspberryPi based solution could be found that suites your use case best (analog or digital or even network output to your Pearl). As I don’t have real experience with such bridges, other users may be able to provide you with suggestions in this regard. It might be helpful for potential helpers though, to know which model of the Pearl you have / what inputs are provided.

Hi,

It’s not clear, to me at least, which application you’re seeing this on … to aid Roon support can you take a screenshot of and upload it to this topic.

1 Like

Hey @Walter_Dreher,

Thanks for getting back in touch. In regards to the issue with inputting a PIN, see if you can first enable airplay password from the home app. That way, it’ll prompt you to input a password rather than a PIN.

As a backup for the PIN, you could always test inputting 0000 or 1234!

Let me know how the above goes :+1:

First: Thanks for your comments. Let me answer…
@Martin: In which application? Within the home-app of iOS, after selecting the pearl the PIN-request pops up. In Roon, I can select the Pearl (it’s an active player), pressing the play button, green dot appears - and that’s it. No Playback, no progress in the progress bar (only this animated sign in the player list shows, that music is playing - but it’s not…).
As said, According to Cabasse, the pearls are not requiring a PIN for Airplay - and you are stating, that Roon doesn’t require it as well - but in the home-app of iOS, it’s requested, and that is in contradiction of your article in the knowledge base…

@Blackjack: Of course I’m using my Pearls in stead with the cabasse-app - and yes, I thought already about a RapsberryPi solution (digital outputs direclty to the optical input of the pearl) - and yes, sure this will work, but it’s not as it should do. The pearls should be compatible with Airplay, and Roon should be compatible with airplay - and as said already, with other devices in my network, this works (e.g. Marantz streaming client with roon - no problems with airplay…). So it should work…

@Carl: It’s on the home-app of i-OS, running on a i-phone. And pop-up comes after step 5 of your guidance in the knowledge base article

@benjamin: For the PIN, 0000 I tested already - rejected. 1234 I will do (will take some days maybe, as I am not at home for a week - so please don’t close this chat, if I don’t give an answer immediately…).
In the home-app I searched for any options to maybe disable this PIN-request, or doing somethin different with it - no success, unfortunately. I couldn’t find anything towards that functionality… And it seems to me, that only numbers are allowed, no characters - at least, I’m only able to type in numbers…

As said, I will be off now for a week - sorry. I’m happy to give it a try again after my return…

Thanks again
Walter

@Walter_Dreher, please explain what this means.

Hi Martin,

I didn’t know either and asked @Walter_Dreher to post a screenshot (still waiting for that)…
I did a little Googling and found this… seems plausible but needs @Walter_Dreher to confirm.

Hi all,
Now attached the screenshots of the iPhone. I tried different ones, and all the same… The pearl is listed in the device-view, but as next screen the PIN request is coming up…
Hope it helps…
Walter

Hi @Walter_Dreher,

Thanks for the screenshots (of the Apple Home App).

I also had a read of the Roon’s Knowledgebase article … as you say there is no mention of PIN numbers, so I’m wonder if something has changed with Apple’s Home App since that was written.

I’m struggling to see how this is related to Roon application as at this stage the communication (to set up Airplay) is between the Apple Home App and the Cabasse Pearls … so I don’t really understand this comment from Cabasse support …

… that the request to use the home-app in iOS and to enter a PIN is coming from Roon-software

Let me tag Roon’s @support team to see if they can shed any light on this.

In the meantime, I wonder if you have tried downloading the Cabasse STREAM Control app, maybe there are setup options which would help.

I also found this … but again there’s no mention of PIN numbers (note Roon only supports AirPlay 1).

https://cabasse.happyfox.com/kb/article/67-airplay-2-with-the-pearl-collection-products/

In addition to @Carl’s post, this Apple Support Q&A may help. It explains how to reset the code if you have forgotten it.

https://discussions.apple.com/thread/8026060

1 Like

Hi Martin, Carl,

thanks for your comments.
I will try this PIN-reset procedure. We will see…
But maybe the SW-version is the root cause for it? Maybe there is an incompatibility between AirPlay1-servers and AirPlay2 devices? Cabasse told me, that they are happy to have it programmed with full AirPlay2-support… maybe that’s the reason?
The cabasse app I’m using as well - and no, there are unfortunately no special settings for AirPlay - at least I couldn’t find anything (and support confirmed, that there are no settings for…).
I will proceed investigating…
Thanks
Walter

Currently, only Apple devices can serve music using Airplay 2. Software such as Roon can only serve music with Airplay 1 (a reverse-engineered Open Source library.)

Many third party, i.e., non-Apple, devices can receive Airplay 2 streams.

Hi @Walter_Dreher ,

Were you able to resolve the issue? Did you manage to find the culprit? One other suggestion if you’re still having issues here - you can try to play to the iOS output and then use the iOS device as a “Bridge” between Roon and the Cabasse. Not the most ideal method, but I wanted to mention this option in case you are still having issues with the regular setup.

2 Likes