Connection issue

I have a Sonictransporter Audiophile where the Roon core resides. I use my MacPro as a remote. This morning I rebooted my Mac. After that, I lost connection to the ST. I go to and it displays the IP address of the ST. Fing on my iPad also confirms that the ST is at that address. Yet if I click on the IP address, it says it can’t connect. Roon does not see the connection. I cannot connect to the server through Finder.

Powered the ST on and off, makes no difference.

I can’t say that rebooting the Mac somehow caused the problem, but it was working fine yesterday.

Thoughts on what might be going on?

Here’s an update. If I plug the ethernet cord directly into my router, I have the core on the ST. The problem is that for some reason if I do that, I lose most of my connected audio devices. If I plug the ST back into my network hub, I lose it.

However, yesterday it worked on the network hub, so what would cause it to not work today?

Hi @soyka0120 ---- Thank you for the report and sharing this observation with us.

Just to make sure you and I are on the same page here :innocent: based on your feedback with the ST connected to your switch the MacBook will not connect but your audio zones are available. If you connect the ST to your router the audio devices are unavailable. Is the MacBook able to to connect when the ST is connected to the router?

I know we had looked into a similar behavior previously in this thread and as such have a few more questions:

  1. Since noticing this latest behavior have you again confirmed the IP address being assigned to the MacBook? If the MacBook cannot reach the ST via finder my assumption is that the IP is not in the same range as the ST. Please confirm.

  2. Besides the mentioned switch (LUXUL AGS 1016) are there ANY other networking devices in play? Kindly describe in detail your network configuration/topology.

  3. Being as we mounted the ST to the switch last time and the issue returned may I kindly ask you to verify what the experience is like with the switch temporarily removed from the chain of communication.


Thanks for following up Eric. After I rebooted the Mac, couldn’t connect to the ST, which was connected to the switch (IP address Worked fine up until then. So I connected it directly to my router again (new IP address 192…168.0.32). Except then I lost my DirectStream/Bridge ii connection, and oddly some others that reappeared upon further experimentation in turning everything off and on. Then I reconnected the DAC/Bridge directly to the router instead of to the hub, and I can see it now on Roon.

What’s equally weird is the saw the IP address of, but when clicked on it, said nothing was there.

So in a way it’s fixed. Though I wonder why any of this should have happened.

Ah computers, great when they work, not so great when they don’t.

Oh, just went back and looked at roon. It no longer sees my Sonos zones.

I missed the details of your network setup but there appear to be 2 different subnets involved here, and which would account for your issues. Is there possibly a second device, connected to the switch, acting as a router?

Hi @soyka0120 — Thank you for the follow up!

I would still be curious to know if there are any other networking devices at play here besides the mentioned switched. Furthermore I did some research on the LUXUL AGS 1016 and according to the Luxul website that switch is capable of doing VoIP:


I am wondering if this could be causing the issue here. Brings this thread to mind.


Hmm, so I looked at the LUXUL diagram which seems to indicate (though it isn’t exactly clear) that if you connect the switch to a router (in my case and Apple Express that runs my in-house wireless network) it should be in the first position (meaning top left). Why that would make a difference and why it hasn’t made a difference before, I dunno. In any event, the Apple Express was not connected there. So I reconnected the Apple Express to the top left ethernet, reconnected the ST and DAC to the switch. Powered everything off, disconnected my router, then powered back up. Everything now seems to be as it should. Fingers crossed that it stays that way.

Thanks for looking up the switch. My AV installer put it in, so I didn’t think twice about it other than that you plug things into it.

Hope I don’t have any further updates, but perhaps this at least might help someone in a similar situation. Again, thanks for the quick response.


So this is weird. I took my laptop with me out of my home office and as is my custom I manually disconnect hard drives connected to it. For some reason (I won’t do this again) I ejected the sonicorbiter as well from the network. Come back plug everything in, and there’s no sonicorbiter on the network. Take the ethernet cable out of the switch and plug it directly into the modem, it’s back on line. Put it back into the switch, it’s gone (even though it was working there quite well before) Have to plug the DAC directly into the modem for Roon to see it as an audio zone.

So okay it’s working, but this behavior seems odd to me. Regardless if anyone has any ideas of what might be going on, thought I should contribute it to the Mystery of Networking file.

Over the last few days behavior has been erratic. Lost power a couple of times, and zones have appeared and disappeared. To clarify my previous post, I have an Apple Extreme plugged into the LUXUL switch. Right now I have Sonos Connect and my DAC plugged directly into my modem, which Roon currently sees, but not my Dragonfly connected to my MacBook or my Squeezebox device, both of which used to show up no problem when my core was on the MacBook and at times on the ST. The software version on the Extreme is 7.7.9. I’ve seen where some Apple networks have reverted to a previous install to correct network issues. Could that be the issue? @support

Hi @soyka0120 — Thank you for update and flagging us down here.

In regard to the MacBook with the Dragonly mounted to it. Are there any active firewalls or antivirus applications currently running on the device? If there are please temporarily disable these features and confirm if this action yields a change in behavior.

Furthermore, where is core currently being hosted? You mentioned that the core is on the MB at times, and at other times on the ST.


There are no firewalls or antivirus programs. The core is on the ST, with the ethernet connected directly to the modem, not through the LUXUL switch. As is my PS Audio Dac/BridgeII, which is the only audio source Roon is recognizing. Interestingly, the Sonos Connect is also directly wired to the modem, but Roon isn’t seeing it. But it has at other times. Just powered the whole system down and then up again, Roon only sees PS Audio DAC/Bridge II.

When the Roon Core was on my Mac, never had any problem finding any source, and the mac is connected to the network via wifi.

Thanks for trying to help with this.

Thanks for touching base with me @soyka0120, appreciated! A few things moving forward regarding this issue…

  • Are there any devices at this time that are currently connected to the Luxul switch that are not appearing in Roon?

  • In you post above you mentioned the following:

    Right now I have Sonos Connect and my DAC plugged directly into my modem, which Roon currently sees, but not my Dragonfly connected to my MacBook or my Squeezebox device, both of which used to show up no problem when my core was on the MacBook and at times on the ST.

    • Just to be clear now the Sonos connect is not being identified by Roon as well as the MacBook with the Dragonfly attached, correct?

    • My assumption is that you are using the MacBook as either a Roon remote OR a RoonBridge. Since noticing this behavior with this device have you tried reinstalling the application on it?

  • You note that you had “lost power” a few times. Did these issues pop up after that had happened?

  • Please provide the IP addresses being assigned to your devices.


Here’s the latest. I powered everything down, connected the ST and PS Audio Directstream DAC/Bridge II ethernet to the LUXUK switch. Now I have all my zones back, except one.

Sonos Connect 192.168.14
Sonos Amp 192.168.6
The above are a grouped zone
Airplay (airport)
PS Audio DAC/Bridge II
Dragonfly (connected to MacBook Pro) 192.168.11

The ST is

The only device that doesn’t show up is a first generation SonicOrbiter that has Squeezebox emulation The device is plugged in via USB to the DAC. I bought this because the original Bridge I in the DAC was such a piece of crap–since upgrading to the Bridge II (which is vastly improved) I don’t really have much need of the Sonicorbiter. Still, it seems odd that it isn’t being recognized. I have checked yes for Enable Squeezebox support, so that shouldn’t be an issue.

I am using the MacBook (and my iPhone) as the Roon Remote. (My iPad, alas is too old).

The original issues actually started to pop up after acquiring the ST and moving the core over to it. Never had a problem seeing all my zones when the core was located on my MacBook.

For the last few days everything has been running as it should. The loss of the Sonicorbiter is not a big deal, hardly use it anymore but it is curious that it isn’t being recognized.

Thanks for the assistance.