Consistently losing connection with Sonos speakers

hi @support

I am experiencing the same issue. here is my logs zip:

[Link removed by support]

I am running Roon version 1.5 build 354
I am running OSX 10.13.6
I am using an iMac 2015 3.2 GHz Intel Core i5, 8GB RAM
Music is stored on the internal iMac hard drive

I am consistently losing connection with my Sonos speakers (“Roon lost control of the transport device”). Today it was the Play:5 in my Bedroom.

Thanks for reaching out, @Matt_Cuttler!

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Do you have other SONOS devices besides the Play:5? If so, what devices? Do all of them experience this behavior? How often does it occur?

Are you making use of a SONOS Boost device?


The iMac has wireless connection with a Netgear Nighthawk router.

I have a Play:5, a Sonos One, a Play:1, and a Sonos Connect.

All of the Sonos devices are experiencing the drop out behavior with Roon. Never with the Sonos app.

I am not using a Sonos boost device.

Thank you for the info, @Matt_Cuttler!

How often would you say this occurs?

I’d like to propose a test that will help us rule out some possible causes for this behavior. Can you connect your Core machine and one of your SONOS devices via Ethernet instead of WiFi and let me know if there is any change in behavior here?


Hey @dylan

Finally got a chance to hardwire both the iMac and a Sonos One speaker via ethernet. Same exact error “Roon lost control of the transport device”


Thank you for giving that a try, @Matt_Cuttler.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hey @dylan

Do you want me to also do this test hardwired via Ethernet or does it not matter?


Hi @Matt_Cuttler,

If possible, yes, please test with a wired Ethernet connection.


hey @dylan

error occurred at 9AM EST Sunday. please let me know what’s next…


Thanks, @Matt_Cuttler.

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

1 Like

Hi @Matt_Cuttler,

Thanks for your patience here while we have been investigating this. I spoke with the team about the analysis of your diagnostics report and have some next steps here. The team has enabled some additional diagnostics tools that should give us some more information about the behavior you’re seeing.

May I ask that you please reproduce this behavior once more and let us know the time that the error occurs. We will enable diagnostics once more from there so the team can take a look.

hey @dylan

I am now unable to reproduce the error via wired with local files or Tidal streaming currently. I will try to experiment with the wireless speakers now.


with wireless, same error now happened at 7:26 AM EST.

Hi @Matt_Cuttler,

Thank you! I’ve enabled diagnostics once more and will pass the report along to the team once it comes it. I’ll be sure to update you ASAP when I receive their feedback.

btw, I was experimenting and experiencing zero drop-outs with Airplay, which I did not try previously. only using the Sonos protocol. seems like an easy solution for now.

Hi @Matt_Cuttler,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link.

hey @dylan

here is a new logs zip:

I just caused the errors to occur again, wirelessly, at 8:49AM and 8:50AM EST.

thank you!

Thanks, @Matt_Cuttler!

I’ve passed the logs along to the team. I’ll update you as soon as I’ve received their feedback from the analysis of the logs.

Hi @Matt_Cuttler,

Thanks for your patience here while we have been investigating. I spoke with the team about their investigation here, and we are hoping to get a little more data. We were hoping that once more you could reproduce this issue and reply here with the timestamps. Once you’ve done this I’ll enable diagnostics and get them over to the team to aid in the investigation.


Hello @Matt_Cuttler,

I wanted to check in with you here and see if you have had a chance to follow Dylan’s instructions and provide some new timestamps. If you are still experiencing this issue please let me know some timestamps so that we can enable diagnostics mode.