Crackling/Popping with multichannel DSD playback

Core Machine (Operating system/System info/Roon build number)

Intel NUC8i7BEH running Roon ROCK Version 1.0 (build 254) production

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
500/500 fiber → Firewalla Gold router → Ethernet Cable → Roon Core on ROCK on NUC

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

All music content files are on a 8 TB WD external HDD attached to NUC

(1) NUC → HDMI → Marantz AV7704 → Emotiva amp


I’m getting crackling/popping on playback of my ripped DSD multichannel files. The DSD is of course converted to PCM by Roon. That’s fine by me, and is how I’ve been using Roon for 3+ years. Multichannel DSD is 90% of my listening, and has worked fine for 3+ years (no pop/crackle). However, for a variety of reasons, I have not listened to much music (and no mch DSD) in a couple of months. Now (noticed since yesterday) every mch DSD album I play has the crackle/pop.

From my testing aimed at ruling out a number of possible causes, I have determined that:

  • There is no crackle/pop on non-DSD music played from Roon, including multichannel (eg, wav)

  • There is no crackle/pop when playing the source SACD (physical disk, in an SACD player) via the same PrePro and amp and speakers

My hypothesis: The Roon DSD → PCM conversion is doing something that generates audio artifacts.

@support – can you help, please? – thanks

@otinkyad, I moved your post to the Support category.

@Robert_F – OK, thanks! I’m never sure what category to post in.

1 Like

Please share the DSD signal path.

@Marian – ah, yes, sorry, I meant to do that

It seems there is sufficient processing speed, so that should not be an issue. My next suspect would be the channel mapping. It’s converting from 5.0 to 5.1, so it has to come up with the extra LFE channel. I don’t have a surround output to test this, but I think it should be possible to turn off channel mapping and let the receiver do the mapping.

To check for possible clipping due to DSD → PCM conversion, called inter sample overs, set “Show clipping indicator” (1) and watch signal path star (2) for red flashes when it occurs, then enter increasingly negative values for “Headroom adjustment (dB)” to remedy that.

Good catch from Marin, but conversion to PCM shouldn’t be a problem with clipping.
What I’ll do (if the headroom adjustment doesn’t help):

  • disable DSP volume → set volume control to fixed
  • try 7.1, because some AVRs have problems with the the 5.1 settings from Roon

It can be a problem. Some DSD tracks go over 0dbDSD (i.e. over 50% modulation), so if you have a +6dB gain set on the conversion, it would bring some samples over 0dBFS and cause clipping. However, clipping should not cause clicking and popping. I tried an offending DSD track earlier with a +6dB gain and a zero headroom, as Marin suggested, and the indicator did show clipping, but I wouldn’t have been able to tell it happened without it.

I’ve seen it flash red without audible signs as well, and I remember reading a Roon support post mentioning that even single sample overs are shown by the indicator.

I also had clipping indications where I’d call the audible effect as clicking and popping, as well as ones that sounded as if a voice coil grinds it’s way along the motor gap with a screeching sound, and then worse than that even…

Many thanks, @Marian @Marin_Weigel and @Burkhardt_Petermann

Will test these ideas systematically and report back. (Pretty sure I already have the clipping indicator set to on, but will check – and will monitor the indicator, which I don’t think I did carefully).

What puzzles me though is that (a) I have been able to play the same exact ripped files using the exact same setup without any issue for the last 3 years, without headroom management etc, and with the same exact signal path, and (b) I am 99% sure that there have been no hardware or software changes to the system in the last several months. No firmware updates to the AVR or amp or NUC, no connection changes, no speaker changes.

That’s what leads me to suspect that whatever has changed is on the Roon end (various Roon/ROCK updates in the last couple of months – there’ve been some big ones for each of Roon and ROCK).

Of course, (1) I may be missing something that has changed in my setup other than Roon, and (2) even if the issue is due to something that has changed on the Roon end, Roon can hardly be expected to freeze their code, and so things necessarily will change, and so (3) it still makes plenty of sense to try the excellent suggestions from all of you!

OK, thanks again for all of the suggestions, all. Here’s an update:

Hmm… I wasn’t able to find a 5.0 setting in Roon (only 2.0, 5.1, 7.1) , and it’s not listed as an option at

I was expecting this idea would do it, but: No red flashes at all when the clicks and pops occur…

Adjusting headroom didn’t have any effect either (presumably because there’s no clipping, at least not according to the Roon indicator)

Neither of these helped …


Thank you all again for the troubleshooting help so far… Any other suggestions would be very welcome!

(I have one other idea, which I will try and report back).

@support - any ideas on this, please?

1 Like

I have the same problem with DSD converted to PCM. It happens only with 5.1 and not with stereo. The core is a NUC 8i5 as is the endpoint which outputs HDMI. The crackling and popping only occurs in the surround channels, not the fronts. It is an intermittent problem, but once it start it seems to persist throughout the listening session. I usually just change to PCM albums. I suppose I just use dBpoweramp to convert all the DSD albums to PCM, but that would be a big job as I have well over one hundred of them.

@Newton_John – interesting.

Yes, I think the crackling I get is also in the surrounds (if you count the center channel as a surround – there’s definitely crackle in the center) – will examine this more carefully.

How long do you think you’ve had this? Is it your impression (like me) that this is only following recent Roon/ROCK updates…?

Also: Is your music stored on an HDD or SSD, and internal or external…?

Probably not the issue. But do not allow 32 bit output. Set max word length to 16 bit or 24 bit output. HDMI does not support 32 bit audio.


I don’t have a centre channel as such, but would expect my processor is redirecting it to the stereo pair so I should hear. Unless I am just losing the centre channel for some reason. Possibly spread over two speakers at the front is less noticeable.

I have had the problem for some time, but it seems a lot worse now. I think I’ve had to a small degree since I added surround channels around this time last year. At first, I put up with the issue. More recently the surround DSD are unlistenable and I worry about damaging the speakers.

I have the surround files on an external HDD. All my stereo files are on an internal SSD. The size of the surround files meant there is not enough room for them on the SSD. I tried adding one surround album to the internal SSD. The problem still occurred with that album.

Thanks for this. Could you give a quick pointer on how to set output to be a particular bit depth? – my searching around for how to control this has not yielded any info. TIA.

Right, since I encountered this two days ago, I’ve been hesitant to play those albums (which are 90% of what I like to listen to) for the same reasons.

Hmm… there goes my bright idea that I was optimistic about (of moving music storage from HDD to SSD).

It’s in device setup - limiting to 24 bit that is

@Newton_John – thanks!

@WiWavelength – no need to reply!