Crashing while playing 192kHz

Same problem here:

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus (Roon Server Software Version 1.8; build 790)
Operating System: Version 1.0 build 227

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Fritz!Box 7590 router (2 months old) on glass fibre WAN with 300 Mbit/s (this value is achieved regularly, verifiable by speed test). Nucleus connected to Fritz!Box 7590 by short ethernet cable. All connections between router and audio gear by ethernet cable CAT6 or higher. No switches in signal path. Only one SOtM CAT 6 filter.

Fixed IP addresses for both NUC and Amethyst.

2 other network branches and 2 switches have already been removed for test purposes.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon Nucleus and Trinnov Amethyst (Serial Number 309, Version, RAAT SDK Version 1.1.21) connected by ethernet cable. Preconfigured Roon input on Trinnov. Max. possible buffer size in Amethyst configured (4096 samples).

Build in SSD in NUC.

Qobuz Studio Premier HighRes streaming up to 24 bit / 192 kHz as primary source.

Description Of Issue

Since January or February 2021 I have the following problem: If I stream highres files with 24 bit / 192 kHz from Qobuz via the NUC, the playback stops after a while (between 10 minutes and 1.5 hours). The Roon Server software on the Nucleus crashes and restarts. This also occurs when there is no further network traffic in the house (at night or when nobody is in the house).

The RAAT server also stops and restarts.

The problem does not arise

  • When playing highres files from the SSD built into the Nucleus
  • When playing back files in CD quality from Qobuz

Highres files with 24 bit 192 kHz require a theoretical bandwidth of 24 bit x 192,000 1/s x 2 = 9,216,000 bit/s. Even if double the data rate were required due to a communication overhead (i.e. 18,432,000 bit/s), then just approx. 6% of the existing WAN bandwidth is used.

I already tried the following:

  • Reinstall Operating System on Nucleus
  • Shutdown NUC and unplug mains

Does anyone have any idea why the Roon server crashes in the NUC?

Log files can be downloaded from my Dropbox. Song played during crash: Just One More Day - Otis Redding at timestamp 05/08 07:10:20

Any ideas?

During the last couple of days, iI moved the Roon Core from Nucleus to my iMac. After finding all the music files and finishing indexing and analyzing, I made it play a Qobuz playlist with 60 recordings with 24 bit /192 kHz in continuous playback. This worked well until after about 24 hours the playback was interrupted.

After that, I redefined the nucleus as the Core. After file search, indexing and analysis, I made it play the same Qobuz playlist in continuous playback. Also after about 24 hours playback stopped and the Roon Server software was restarted.

Is it possible that setting up the database from scratch has any influence in the ability to playback Qobuz highres files?

Hey @Klaus_Dakena!

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can. Just wanted to say thanks for the detailed information and to let you know this has been escalated to our technical team. They’ll get back to you directly with next steps.

1 Like

Greetings @kirsten,

I continued examining the issue and disconnected the internal SSD in the Nucleus so that really no computing power is wasted on analyzes. Last Tuesday I played the Qobuz playlist with the 60 24bit / 192kHz songs again. It played in endless mode without interruption until I myself interrupted playback after about 25 hours. While playings back my wife was in a 2 hours video conference and my son played video games over the web. Worked as a charm!

The next day I wanted to continue the test and play the list again. Before that I updated to Roon Server 1.8 build 795. And … every few minutes the Roon Server software crashed and restarted. I then restarted all my network components, including Nucleus, Trinnov Amethyst, Fritzbox, Switches, Airport Extreme and TimeCapsule. Since then I am able to play hires files again and at the same time (after having connected SSD again) have the Roon database analyzed with several cores without interruptions.

What happened in build 795?

Problem solved? Hopefully, but not shure.

Nice dream! Yesterday Roon Server crashed three times within one hour, even with 96 kHz/24 bit.

Any ideas?

I don’t know if your situation is exactly the same, but In a related post, it was confirmed that there’s a memory leak issue.